Posts by Mario77

    So I updated a RPi 3b from LibreElec Addon from 9.0.2 to 9.1.002 and it starting acting weirdly...went to safe mode many times and got over 2000 crash logs in a week..

    Addons don't respond and couldn't connect in any way to the Rpi.

    Main error I could see in every log is this :


    Code
    1. 2019-08-03 11:20:34.362 T:1937531456 ERROR: failed to create window surface (EGL_BAD_NATIVE_WINDOW)
    2. 2019-08-03 11:20:34.362 T:1937531456 FATAL: CApplication::Create: Unable to create window
    3. 2019-08-03 11:20:34.720 T:1937531456 ERROR: eglSwapBuffers failed (EGL_SUCCESS)
    4. 2019-08-03 11:20:34.720 T:1937531456 ERROR: Exception in CApplication::Cleanup()

    This is a headless Rpi being used as a TvHeadened server with RPi TVHat attached..

    Only addons installed are VNC,Tvheadend Server/HTSP Client and Emby4.


    Please understand this is far away from my home so it's bit hard for me to try certain things.


    Any Help appreciated..

    More Logs HERE

    On the updates menu you will have to change update channel from 9 to 8 first to see old versions...

    What kind of problems are you having if i may ask?

    Today CVH compiled latest tvheadend server 4.3 if you want to try

    Good idea but that's still a script to me..plus all you have to do is install libreelec tools addon and it will work with a small script via gpio anyway...on/off speed control etc...tested and works fine

    I can confirm this too although not sure what went wrong exactly as my Rpi is 3500km away..all I have installed on it is Tvheadened server....emby server4 and VNC server..

    Tryed to update to 9.1.002 from 9.0.1 trough VNC and lost connection and couldn,t connect anymore...

    After getting my inlaws to get an old monitor and connect to the Rpi to see what went wrong just found out it was stuck on Safe Mode and just needed a reboot altough VNC did need a force update to start again..

    Yes, that's my final thought, too. During the updates an analogue setting maybe got lost. Analogue output is not a very popular feature.

    I use analogue output a lot connected to an old Dvd Surround Sound System and audio is normal as when playing dvd's..

    I always leave the audio setting ON to both analogue and hdmi audio...then when I need to use the speakers just mute the TV.

    Press that plug in as far as you can till it clicks.

    Are you sure it's not a driver issue and audio outputs are working and recognized properly?


    ssh to your pi

    Code
    1. aplay -l

    check if device 0 analog is available..


    If you get the error no sound card detected (not sure if it's a bug or something changed in LE9) add this line to config.txt

    Code
    1. dtparam=audio=on

    Restart and go back to LE menu where you change audio output...now you can see more options to choose from namely ALSA default driver analog/hdmi or both


    Hope this helps you in some way..

    A small fan seems to be the most effective solution, you don't even need a heatsink. However I find all small/cheap fans to be junk with low-quality bearings which will not last very long. Of course, you can buy high quality fans like Noctua but they are too expensive to justify on a RPi.

    Cheap fans are not that bad...I got a 4cm one from china on my Pi2 connected on the 3.3v and it's completely silent...been On for over 2 years..still going..although it's not always On....it just goes on above 55c so when rpi is idle it's OFF...

    If I remember well you shouldn't enter anything in host/port/user/pass etc if you'r using a non Foscam Camera..

    Infact those settings should be greyed out when you choose generic.

    Pan and tilt and motion detection they only work for Foscam too altough it was around a year I used that addon last so things might have changed..follow their thread on Kodi.tv..

    All you have to enter in that category is the snapshot or video feed url..

    There is a <filename>guide.xml</filename> by default meaning that wherever the executable is, the xml will be written there.


    I got my guide.xml, where im lost is where to set in TvHeadEnd where to get that guide.xml

    So probably guide.xml should be in the same folder of WebGrab++.config.xml

    Are you using TvHeadend the normal version from Libreelec repo or the docker version?

    In the normal version you just point to the guide.xml from the tvheadend addon settings and you enable the Internal Xmltv Grabber from Tvheadened UI.

    The docker version I never used sorry so not sure if it's the same or you might need to make some script/cronjob to make it work..