[8.2.3.1] LibreELEC 8.2 for S905/S905X

  • Sure this has nothing på do with libreelec on S905/S905X - you should learn to google and read.

    I gathered you currently have a DVB-T USB dongle working perfectly with your TV Box to accept local free-to-air (FTA) US TV channels here in the US? If so, I sure would like to know which city and/or state you are in. The reason I asked this is because I know a DVB-T is the DVB European-based consortium standard for the broadcast transmission of digital terrestrial television used in EU countries while ATSC standard is largely a replacement for the analog NTSC standard and it is a set of standards for digital television transmission over terrestrial, cable, and satellite networks used mostly in the North America, i.e. Canada. Mexico, and United States. To support what I said, please see this DVB-T USB dongle digital television sticks do NOT function in the United States, Canada, nor Mexico video (circa 2012) and/or this post (circa 2016). If you and/or anyone here can confirm a DVB-T, especially a DVB-T2, USB dongle that works with a TV Box running on an LE 8.1.x to accept FTA US TV channels, then I would like to get one of the DVB-T2 USB dongle to work with my S905 TV Box running on an LE 8.1.x to watch local FTA TV channels.

  • I never had /storage/.config/samba.conf, only samba.conf.sample, no problem with 8.0.2e on my Odroid C2 ! But with the 8.1.2 build, i can't access to my Windows shares... I tried to create a samba.conf manually but no effect !


    An idea ?

    Same here.

  • I see 2 main changes:

    * new line: netbiso name = %h

    * changed line: security = share instead of security = user


    Why did it change and could this be the reason?

    LE 8.2 changed to Samba 4.6. I'm afraid I cannot help with the version change as I don't know what changes it brings.

    Is strange the physical ports are all USB 2.0 in my boxes (beelink and mecool), but lsusb reports a USB 3.0 hub. There must be available on the board but unpopulated.

    Maybe some developer can explain more in detail this.

    If I remember correctly, S905X and S912 use USB 3.0 controller stripped down to support only USB 2.0 - at least only USB

    I have a question about the video pipeline of these AmLogic port of Libreelec, mainly because I am following the Amlogic mainline effort.

    I understand that Mali OpenGL is used for the sceen rendering (GUI, ecc...), but what's the hardware decoding framework? Is it Mali itself providing it, or providing some sort of wrapper on the VPU?

    Or there is some standard framework, like OpenMAX, VAAPI, VDPAU, etc...?

    Amlogic uses in-house designed VPU for video decoding. It is not supported in mainline Linux kernel. There are plans to implement V4L2 frontend for it.

  • Quote

    Kahio wrote:

    I never had /storage/.config/samba.conf, only samba.conf.sample, no problem with 8.0.2e on my Odroid C2 ! But with the 8.1.2 build, i can't access to my Windows shares... I tried to create a samba.conf manually but no effect !

    Simple fix:


    ssh to the box: edit the file "nano /storage/.config/samba.conf"


    Delete the entire [global section] and replace with the following


    Reboot and everything should work as it did before.

  • Hi Kszaq,

    My device is Khadas Vim 2/16.

    Fresh 8.1.2 build, from this thread, wouldn't boot (with kvim device tree from this build).

    There is installed 8.0.2e on internal of the device.

    Can you help, please?


    Thanks.

  • I am also "fighting" to install kszaqs 8.1.2 on my VIM Pro EMMC, at least I can use it from external drive, with balbes150s device tree, but do not try to install on EMMC because it will stop working...


    Device tree and more info here:Bring the build to libreelec community - LibreELEC - Khadas Community

  • I will look into KVIM issue (and other reported issues as well!) as soon as I can. I'm currently dealing with some much more important stuff than LE development. :(

  • Hi,


    I was on LE 8.0.1l since a few moment.

    I put both LE 8.1.2 img.gz and the new gxl_p212_2g.dtb (renamed to dtb.img), as it specified on the update folder then i rebooted my box.

    New version was detected, installation OK.

    I try if everything is operational and seems OK.


    Thank you very much for your work :).


    Mike

    Beelink MINI MXIII II (S905X) 2GB/16GB

  • Just a little question (and sorry for my english):

    With the old version, when the box booted, i saw the KODI started page.

    Now, it's a black page between the libreelec logo and the KODI home menu.

    Someone know how can i restore the KODI started page?

    Thx

    Beelink MINI MXIII II (S905X) 2GB/16GB

  • Since 8.2 smb mounts to my windows10 machine won't work anymore.

    I also can't browse smb, it only gives ..

    With the 8.0 version I didn't have any problems.

    Funny part is, doing manual mounts, all works fine (password less account) .


    As workarround I created a /storage/.config/autostart.sh file


  • I will look into KVIM issue (and other reported issues as well!) as soon as I can. I'm currently dealing with some much more important stuff than LE development. :(

    Thanks for your work on this project. I hope things are work out OK for you

  • Since 8.2 smb mounts to my windows10 machine won't work anymore.

    I don't use Samba shares myself, but I'm pretty sure I have read here (numerous times) that the newer builds require a Samba password.

    If you are not using Samba passwords then the obvious fix would seem to be to start doing so (or use a different method of file access by your media box)

  • I don't use Samba shares myself, but I'm pretty sure I have read here (numerous times) that the newer builds require a Samba password.

    If you are not using Samba passwords then the obvious fix would seem to be to start doing so (or use a different method of file access by your media box)

    Ok, but as you can see mounts can be made to a windows10 machine without the need of a password. As I interpret this, it's a limitation in Kodi, the way it does the mounting stuff. It has nothing to do with samba versions, because the mounts do work if you make them at Linux level.

    It's also strange smb browsing doesn't work at all in the 8.2 LE. In the older version, I could simply browse my network and every samba share (both windows and unix like) would pop up, and I could add them to my list like that.

    I can make mounts to my Linux server and Dreamboxes without any problem. Only Windows 10 does not work.

    I also played with the maximum smb version setting, it doesn't make any difference.


    ps. an account with password also fixes the problem, but I still can't browse for smb shares.

    I use advanced sharing in Windows 10, I just added an account called kodi with password with read only access to my share permissions.

    Edited 3 times, last by gjstroom ().