Intel NUC, kodi on 4K is limited to 30FPS

  • Hey, I am running LibreELEC on a intel nuc that is capable of outputing 4K at 60FPS with a TV that is capable of showing 4K 60FPS. both units have hdmi 2 or 2.1 ports. On 4K I cant get higher FPS than 30. is there a limit on the linux drivers or in kodi? Thanks

  • Wait... Intel made more than one NUC ?!?

    Providing a kodi.log file would make things much easier. :)

  • Quote

    18:41:22.109 T:139972188337408 NOTICE: Disabled debug logging due to GUI setting. Level 0.

    Not a debug log.

  • I am having the same issue on a new Vizio M65-E0 tv. I am curious, what tv are you using. I see Sony in the log but not the model number.

  • Your log is reporting [email protected] as the maximum:


    Code
    1. INFO: ID:0x48 Name:1920x1080 Refresh:60.000000 Width:1920 Height:1080


    For a recent NUC I would recommend a community build with the latest and greatest kernel / display driver stack. Try mine or Milhouse's.

  • they both have a hdmi 2.0 port. even tho one of the sites stated only 1.4 for my TV but it seems that a firmware upgrade enables 2.0 on older models. I do have a updated system. but will keep looking for bugs if I find something wrong with the setup. TV and the NUC only have hdmi. no display port :/

  • Try adding the modeline manually via xrandr.. it wouldn't be the first time the Intel driver had a bug!

  • I have been looking around for good instructions on using xrandr but do not find anything that explains it good enough for me to really give it a try. Do you have any example by any chance.

  • Thank you very much for your help. Used the code but with DP1 instead of HDMI1, no errors but did not give me the 60hz refresh rate. I do have the same nuc as BoKKER. I also installed windows today to make sure I was not crazy and to make sure bios and firmware were up to date and was able to get 3840X2160 @60. I included a pic below.


    I have also attached a link to my log. NSZY


    Also here is the xrandr command I tried


    LibreELECnuc:~ # xrandr --output DP1 --mode 3840x2160 --rate 60.00

    LibreELECnuc:~ # xrandr

    Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767

    DP1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 1430mm x 800mm

    3840x2160 30.00*+ 24.00 29.97 23.98

    4096x2160 24.00 23.98

    1920x1080 60.00 59.94 30.00 24.00 29.97 23.98

    1920x1080i 60.00 59.94

    2880x480 60.00 59.94

    1280x720 60.00 59.94

    1024x768 75.03 70.07 60.00

    1440x480 60.00 59.94

    800x600 72.19 75.00 60.32

    720x480 60.00 59.94

    640x480 75.00 60.00 59.94

    720x400 70.08


  • I did install windows today too to check that there it works. too bad I did not see your post. It would have saved me a few hours. I added 60 fps 4K with xrandr but I always end up with the


    xrandr: configure crtc 0 failed


    error. I tried to tweak it but I did not manage to get it work.

  • I did not get any errors when I ran the xrandr command from above, but no changes either. Did you change HDMI1 to DP1 from the example above from Chewitt?