Librespot addon

  • Hast Du denn evtl ne Idee, was bei mir schief laufen könnte, bzw. was für Infos bräuchtest Du noch für eine Einschätzung?


    edit:

    Es scheint daran zu liegen, dass bei ALSA Device kein Eintrag vorhanden ist. Die Auswahl aus dem Wizard wird jedoch nicht übernommen und die manuelle Eingabe verschwindet auch nach kurzer Zeit.

    Due to a change in Kodi 18 (LibreELEC 9), the wizard only displays devices, but does not fill the field anymore. Fill the field manually.

    @

  • Hast Du denn evtl ne Idee, was bei mir schief laufen könnte, bzw. was für Infos bräuchtest Du noch für eine Einschätzung?


    edit:

    Es scheint daran zu liegen, dass bei ALSA Device kein Eintrag vorhanden ist. Die Auswahl aus dem Wizard wird jedoch nicht übernommen und die manuelle Eingabe verschwindet auch nach kurzer Zeit.

    Unter Kodi 18 wird die Auswahl aus dem Wizard nicht übernommen, die musst du manuell eingeben

    @

  • There is a problem in CoreElec again.


    If librespot is activated, you cannot switch live TV channels (TVHeadend) anymore. The screen is black and TVHeadend seems to be crashed.


    CoreElec 8.95.0,

    librespot 111,

    TVHeadend is 4.2 9.0.115,

    TVHeadend HTSP Client is 4.3.4.2.


    It seems to be independent of the audio settings of librespot. It occured as well with ALSA and Kodi audio mode.

  • I have seen an Odroid_C2 running this configuration without interference between Librespot and TVHeadend.


    What system and tuner are you using? Also, provide logs.

    @

  • I have seen an Odroid_C2 running this configuration without interference between Librespot and TVHeadend.


    What system and tuner are you using? Also, provide logs.

    It is CoreElec latest, and Tvheadend server running on my server. Let me know what to enable in Logging and I will send you the logs.

  • I have seen an Odroid_C2 running this configuration without interference between Librespot and TVHeadend.


    What system and tuner are you using? Also, provide logs.

    Here is the log: https://paste.ubuntu.com/p/9kryssjjfr/


    Odroid C2. It is not working on previous version of CoreElec.

    If Librespot is enabled, then LiveTV can be started, but can't switch channels. If STOP is pressed, then complete freeze. Don't know what can be the problem, I hope you can help to resolve it. Thanks.

  • awiouy Do you see something in the two logs that might help to resolve this long standing problem? Let me know if you need any further help from our side. Thanks.

  • Revision 111j requires Kodi 18 alpha 1 or more recent.


    In addition to the previously mentioned improvements, revision 111j solves issues with TVHeadend zapping and with settings changes and a big meh...

    gurabli please confirm that this fixes your zapping issues.


    For RPi2

    - Addon: https://drive.google.com/open?id=1h0gtkk2stk4vpkpxgnsvsrizy5knw6a5

    - Code: Commits · awiouy/LibreELEC.tv · GitHub


    For Generic

    - Addon: https://drive.google.com/open?id=17c2athb6qlvnwxmdbfsimpmg3iexpjnq

    - Code: see RPi2


    For CoreELEC

    - Addon: https://drive.google.com/open?id=1cswcla4tkitdpriepptnrvfnl23jo721

    - Code: Commits · awiouy/LibreELEC.tv · GitHub

    @

  • Wow, so much thanks!

    I will check revision 111j once I'm home and report back!

    I can test the CoreELEC version on Odroid C2 now, I'm not using RPi atm (actually yes, but an official LibreElec build with Kodi v17, where librespot works fine with TVHeadend zapping).

    kaibenn I believe he can test it on CoreElec on Wetek Play 2.

  • Wow, so much thanks!

    I will check revision 111j once I'm home and report back!

    I can test the CoreELEC version on Odroid C2 now, I'm not using RPi atm (actually yes, but an official LibreElec build with Kodi v17, where librespot works fine with TVHeadend zapping).

    kaibenn I believe he can test it on CoreElec on Wetek Play 2.

    Here, I am able to continuously zap through my 100+ channels of my Odroid_C2.

    The librespot addon was sending a systemctl stop command each time TVHeadend switched to a new channel, which killed the system.

    Now, the librespot addon only sends a such command when the system.d service is active.

    @

  • Here, I am able to continuously zap through my 100+ channels of my Odroid_C2.

    The librespot addon was sending a systemctl stop command each time TVHeadend switched to a new channel, which killed the system.

    Now, the librespot addon only sends a such command when the system.d service is active.

    I can confirm that you have fixed the problem with CoreElec and Librespot (on Odroid C2)! So much thanks, your work is really much appreciated.

    I installed 111j and zapping works perfectly with Librespot service enabled.


    Some remarks&feedback:


    - selecting Kodi as audio device: artist, songs, etc is correctly recognized, but playback starts somewhat slow, and time displayed is not correct. For example, if I pause playback on phone, time keeps going in Kodi (music is paused). Even lyrics are recognized, but are out of sync (actually not working) since the time elapsed is not correct. I don't really care about these functions, I just wanted to report back. I use Librespot 99% with TV switched off and only AVR on.


    - selecting ALSA now works perfectly, the wizard enters the selected playback device. In ALSA mode playback is instant, seeking is instant, it is perfect. Of course, there is no artist/song information in ALSA mode, therefore no lyrics (bad for Karaoke fans) :) I use ALSA, as I said, use AVR with TV turned OFF for music.


    I will continue to use it, should I encounter anything, I will report back. Again, so much thanks for your great work!

  • Thank you awiouy!


    her my comments, after a short test.


    I seems that the problem on CoreElec with TVHeadend and librespot is solved on my Wetek Play 2. At least I have switched several times between both, switching channels,... Looks good!


    The ALSA mode works good now good as well.


    The Kodi audio mode has worked in the past better than the ALSA mode, but currently it does not work for me The spotify app on my phone is playing, but I hear nothing, And also see no song info.

  • I have noticed that sometimes switching mode from ALSA to Kodi breaks Kodi playback and requires a reboot. This is on my todo list.

    @