WD TV Live remote


  • I am using the community build with retroplayer integrated.


    Thanks for the info!


    Just checked the git tree, that build seems to be mostly on 8.0.0 so the rc_maps.cfg functionality isn't available there.


    No need to run any other tests, everything's clear to me now, just keep your autostart.sh for the time being.


    so long,


    Hias
    [hr]


    If I understand you correctly, then loaded/not loaded kernel keymap shouldnt interfere with ir-keytable -t / evtest results.


    Yes, exactly. The only thing that matters is the enabled protocol(s) (changeable with ir-keytable -p).

    Quote


    So I am back on the start, why the heck I am not able see any input from any remotes which I tried :)


    That was probably just bad luck, try some other remotes :)


    If it makes you feel better: did a quick test, checked with my (older) Panasonic TV and Denon amp remotes and they didn't work with ir-keytable either. My Philips VCR remote worked fine though, could even see codes from the jog/shuttle control :)


    so long,


    Hias

    Edited once, last by HiassofT ().

  • Ok thanks HiassofT


    Will there be changes in 9.0? It's too bad that there wasn't a simple addon to setup program and configure a remote without having to make all the files and read dozens of web pages and a noob who is non-linux in nature could figure out. The tutorial above did the trick, but it's far from user friendly.


    I am still struggling to get my games to work. Some do some don't.
    I have 2 Wii games... able to get them to run, but can't figure out the wii remote things. with lots of digging was able to get them to sometimes connect automatically, just not work in the games.


    It's a work in progress. I am learning lots.


  • Hmm, then I will give up for this time I guess. I did my best. Thank you for the help, I learned something new. Thanks god we have lirc on board, which is not picky at all :)

    2x VIM3L, 3x X96 Air P3, 6x C2; 6x RPi2; 3x Win7 Kodi + vPeter's mariaDB plugin as Library DB

  • I'm trying to add a button to my Logitech config using this process. I've got all the scan codes and event codes into a file but when I run the test, I get an error


    LibreELEC:~ # ir-keytable -c -w /storage/.config/rc_keymaps/logitech -t

    invalid other

    Invalid parameter on line 1 of /storage/.config/rc_keymaps/logitech

    Invalid parameter(s)

    ir-keytable: -w: (PROGRAM ERROR) Option should have been recognized!?

    Try `ir-keytable --help' or `ir-keytable --usage' for more information.

    Try `ir-keytable --help' or `ir-keytable --usage' for more information.

    Old keytable cleared


    My remote protocol is reported as "other" & "rc-6". I got no codes from rc-6 but "other" gives the codes.

    I tried rc-6 and got the same error. I've attached my table. Have I done something wrong?

    logitech.zip

    Thank you.

  • Your "logitech" file uses DOS-style line-endings (CR LF), change that to unix style (LF only) and it should work.


    so long,


    Hias

  • Ah. Damn. I used Notepad ++ to do it on a windows machine. Usually works fine. I'll check it out.

    Thanks for the advice.

  • That solved that issue. Notepad ++ defaults to dos endings on new files. No errors with that now.


    I can't seem to find the correct events to do what I am trying to do.


    1 - I have a button "Guide" on my remote that I would like to open the OSD EPG as a global event. I've tried KEY_EPG & KEY_PROGRAM but they don't seem to produce the correct result.

    2 - I have a button "Menu" that I would like to bring up the home menu. I think this is just a case of switching full screen video to the background instead of foreground?

    3 - Button "Recordings" I would like to open my TV recordings.


    Do you know any way to achieve these things? I used to do it in OpenELEC with lircmap.xml & remote.xml files.


    Thanks for your help.

  • For 1 and 2 I'm using this:

    buttons mapped to KEY_EPG and KEY_HOME in keytable.


    In oder to get the EPG working I use the following Lircmap.xml


    Code
    <lircmap>
        <remote device="devinput">
            <guide>KEY_EPG</guide>
        </remote>
    </lircmap>


    The linux input events translated by eventlircd will show up as "devinput" lirc events in kodi.

    As for 3: that should be doable with mapping a button to KEY_PVR - that should map to <recordedtv> in the default kodi keymap for devinput and will then bring up the window via this entry in the default kodi remote.xml

    Code
    <recordedtv>ActivateWindow(TVRecordings)</recordedtv>


    so long,


    Hias

  • Ahh. Cool.


    Didn't know if that was gonna work here. Guess it does.


    I'll just use my old files from OpenELEC and all should be good.

    Thanks for the help.

  • Fantastic! I got the EPG & TV recordings working. Thanks for your suggestions. Unfortunately, the KEY_HOME button doesn't do what I want. If I use that, it simply toggles Video (OSD) but I sort of got it working. Setting it as KEY_BACKSPACE sort of gives me the functionality I was looking for.


    Now I'm trying to create a shortcut directly to Movie playlists & Music playlists.


    I can't seem to find the correrct name for those. Again, I had it working in Openelec but my old remote,xml used to work with these lines

    Movies -

    <movies>ActivateWindow(MyVideos)</movies>

    And Music -

    <music>ActivateWindow(MyMusic)</music>


    These just opened the library but I was hoping to point them to the relative playlists and can't seem to find the correct entry to use.


    Thanks again.

  • Ah, yes, you are right about KEY_HOME (<start> code in kodi). The global section maps that to PreviousMenu, but in FullscreenVideo it's changed to OSD.


    Not 100% sure about the window names, have a look here for the list of Window IDs: Window IDs - Official Kodi Wiki - the links to Keymaps and Action IDs at the bottom of the page might also be worth a read.


    so long,


    Hias

  • Cheers. Thanks for that info. I was trying to find the correct id's in that link but none seemed to work.


    They are not that important so I guess I'll just play around with them. You helped me sort out the important ones.


    Cheers.

  • Keers HiassofT i was stumped, as the wiki hahdnt been updated. ive made a basic link to your post, you montion you will be posting a wiki guide, good! In your post #2 with the guide, 3 bits you could add,

    1 - put dtoverlay=gpio-ir in config.txt (and have lirc disabled)

    2- watch out for line endings in keymap

    3- reboot at end of your guide for it to work with kodi (and to get kodi going again)


    thanks !

  • I tried to setup a remote following the guide of this thread, but when I enter ir-keytable receive "/sys/class/rc/: No such file or directory", the folder rc actually not exists


    I flashed the Image 8.0.2 using a Raspberry PI 2. The Setup was working with OpenELEC 7 in combination with Lirc and ir receiver at GPIO 18


    Is there a way to get it running anyway?

  • You are probably still using the lirc-rpi dtoverlay. You need to use "dtoverlay=gpio-ir" instead.


    so long,


    Hias

  • HiassofT guide from the seond post is the single best thing on the topic I havew found. Thanks.


    I am using v7 since it works and I do not fix what is not broken. For last years I used RPi with an inexpensive IR set wihich included USB receiver and remote - IRF Media Media Center PC (W-01RN). Instead of the chinese remote, I actually use Logitech 600/650 remotes as I do for last 10 years. Good thing is I can get 45 distinct commands I needs from this combo. Bad thiing is: it uses Blue to turn the mouse off, uses Red instead of Record button, there are no Exit and Back separate keys, There are no EPG and Info keys, plus... So I had to be creative.


    The only thing I did not fix perfectly was finding out how to make an Exit button go to the Kodi Home screen and stop everything else, wherever I might be in Kodi. Best I managed was to use an extra code and map it to the <rootmenu> and then use that code to try exiting,b ut it does not work perfectly. List of actions in Kodi is exntesive but usefull since no description of what is where can be found. Just the list of names.


    What may be of interest here? Recently I switched to TSOP IR receiver. I just plasecd


    dtoverlay=lirc-rpi


    into config.txt and learned LIRC all the codes from my Logitech (as it was setup fir IRF) and all works perfectly.


    To test the new method, I replaced the above line with


    dtoverlay=gpio-ir


    and after a reboot, all is working perfetly again. I did not try generating any new config, I am still using evveryhting else as setup for the old method. But, this seems like a good way to start working with the new method. When I kill lirc and Kodi, I get normal responses from ir-keytable as expected.


    But, I must say that I am not exactly clear on which combo this scenario is using. I am still currently using LIRC but with dtoverlay=gpio-ir. Seems to me like old method was simpler to implement.