Tivo Slide Remote

  • So I did a search and the words TIVO Slide don't appear in any post I can find using the built in search or search engine.


    Mostly this remote works great, but there are a couple of things I haven't been able to do mainly around getting the other buttons to work, things like the info button and the select button in the middle of the dpad when it's slid open. I followed the directions on this site: TiVo Slide - Official Kodi Wiki


    and put the file 95-tivoslide.hwdb in /etc/.config/hwdb.d


    This is my file:



    I also made a copy of this called 99-tivoslide.hwdb then I created the file 95-keymap.rules and 99-keymap.rules with this content

    Code
    SUBSYSTEM=="input", SUBSYSTEMS=="usb", ENV{ID_VENDOR_ID}=="150a", ENV{ID_MODEL_ID}=="1203", RUN+="/lib/udev/keymap $name /etc/udev/hwdb.d/99-tivoslide.hwdb"


    Then I ran the command

    Code
    udevadm hwdb --update



    and still these key's don't work any thoughts?


    thank you,


    -G

  • There is no such command "/lib/udev/keymap", I would replace the command with "systemd-hwdb update". So your udev rule becomes

    Code
    SUBSYSTEM=="input", SUBSYSTEMS=="usb", ENV{ID_VENDOR_ID}=="150a", ENV{ID_MODEL_ID}=="1203", RUN+="/usr/bin/systemd-hwdb update"


    make sure you are using the correct rule for your remote.


    also see the note on that page

  • Thank you! I saw the second part and thought I'd done the substitution so maybe I pasted an old version of the file, or missed it.


    The first bit I'm hoping is what I need. I'm traveling for a few days but will give it a go when I'm back.

  • Okay just tried the command above and it didn't work, I notice your command doesn't include the path to the hwdb file and I don't see where to add that looking up that command on the web. Sorry I'm not much of a linux person I'm trying to learn and have a lot of experience with other OS's

  • Ping to try and find if anyone's made this work. I'm really trying to get the Info, Guide, and Channel Up/Down buttons working. It'd be nice to get the Dpad working from the keyboard as well, but I've just had no luck at all.

  • Here's what I've figured out so far. I've gotten evtest installed and running, the output looks like this at the top

    Code
    No device specified, trying to scan all of /dev/input/event*
    Available devices:
    /dev/input/event0:      TiVo, Inc. S5 Remote Control
    /dev/input/event1:      TiVo, Inc. S5 Remote Control
    Select the device event number [0-1]: 0
    Input driver version is 1.0.1
    Input device ID: bus 0x3 vendor 0x150a product 0x1203 version 0x111
    Input device name: "TiVo, Inc. S5 Remote Control"
    Supported events:


    then I pushed the buttons I wanted to use:

    Code
    Properties:
    Testing ... (interrupt to exit)
    Event: time 1491193607.720322, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0209
    Event: time 1491193607.720322, type 1 (EV_KEY), code 358 (KEY_INFO), value 1
    Event: time 1491193607.720322, -------------- SYN_REPORT ------------
    Event: time 1491193607.952321, type 4 (EV_MSC), code 4 (MSC_SCAN), value c0209
    Event: time 1491193607.952321, type 1 (EV_KEY), code 358 (KEY_INFO), value 0


    Then I found that the file needed to be in /storage/.config/hwdb.d/99-tivoslide.hwdb (not 95 like the item says accoording to the readme in the directory)


    Then I made my file look like this:


    but still no dice, I cannot get those commands to work. Anyone got any ideas? I was trying to follow along at home from this thread: thread-1632.html?highlight=hwdb.d but it seems like there's not enough here to make it work