[8.2.2.3] LibreELEC 8.2 for S912

  • Good afternoon! Many thanks for the work done! Everything is great! Installed version 8.0.2c on Beelink G1 Ultimate (3 Gb ram). Everything works fine, even a blutooth headset is defined! There is only one problem - in the kodi menu, when navigating, it happens that you press up or down or enter several times, and the system seems to freeze and not react, and after about 30 seconds or a minute quickly performs all the actions that correspond to the pressed keys (for example : I flipped through the list of films by pressing the "down" button a few times, and then the system suddenly hung, and then a minute later It quickly moved the cursor down to the number of clicks I made with this hang. I would be very grateful to you for solving my problem. Thank you! Have a nice day!

    Hi sabdro_66,

    I have a Beelink GT1 Ultimate 3Gb too and it works fine, but I have problems with bluetooh headset:

    1) very buggy the devices discovery. The headset appeards ramdomly (tried with two different headset models)

    2) when at the end I can pair the headset, the audio is bad because it stop/start like with a connection problem (but it is not the problem I guess).

    I tried to change all the values for Frequency, channels, upmix, downmix etc. but no luck.

    Any suggestion ? kszaq?


    have a nice day.


    Dear kszaq I was able to have bluetooth working with headset only adding an external bluetooth dongle, I wonder if maybe there is a problem with device tree. I have a Beelink GT1 Ultimate and I'm using gxm_q200_3g.dtb is it the right one ?

    sabdro_66 are you using a different .dtb ?


    best regards,

    Edited once, last by miketyson ().

  • Check your audio settings, enable pasthrough for all the formats.

    All the HD audio works here.

    RPI3 1GB, Z4 RK3368 1GB, MINI MX-G 2GB, Mini M8S II (coreelec.org 9.2.1), H96 Pro (coreelec.org 9.2.1), ODORID N2 (coreelec.org 9.2.1), VIM3 PRO (coreelec.org 9.2.1), Beelink GT King (coreelec.org 9.2.1), Denon AVR-X2600H, LG 60SJ810V
    pel.hu

  • Check your audio settings, enable pasthrough for all the formats.

    All the HD audio works here.

    What do you mean "All Formats" there is just one toggle button to allow pasthrough in the settings , no?


    Thanks!

  • What do you mean "All Formats" there is just one toggle button to allow pasthrough in the settings , no?



    No.

    There are some more settings

  • Today was released Linux kernel 4.12 . They have more improvements including some for AMLogic.

    Is there any chance to improve compatibility with the s912 - Mali GPU ?

  • Today was released Linux kernel 4.12 . They have more improvements including some for AMLogic.

    Is there any chance to improve compatibility with the s912 - Mali GPU ?

    Linux kernel has nothing to do with OpenGL ES drivers. AMLogic has to acquire license for Linux GPU drivers from ARM to provide those drivers to end users. Another solution is to write Mali drivers using reverse engineering but it's not an easy task.

  • Would it be possible to solve the problem with the high-bit rate H.264? For example, when playing a Panasonic GH5 video with a 150 Mbit / s data stream.

    Otherwise great thanks for the perfect job

  • #Kalebroch did you get the Lan to work on the Sunvell T95Z Plus after I updated to version d my lan doesn't work either. Worked perfectly before.

  • Dear kszaq I was able to have bluetooth working with headset only adding an external bluetooth dongle, I wonder if maybe there is a problem with device tree. I have a Beelink GT1 Ultimate and I'm using gxm_q200_3g.dtb is it the right one ?


    sabdro_66 are you using a different .dtb ?

  • jkjelds

    To tell you the truth, I haven't spent any more time on the T95Z in the last couple of weeks, just been too busy with work and stuff. I'll try to get to it over the next few days and report back to you. My issues might be slightly different from yours, for some reason the LAN on my T95Z will not work at all with Libreelec, however if I flash back to Android it does, so as I said I'll try to get some time at it over the next few days.

  • Hi kszaq!


    Congratulation on your fantastic work! I've just tried the le on my gt1 and it's working smoothly. Not tested too much yet but this has a nice state!

    I noticed that cec is working well with my tv remote but the original android rom is buggy. E.g channel +/- buttons disconnects the device to tv source. But the LE is working correctly. Is it a chance to replace the cec part on the android?

    I dont know a kernel module or a kernel modification is needed for that but i hope you know and know how hard is.


    Thanks a lot and i wish you a good luck for the further development!

    Edited once, last by pszab ().

  • Android uses Amlogic CEC implementation, whereas LibreELEC includes libCEC implementation from GDPR-1. I don't think it's trivial to add it to Android - you'd need to have full Android source code as it's not only kernel part but also userspace.