Cubox-i4 Pro

  • I have never been able to get this to run on this device. It's pretty straight forward. Boots up to the splash screen and then a dark screen that never recovers from.



    Sent from my iPhone using Tapatalk

  • Yep. I can confirm that vpeters build work. I installed the latest (in his link above) and it booted without problem.



    Sent from my iPhone using Tapatalk

  • I should add that I am experiencing some problem when watching videos. The sound sometimes sway, like an old turntable but it's only noticeable with slow background music, not speech. A few times the video just froze as well. I have not yet checked if it's a Krypton problem, LibreElec problem or LibreElec on Cubox. Love LubreEkec but temporarily switched back to my previous OpenElec SD until I have time to research and look into it further.



    Sent from my iPhone using Tapatalk

  • Hi Guys


    I've a cubox-i4 pro and try to switch to libreelec. I used the LibreELEC.USB-SD.Creator to download and write LE 8.0 to a sdcard.
    My cubox is able to boot from it and at first everything looks fine. But after a few tests I recogniced two problems.


    The first one is that I have to wait about 2 minutes until the soundcard work. Until the soundcard is working I'm also unable to start a video.
    My cubox is connected via hdmi to my tv.


    The second one is that there are sporadically reboots. Sometimes after a few seconds and sometimes after hours.


    With my old OE 6.0.3 there are no reboots and no soundproblems.


    I hope someone can help me to fix it.


    -
    Daniel


  • The first one is that I have to wait about 2 minutes until the soundcard work. Until the soundcard is working I'm also unable to start a video.


    Update with this version. Will be fixed in v8.0.1.


    For second problem you could try this version.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)


  • Update with this version. Will be fixed in v8.0.1.


    For second problem you could try this version.


    Hey vpeter,


    I'll use this thread bc my problems are simular. I'm using your updated version with the sound-fix. That works, but since updating to the final I experience my Cubox to just hang during the night (sometimes). That was also mentioned in the comments at one point and did not happen during beta. I cannot control LE anymore and even SSH does not work. Solution is a plugging off and on the Cubox.
    Are you aware of this problem? Difficult to provide logs at the moment, I'm sorry but I could try if necessary.
    If you're aware of it, is there a version that fixes both: the sound problem and the sporadic crashes?


    Thanks a lot for your effort.


  • No. I don't have it running 24/7.


    Thanks for the answer,


    I'll try to go back to kernel 3.14 and check if that helps or are there any good reasons to keep 4.4?
    Otherwise I'll try to narrow down the problem and get some logs...


  • are there any good reasons to keep 4.4


    There was requests for newer kernel to have overlay support for running docker. But atm don't really know if anyone actually uses this.
    Fyi: openelec is using 4.8 already. I already have it used but not much. Maybe some issues are fixed there... Any volunteer for testing around?


    Otherwise I'll try to narrow down the problem and get some logs...


    Try to stop kodi when you leave system idle:

    Code
    1. systemctl stop kodi

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().

  • If you are talking about the latest stable OE with Jarvis I am running that now without problems. Never turn off my Cubox-i and it never froze.



    Sent from my iPhone using Tapatalk

  • There was requests for newer kernel to have overlay support for running docker. But atm don't really know if anyone actually uses this.
    Fyi: openelec is using 4.8 already. I already have it used but not much. Maybe some issues are fixed there... Any volunteer for testing around?


    I am running 4.8 for some weeks now (thanks vpeter , btw: did you already build a verision with final kodi krypton?).


    I did not have any unexpected reboots until now and there is no sound issue, sound is working directly after boot.
    One thing I noticed is my DVB-S card doesn't respond any more when running ~2 days. After reboot it is ok again. Nothing to find about the reasons for this in any of the logs, neither in the kodi logs nor in the kernel logs.

    CuBox-i2ex
    DVBSky S960 / Montage M88DS3103
    Western Digital Elements 3TB USB HDD
    Optoma HD131Xe Projector
    Teufel Concept E 400 Digital "5.1-Set"

  • Thank you, just downloading it :)

    CuBox-i2ex
    DVBSky S960 / Montage M88DS3103
    Western Digital Elements 3TB USB HDD
    Optoma HD131Xe Projector
    Teufel Concept E 400 Digital "5.1-Set"

  • I was running LibreELEC-imx6.arm-8.0.0 (4.4 kernel) and everything was fine with one exception - when the movie ends I'm not getting back to menu, there is a black screen only.
    There is no such problem with LibreELEC-imx6.arm-8.0.1-xbian-4.8, but with this version I see some freezes during the movies, so I have to stop and play again.
    The last working good version for me was 7.95.1 (4.8 kernel). Will appreciate any recommendation about upgrade.


    edited to fix wrong version number

    Edited once, last by AndrewZ ().


  • Boots up to the splash screen and then a dark screen that never recovers from.


    Could you test this image? It includes some fixes which could fix this issue. With kernel 4.4.
    [hr]


    The second one is that there are sporadically reboots. Sometimes after a few seconds and sometimes after hours.


    Could you test this image? It includes some fixes which could fix this issue. With kernel 4.4.

    Better support for Amlogic devices: use CoreELEC

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community with limited support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

    Edited once, last by vpeter ().