VPN Manager for OpenVPN

  • I'm having issues with unblockr and the addon.

    It used to work great not sure what happened.

    Here is the current log file for addons

    Any help would be great.

    I uninstalled the addon and reinstalled it is working now. Upon setting up the user defined I selected "no" to the option that pops up.

    Edited once, last by Mickey690 (December 1, 2019 at 8:30 PM).

  • Hi Zomboided, I hope you can help me at least, because I wouldn't know what to do. For at least a week I have a problem with the Cyberghost vpn connection to the Italian server with libreelec. In practice, all the credentials and certificates downloaded from the Cyberghost website are ok and up to date, I can enter without errors and connect to all the vpn servers I've tried except the Italian one. I asked Cyberghost for help but even they don't know what the problem is, they told me to reinstall the addon and the credentials, which I did a lot of times but nothing ... I don't understand why I just can't connect to the Italian server . It says the address is not known or incorrect, but in reality the credentials are updated. I believe there is a problem of conflict between the stored addresses on open vpn managers and those of the provider vpn cyberghost. The fact is that if I try to manually change the file locations.txt by entering the server address vpn italia (updated) it still cannot connect. I am attaching the error screen in case I know what the problem may be. Thanks again for the availability. A greating

  • Is the openvpn-it.txt something you downloaded from CyberGhost? Looks simply like the server has changed.

    Yes, it's the vpn Italian configuration downloaded from Cyberghost website. You could update the locations.txt in your database o explain to me how update this manually? I'd like can solve this problem and no use "user defined configuration" because automatic configuration is better. Many thanks.

    Edited 2 times, last by giggi_80 (December 5, 2019 at 8:10 AM).

  • Maybe the servers have changed. I need to regenerate them. I also need to fix Cyberghost, but neither is happening until I finish work for Christmas.

    Thanks, I hope you can solve cyberghost problems soon, the program with this vpn has been bad for a long time, it loops continuously and disconnects from the servers.

  • Is it possible to configure this app to work with ghost vpn?

    No matter what I do I cannot get it to work with the providers .opvn files :( and the log just gives me a 1 line error mentioning -killall

  • Hi, am having problems with the openvpn manager addon after a completely fresh libreElec install and setup today. Latest versions of everything downloaded. I also have the embuary skin installed.

    I can set up my PIA connection fine and set primary and secondary servers fine. I can set the vpn to connect before kodi starts. However if I try to disconnect from my primary vpn or change to a different server, I see the message titled "Disconnecting from VPN", the addon seems to hang for 15 seconds while trying to pause the vpn monitor, and then reports "Error, Service not running. Check log and reboot." The original vpn connection remain intact and will not disconnect.

    Can you help please?

    Log File

    Edited 2 times, last by SDSD (December 31, 2019 at 8:27 PM).

  • Recreate on a vanilla LE build without anything else running. There’s a bunch of crap running on the build you have which could be stopping it. There are no errors in the log to show the service stopping so I think it’s something else interfering.

  • I have the same problem and am located in the Midwest US. My closest VPN is Chicago. I have a Ras Pi 4 with Libreelec 9.20 and Kodi 18.5. I have tried numerous times, after reformatting SD card and reinstalling Libreelec starting from scratch to install CyberGhost OpenVPN with no success. It keeps connecting to my local IP which must drop it and it tries to restart every so often. I would like to know if anyone has been successful with this setup to install CyberGhost or any other VPN and if so which one and how?

  • The same problem as what? SDSD was having an issue that was weird. Yours sounds like a "regular" connection issue and might be related to CyberGhost changing their servers again. If you have a log with debug (VPN Mgr settings/Advanced/Debug on) then post it and I'll look.

  • I need to see a Kodi log with the option switched on I asked for.

    First, great Addon! Thanks for all your work!!!! I am using Cyberghost, too. Made a complete ne installation and I spent already 10 hours to fix it. What exactly do you need? Which option switched on? You need the kodi log? I have one including debug options:

    Please give me a sign, when you have downloaded it. Thanks

    Edited once, last by benito (January 17, 2020 at 6:15 AM).