VPN Manager for OpenVPN

  • Has anyone had any success with setting up blackvpn? Or could this be added to the providers? Ive installed the OVPN file using the wizard that is avaliable in their windows 10 download section but it isnt connecting
    [hr]


    Has anyone had any success with setting up blackvpn? Or could this be added to the providers? Ive installed the OVPN file using the wizard that is avaliable in their windows 10 download section but it isnt connecting


    Sussed it the files for MAC work!

    Edited once, last by Bobbets ().

  • 3.0.0 is out on the repo and GitHub


    This adds support for third party add-ons to use the filter functionality. I've been able to add a few lines to the IVue add-on (my TV Guide of choice) to get the VPN connection to switch with a channel. Probably the next task is to convince third parties to add support (as I'm not going to hack around a bunch of other peoples work)

    Edited once, last by zomboided ().

  • Hello Zomboided,


    First of all, great VPN product! I've been using it religiously with LibreElec on a RaspPi for quite some time. Last evening I upgraded to the latest LibreElec version 8.0 Krypton vs previous 7.0.3 Jarvis. I'm an Express VPN user and for the most part everything has been stable in the past. With this recent update though, I cannot connect anymore. I even uninstalled the repository, reinstalled and ensured I have the latest 3.0 vpn service manager, as of last evening. No luck, including starting a fresh profile via username/password/reloaded certs again.


    Thoughts?


    To expand a little more, even though I triple checked the settings to be accurate, it allows me to login into the express vpn location list to make a selection. However, when a location is chosen (tried many options), I get an error disconnecting from VPN in the status bar. Followed by this message:


    Error connecting to VPN, could not establish connection. Check your username, password and network connectivity and retry.


    Again, verified the credentials are correct and I do have internet access to the system


    The log has a verify error: depth=0, error=format error in certificates notAfter field: C=VG, ST=BVI, O=ExpressVPN, OU=Expressvpn, CN=Server-1786-1a, [email protected]
    OpenSSL: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    TLS_ERROR:BIO read tls_read_plaintext error
    TLS Error:TLS object -> incoming plaintext read error
    TLS Error:TLS handshake failed
    SIGUSR1[soft,TLS-error] received, process restarting

    Edited once, last by Yeager ().

  • Glad to see "zomboided" again, whoever this ominous zomboided1 may have been ... :D :D


    In order of your moving i also migrated to LE Forums.
    So what's to do first? Ah i know ... leave +rep for this great addon ;)


    yep, that's all for now ^^


    Greets from Austria ... and as always, thank you very much for your dedication to this project :)

    Edited once, last by nokodemus ().


  • See this reply earlier in the thread.
    thread-5032-post-39337.html#pid39337




    [hr]


    Thanks man, glad it's working well for you.

    Edited once, last by zomboided ().

  • Whats gone wrong here?


    This used to work up to recently, I havent changed anything manually - something might have updated automatically.


    Any ideas?


    Edit: Issuing 'openvpn "Norway 1 (TCP).ovpn"' command from command line (along with username/pwd) connects just fine.


    -------------------------------------------------


    19:55:18.360 T:1962017232 ERROR: Previous line repeats 2 times.
    19:55:18.360 T:1962017232 NOTICE: Samba is idle. Closing the remaining connections
    19:55:18.750 T:1649259424 ERROR: VPN Mgr : (service.py) VPN connect to has failed, VPN error was 0
    19:55:18.769 T:1649259424 NOTICE: VPN Mgr : (platform.py) VPN log file start >>>
    19:55:18.769 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 OpenVPN 2.4.0 armv7ve-libreelec-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [AEAD] built on Feb 17 2017
    19:55:18.769 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 library versions: LibreSSL 2.4.4, LZO 2.09
    19:55:18.770 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Auth Username:'. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.
    19:55:18.770 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 Exiting due to fatal error
    19:55:18.770 T:1649259424 NOTICE: VPN Mgr : (platform.py) <<< VPN log file end
    19:55:58.068 T:1874850720 ERROR: Unable to find plugin
    19:55:58.068 T:1962017232 ERROR: GetDirectory - Error getting plugin://
    19:55:58.069 T:1962017232 ERROR: CGUIMediaWindow::GetDirectory(plugin://) failed
    19:56:01.810 T:1481634720 WARNING: COMXImageFile::GetCodingType progressive images not supported by decoder
    19:56:01.811 T:1481634720 WARNING: Previous line repeats 1 times.
    19:56:01.812 T:1481634720 NOTICE: LoadJpeg: unable to load /storage/.kodi/addons/script.ustvnow.plus.guide/fanart.jpg
    19:56:18.956 T:1649259424 ERROR: VPN Mgr : (service.py) VPN monitor service detected VPN connection is not running when it should be
    19:56:18.975 T:1649259424 NOTICE: VPN Mgr : (platform.py) VPN log file start >>>
    19:56:18.975 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 OpenVPN 2.4.0 armv7ve-libreelec-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [AEAD] built on Feb 17 2017
    19:56:18.975 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 library versions: LibreSSL 2.4.4, LZO 2.09
    19:56:18.975 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Auth Username:'. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.
    19:56:18.975 T:1649259424 NOTICE: Fri Mar 17 19:53:58 2017 Exiting due to fatal error
    19:56:18.975 T:1649259424 NOTICE: VPN Mgr : (platform.py) <<< VPN log file end


    -----------------------------------------------
    [hr]
    To add to the above post:


    I get this in the openvpn log file when trying to make a connection through the front end, it looks suspicious:


    Edited once, last by Scope ().

  • Upgrade to 3.0.0 if you're not there already
    Settings/Utilities, Delete ovpn files.
    Settings/Debug, switch on debug.
    Click ok
    Ideally restart.
    Reconnect again.
    Get me a FULL log, not just an extract.

    Edited once, last by zomboided ().


  • No need for a log.. Resetting the ovpn files seems to have sorted the problem. :)

  • I'm having issues setting up slickvpn with the ovpn files provided here and also this one here. For some reason it's not extracting the user key?

  • I haven't looked at the zip, but the first example you have has the user key and cert commented out - so the import thinks they're not needed.


  • I haven't looked at the zip, but the first example you have has the user key and cert commented out - so the import thinks they're not needed.


    Thanks for the reply. Yea I'm not quite sure what's required as a bit of a newb to all this. My provider only lists that ovpn under Ubuntu/Mint so thought that's all i needed. The other zip has a crl.pem file as well which I've no idea what's for. That was under the openvpn windows FAQ. I've tried creating some .crt files from this tutorial and removed the # from the ovpn file but still no dice. I'll try get some logs if you would be so kind to have a look at them.


  • The use of user defined vpns is documented on a wiki page. You should go read that


    Thanks yea I've been looking at the wiki. Don't think I've missed anything. As far as I can tell I don't need any crt's just username and password which I've entered. Weirdly it says I'm connected however I only get one server option and the IP is my current one.


    Uploaded a log from a defaulted LE 8.0 installation just to rule any other addons out.


    Can see this error:
    ERROR: Linux route add command failed: external program exited with error status: 2
    [hr]
    Just been having a trawl around and found this suggestion to add slickvpn to the OE connections which works. Now how to get it working with VPN manager.

    Edited once, last by Morphy ().

  • The number of vpn connections you're offered is related to the number of ovpn files you upload. Each has a different IP address for the different connections. If you only upload one, how is it to know where the others are?


    The error you get means that the routing table hasn't been updated, this can happen for a whole variety of reasons. You should always verify the connection gives you a different IPaddress to confirm its worked

  • Right ok I thought it discovered the servers from the initial url. When I connect with VPN manager it doesn't work, I get my usual IP address not a VPN one. When I connect with the OE VPN connection it works ok and I get a new VPN IP. The connection method is PPPT apparently.

  • If you can't get it to work, use a VPN provider that's already been added, you've 30 to choose from. I don't have the energy or time to debug yet more random VPN providers, sorry.

  • Hi Zomboided


    Thanks for this addon. Just wondering is there a way for this addon to stay connected outside of kodi?


    I'm using osmc on rpi3 which has a x11 desktop feature where kodi closes and opens a lxde desktop?


    I'm assuming your addon only works inside kodi as my ip reverts to isp when on desktop.


    Also about the wiki vpn risks, i tried ssh to my kodi box after it connected and it brought me to login console, although the osmc username and password didn't work, it seems PIA use same ip address for everyone connected to same server so when i ssh a particular address i may not be connecting to my kodi box? Although i've read that the ssh port is open for the vpn admins for management, so i may have been connecting to the server console login.


    Does this addon have port forwarding on by default, I assume the device will be reasonably safe on vpn if no port forwarding?


    I'll change default password for extra security.

    Do you use PIA yourself?


    Thanks for any info :shy:

    Edited once, last by the_bo ().


  • I don't know what the behaviour is on OSMC. You can see if the openvpn task is still running when you exit. I don't explicitly close it (which is something I'm going to look at in the next release). I don't really think relying on Kodi to manage your VPN connection when Kodi is not running is the right approach anyway - I'd be doing this myself via some other means (perhaps a process that will start if openvpn and kodi are not running).


    I don't know what you're expecting when you say port fowarding. A VPN will create a tunnel for your outbound traffic. You can see the results of the VPN in the routing table.