Posts by Morphy

    The OP was referring to RPi0/1 however this is true for all RPi IMO. From a consumer hardware perspective, connecting a new device wirelessly is industry standard and something which would make LE a lot more accessible. Thanks for confirming it's not something on the road map however. I'll see if I can find someone to help code an add-on to do it.

    Yes, it's possible. Mount the SD card on your computer and create (as root):

    Code
    nano /where_sd_card_is_mounted/storage/.cache/connman/mywifi.config

    Add the following (change "mywifi" after "Name" to your SSID and "passphrase" to your passphrase), save the file and boot your pi:


    Code
    [service_wifi_mywifi]
    Type = wifi
    Name = mywifi
    Passphrase = passphrase

    Hi chewitt


    The Libreelec connection flow has always been great apart from when installing a new instance without HDMI CEC, input peripheral or ethernet. I've had it happen a few times where something has failed and I've had to dig my emergency 50m ethernet cable out! Why can't we manually define the credentials in the LE settings? Surely it's as simple as generating this text file?


    Then if we enable WiFi tethering pre-install, once the WiFi credentials were known it could be entered via the GUI and a remote app like Yatse or XBMC Remote. Once the file is there and hotspot tether is disabled it will autoconnect.


    If it's something LE team are not interested in maybe someone with some basic python skills (not me or I would) could make a simple addon to create this file.

    I have a similar issue with one of my RPi4's which is connected to a long cable to a Onkyo amp and LG TV. Occasionally, with no apparent pattern I will switch it on to find a blank screen on TV saying no input. There is something coming from it as it would normally be a blue screen from the Onkyo amp.


    The amp always remains on or on standby however the TV is switched off via a smart plug.


    I've managed to figure out how to get the picture back up without restarting.


    tvservice -p

    systemctl restart kodi


    I'm not sure if I have to do a tvservice -o then -p in between the restart as yet.


    This is the dmesg log which could show something. I did try unplugging a couple of times, powering the amp off/on and Kodi crashed a couple of times too so who knows which is the error. I'll try get a more specific one next time.

    So I keep getting these issues and it's usually resolved by restarting my router which isn't helpful in getting to the bottom of it.

    I've noticed this in the journalctl:


    Code
    wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
    wpa_supplicant[367]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="myssid" auth_failures=1 duration=10 reason=CONN_FAIL


    I can't see anything on my router logs which is weird. No other device is having this issue which is why I'm posting here. I suspect it's an issue between the two devices, I just need to figure out what it is.

    EDIT: fixed this, the script wasn't in unix format!

    I'm struggling with this script, probably something simple but this is what I have:


    I get this error when running:

    Code
    autoconnectwifi.sh: line 26: syntax error: unexpected "done" (expecting "then")


    So after figuring my stupid mistake I found this other script and adapted it. This uses the wifi network instead of a ping, maybe better if for some reason the IP will change or unavailable. wifi_servicecode_managed_psk has been changed from what is listed in connmanctl services


    Bash
    #!/bin/bash
    
    while true ; do
        if ifconfig wlan0 | grep -q "inet addr:" ; then
            sleep 60
        else
            connmanctl connect wifi_servicecode_managed_psk &>/dev/null
            sleep 10
        fi
    done

    I guess this never got added to the wiki :( This line needs to be changed for other chips:


    3b. Edit /flash/config.txt and add (somewhere near the end): dtoverlay=i2c-rtc,ds3231

    with


    Code
    dtoverlay=i2c-rtc,ds1307

    or

    Code
    dtoverlay=i2c-rtc,pcf8523

    Also, I'm not sure if this step is necessary:

    4. Adjust the RTC's time:

    4a. Verify local system time with the 'date' command. If local time is off, either adjust it manually or connect your Pi to the Internet and wait for it to the the correct time from an NNTP server.

    4b. Transfer local time to RTC: hwclock -w

    4c. Verify RTC time: hwclock -r


    I've just added a used ds1307 rtc and the date from hwclock -r was UTC, I'm on GMT, so an hour behind. Doing hwclock -w and then rebooting with no network resulted in it being an hour ahead for some reason! It's now sorted itself out though and keeps the correct time after losing power and no network.


    Now I just need to figure out a script to keep trying to reconnect the wifi if it's unavailable after power loss. Then my pi might just get itself back ship shape after a rare power cut!

    I've managed to achieve this on rpi 4 by adding the above to cmdline.txt in /flash so it looks like this:

    Code
    boot=UUID=xxxx-xxxx morequiet disk=UUID=xxxxxxxx-xxxxx-xxxx-xxxxxxx quiet systemd.show_status=0

    It works fine apart from I'm still seeing "waiting for network...." even though this option is disabled in LE settings. Enabling it just results in another line with the same. Any idea how I can suppress this as well?

    I'm having a very intermittent issue with the onboard wifi adapter crashing on my RPi4 after some time (days or hours) of being connected and online. The connection will appear up in LE settings however I can't ping the device at all. Enabling and disabling the wifi does nothing, only a reboot works.


    I've had a look in the log and can't see anything related and am hesitant to turn on debug logging as this could happen hours or days after a boot and the log file would be huge. Here's a few things I've tried after getting onto it via a cable:


    dmesg

    Code
    connmanctl scan wifi
    Error /net/connman/technology/wifi: No carrier
    Code
    iwconfig wlan0
    wlan0     IEEE 802.11  ESSID:off/any
              Mode:Managed  Access Point: Not-Associated
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off


    Is there anything else I can try looking at before I get a debug log?

    I updated to this build and it seems to work ok apart from Kodi will relaunch when I'm in ES or playing a game in Retroarch. Any idea why this is happening. RPi3 build.

    emby4.start

    Code
    ERROR: ld.so: object '/storage/.kodi/addons/service.emby4/lib/libMagickCore-7.Q16HDRI.so.6' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/storage/.kodi/addons/service.emby4/lib/libMagickCore-7.Q16HDRI.so.6' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/storage/.kodi/addons/service.emby4/lib/libMagickCore-7.Q16HDRI.so.6' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    ERROR: ld.so: object '/storage/.kodi/addons/service.emby4/lib/libMagickCore-7.Q16HDRI.so.6' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
    cat: error while loading shared libraries: libMagickCore-7.Q16HDRI.so.7: cannot open shared object file: No such file or directory
    /storage/.kodi/addons/tools.dotnet-runtime/bin/le_dotnet: line 8: dotnet: not found

    Hi awiouy thanks for getting back to me. I have updated all addons so I'm assuming dotnet is up to date. Output of journalctl -u service.emby4 is blank. I'll try refreshing the repo's see if it's missing an update.


    systemctl status service.emby4.service reports:

    Just seen an old thread re emby and this command might help? ldd $(which dotnet):


    Code
            linux-vdso.so.1 (0x00007ffe41508000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007febe8c4c000)
            libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007febe8c32000)
            libc.musl-x86_64.so.1 => not found
            libm.so.6 => /usr/lib/libm.so.6 (0x00007febe8af2000)
            libc.so.6 => /usr/lib/libc.so.6 (0x00007febe893c000)
            /lib/ld-musl-x86_64.so.1 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007febe8fe6000)