VPN Manager for OpenVPN

  • Any chance to force a VPN reconnect after standby? Everytime after wake up from standby I have to reboot to establish a VPN connection otherwise I have no connection to the internet nor do I have a VPN connection.

  • There's a ping option in either settings/monitor or debug to keep the connection alive, or reset it if the ping doesn't work. Is that switched on? You'll need to reset the VPN provider files after changing it.

    I'm guessing openvpn doesn't notice something has changed. You could kill that task when the computer wakes up, providing you can find somewhere to hook into. If the task isn't there, the addon will restart it.

    Otherwise get a kodi and openvpn log with debug switched on.

  • First off, thank you for a remarkable program. I am having a problem which may have been previously addressed. When I go to add a second VPN connection, in the "settings" menu, the program scrolls up on its own. The second VPN connection is not accessible as it is now sitting directly under the VPN Connections tab. and is partially hidden. When I attempt to click it, the tab opens instead. I am having this problem on all three of my RPI's, so it is not an isolated event and have tried reloading the program. I have just ignored adding a second, third, etc., VPN location until I just now saw this forum and thought I'd ask about it. Any guidance?

    Again thank you for a remarkable program. 8)

  • Yes, it's a skin problem. I see it on mimic but you can scroll and click with the directional buttons still. Maybe other skins don't have this problem, I don't use them though

  • The up/down buttons are ineffective for the problem probably as skin issue as well. I will change skins.

    Thank you for your prompt reply.

  • I have setup my VPN but I can't for the life of me figure out how I can route my DNS through the VPN.

    In Ubuntu, I know this is handled by the resolve.conf. How can I make this happen in Libreelec?

  • I think you'd be able to use the up/down scripts to set it. See the wiki for how to use those. I don't know what the specific set of commands are that you'd need, and I'm not sure if you'd need to add something more to the ovpn. I did do some googling but there seemed to be some confusing info that would need to be worked through. Post up what you find, this is an interesting problem

  • Hello...I have libreELEC and was trying to install zamboided from a zip en part of getting my vpn set up on my box (ipvanish) , but every time I go to install from zip file it continues to give me an error? Fail to install.....is there something I am missing? Or doing wrong? Any help would be greatly appreciated


  • Installation instructions are linked in the first post. It's just an addon like all the others. Maybe your download of it didn't work

  • The add on zip file is not working, I did follow instructions, but when it comes to...install from zip file, it gives a file install error..

  • I've just installed it from the repo, no problems. The repo hasn't changed in months, so I'm confident that's not a problem. It's something to do with your download or your environment, there's not a problem installing the addon

  • Hi, anyone had any luck using this with ipredator.se?

    I tried the "user defined" settings, importing .ca .key .auth .conf .ovpn .ovpn files (sure to many, but after fail, it tried everything :) )

    the log gives me nothing other than a message that ---ping is not nescessary when ---keepalive!

    I tried NordVPN, but ipredator is really the only server I know that solves my problem.

  • Turn off settings/debug/Check connection with ping as it's adding ping when you don't need it. Then try importing again.

  • Turn off settings/debug/Check connection with ping as it's adding ping when you don't need it. Then try importing again.

    Ok, now I got another message in openvpn log:

    warning: cannot stat file `path/to/openvpn/config/keys/IPredator.se.ta.key`:no such file or directory (errno=2)

    Options error: -tls-auth fails with `path/to/openvpn/config/keys/IPreator.se.ta.key`:no such file or directory

    Warning: file `/storage/.kodi/addons/service.vpn.manager/UserDefined/pass.tx`is group or others accessible

    Options error: Please correct theese errors

    And now I got it working I do not why, but made a directory and put the file in`storage/to/openvpn......../ipredator.se.ta.key`

    pass.txt was showing (usernamepassword) connected in one line, moved password to line2. Might just be notebook that showed it that way.

  • They supplied you with ovpn files that contained a path they intended you to change to make your own. I like that you've created that example path to fix the problem tho :-)

    You can could have deleted the path entirely and the import function will fix it for you. I guess that's less practical for 10s of ovpn files

  • No, that path is not written any place in the .ovpn file.

    I run this on Amlogic S905x box

    Now testing Airvpn, Norway is missing from list. Any way you could fix or anything I can do?

    Edited once, last by ryv ().

  • This is from the ipredator.se ovpn that was causing your problem:

    ca /path/to/openvpn/config/keys/IPredator.se.ca.crt

    tls-auth /path/to/openvpn/config/keys/IPredator.se.ta.key

    If you'd used one of the ovpn files that used inline certs and keys you'd have not seen the problem.

    I don't have an AirVPN account anymore. Can you provide me with the latest ovpn files?