[9.0.0] LibreELEC builds for MX2/G18

  • Hi Everyone, I have download 8.0.2 build here. Doing like that:

    1) Extract "LibreELEC-Amlogic_MX2.arm-8.0.2.zip" to any FAT32 USB key;

    2) Use "LibreELEC.USB-SD.Creator.Win32.exe" to burn "storage.img" into an empty SD card;

    3) plug both USB key and SD card to the set-box;

    4) make the set-box enter recovery mode and then select "apply update from EXT" and choose udisk as source;

    5) The messages shows everything is OK and almost the same as video from "https://www.youtube.com/embed/Ni4jN0JHoeU";

    but then the set-box cannot startup anymore. Even bad, I cannot make it boot into recovery mode. How could I restore it to original state with Factory Firmware? Thanks a lot.

  • And even after I have build a bootable recovery sdcard as "https://www.cnx-software.com/2016/11/19/how-to-create-a-bootable-recovery-sd-card-for-amlogic-tv-boxes/" told. The set-box won't enter recovery mode but still boot the LibreELEC and stuck at the screen that I had just post.

  • Well, I successfully make the set-top box run into recovery mode from rescue card by short-connect SPI chip's PIN. But "apply update from EXT" will failed. I have tried two stock ROMs from the vender. But none of them can successfully update. Seems LibreELEC has done something in the NAND and then stop the Android update process. It's my fault. I haven't researched carefully. I have misunderstood that LibreELEC will burn to SDcard from USB key. Actually, it is not. Suggesting we should have a big red WARNING message for this behavior.

  • OK, finally I successfully recovery this set-top box to a stock firmware coming from its vendor. Seems the reason is that the way I use a straight screwdriver to short-connect SPI's PIN is not stable. OK, let me describe the whole process that might be useful for somebody someday:

    Mistake I made:

    1. First, I made a wrong decision to install LibreELEC on this TV-box cause it is no a dual boot solution. I haven't researched carefully but just saw the tutorial video from MPXproject has used one USB key and one SDcard. So I think it will burn LibreELEC to SDcard. But it isn't.

    2. Second, I made another mistake that I used the default dtb.img in this release. That is for MX2/G18. I should try to find the exact dtb.img for this TV-box or try to get this TV-box device tree file by the mothod that "https://www.cnx-software.com/2014/05/12/how-to-extract-a-device-tree-file-from-android-firmware-files/" has told.

    Process I did:

    1) Extract "LibreELEC-Amlogic_MX2.arm-8.0.2.zip" to any FAT32 USB key;

    2) Use "LibreELEC.USB-SD.Creator.Win32.exe" to burn "storage.img" into an empty SD card;

    3) plug both USB key and SD card to the set-box;

    4) make the set-box enter recovery mode (This 10moons D6-dual core TV-box has no reset button but hold the power button for longer than 3 or 5 seconds) and then select "apply update from EXT" and choose udisk as source;

    5) The messages shows everything is OK and almost the same as video from "https://www.youtube.com/embed/Ni4jN0JHoeU";

    6) And then the TV-box will hang on startup. It can show a "MATRICOM" splash screen and then show "LibreELEC" splash screen and then hang;

    7) I made a bootable recovery sdcard with "Amlogic_SDcardMaker_BootcardMaker_burnBootCard_v1.0.1" as "https://www.cnx-software.com/2016/11/19/how-to-create-a-bootable-recovery-sd-card-for-amlogic-tv-boxes/" told.

    8) The TV-box cannot reboot to enter recovery process though I tried to hold the power button for many times. -- Here, I guess that is because the uboot has been replaced with the uboot for MX2/G18 that shipped with LibreELEC firmware. And that uboot won't response to hold power button behavior;

    9) So, the only way is to force TV-box booted with the uboot in SDcard. I can't remember where I found a method that short pins of NAND in "http://freaktab.com/forum/tv-player-support/amlogic-based-tv-players/aml872mx/other-aml8726-m/6373-solution-for-stuck-in-android-load-aml8726-mx-dual-core-tv-box-android-4-2-2/page11" or "https://www.slatedroid.com/topic/41478-how-to-unbrick-your-amlogic-aml8726-mx-series-tablet-v20/". But the pin is too small. I cannot easily short it with tools in hand.

    10) Then I found somebody has said short-pin of SPI will have the same effect. Then I tried this method with a and finally I successfully make the TV-box enter recovery mode and flash with a stock android firmware. That means short-pin of SPI and click power button together (no need to hold the power button, actually holding the power button won't work). If you see HDMI signal coming to TV screen, you can finished short-pin and wait. The position I have marked in the picture I posted.

    11) To successfully flash the stock firmware, I have tried many times.

    11.1) One possible failure reason is the short pin not stable because I just use a word screwdriver to short pin; That is true. If I failed to make it, the TV-box will booted with MX2/G18's uboot. And "MATRICOM“ splash screen and "LibreELEC" splash screen will show on TV;

    11.2) Another possible failure reason is that the stock firmware I used is not correct. I have tried three version of stock firmware. All are coming from vender's website. So I am sure it is correct. I have seen someone said that sometime if the stock firware is older than the one stay in NAND, the flash will failed with a message "Script aborted (no error message)Installation aborted.". That might be true. I have made the TV-box enter recovery state many times. Every time it will failed to flash the firmware except the last one. And the last successful one is the newest stock firmware.

    11.3) The last reason is the luck. The page that I learn short-pin SPI has said that this method is not stable. That could be also true. Many times short-pin seems work, TV won't show "MATRICOM" splash screen. But it didn't enter recovery mode successfully and TV screen keep showing nothing but gray.

    That's all. Seems we need correct tools and operation, correct stock firmware and patience.

  • Hi,

    good to know you've been able to recover your box. This build is tested for G18 and MX2. You haven't said what model do you have.

    The photo with the error is missing first line because of HDMI overscan on your TV. You should set your TV aspect ratio to Scan only, No scaling, Original or something like that (depends on the TV) so you can see the whole image and the error message itself. Actually it seems like you've done something wrong with the SD card. Was the card inserted in the box while you were trying to boot the LibreELEC?

    Btw. Good news everyone! I've just seen this commit in the repo: kodi: add hack to fix audio for WP1 · LibreELEC/[email protected] · GitHub

    If it finally resolves the audio problem I will release first alpha build with Kodi 18 in a couple of days!

  • I've updated one of my boxes to the devel version from 25 november. Configured my setting and addons. Made a backup. Updated a second and 3rd box to the november 25 devel. After restoring the backup on those two boxes i get file system corruption error on boot. Tried also with the November 7th devel. Same result.

  • The backup seems to contain some device specific files and it is not meant to be used on another device. I'd try to open the backup file on PC and remove the .cache, .config and .ssh directories before trying to restore on another device. However I don't have a second device to try if it helps.

    How about the sound distortion problem on the device which works? Have you tried games?

    P.S. To restore the 2 boxes after the failed backup try to recreate the SD card from the provided empty image (storage.img.gz).

  • HI,

    I've managed to get around it by restoring the backup on your 8.0.0 build and then updating to the November 25th devel. But even after restoring the backup some settings are lost. Time zone, location, weather. Small crap. I have not noticed any sound issues yet. I tired steaming couple episodes of a show from my server and everything seemed fine. I don't play any games on the box, and don't plan on it.

    Again, thanks for making the builds!

  • Thanks for the feedback.

    Just in case anyone is going to play with the new RetroPlayer feature, I'll post some MX2 specific experiences:

    First of all, yes it actually works and the MX2 hardware is powerful enough to handle emulation of most systems up to the Playstation (though not all PSX games are running at full speed).

    In order to achieve reasonable performance you need to disable the rewind support in the global games settings. Basically only 8-bit systems are fast enough even with the rewind support enabled.

    You need to pick the right emulator for every platform, preferably optimized for mobile devices (ARM).

    Here are the best cores to choose for playing on MX2:

    - Nintendo (8-bit): Since Nestopia is currently broken and only shows black screen, the best core is FCEUmm.

    - Super Nintendo (16-bit): SNES9x-2010

    - Sega Genesis (16-bit): Genplus

    - Playstation (32-bit): PCSX-reArmed (some games are slow)

    It is pretty cool to play e.g. Worms World Party (the PSX version) on MX2 in your living room! ;)

    Edited once, last by KOPRajs ().

  • @KOPRajs

    nice work!

    I've also got an old g18 very close to the Wetec Play (dvb-S2 similar avl chip).

    Years ago I was used to boot xbmc from sdcard. But this was befor the 3.10 Kernel.

    I've tested now 3 variants of configs with out any success. I could see in terminal (tty0) kernel is booting.

    setup: sdcard p1=FAT with aml_autoscript (3 variants) to start from sdcard, KERNEL (file) p2=squashfs (dd from SYSTEM) (also a try with ext3) p3=LABEL=LIBREELEC_DISK ext3


    echo "*** openELEC(g18ref) linux 3.10.X boot script ***"
    if fatexist mmc 0:1 KERNEL
        echo "booting openELEC from sdcard..."
        fatload mmc 0 82000000 KERNEL
        setenv bootargs "root=/dev/ram0 rdinit=/init boot=/dev/mmcblk0p2 debug"

    I've also tryed to start SYSTEM as a file from FAT.

    then I've build the whole 9.0 LibreElec for MX2 (gcc8: build kernel errors on asm)

    I've fixed it by using src from that patch:

    Patch "ARM: fix put_user() for gcc-8" has been added to the 4.4-stable tree - Patchwork

    for aml linux-95ba9d626c0fce672caa296f5911ab9190881642:


    flashed all to sd booted same result:

    kernel starts but i think it do not run the SYSTEM partition.

    I've also built a lot's of 3.10 kernels, but they also didn't start partitions.

    Could it be the bootloader? Maybe you could help me with a tipp?

    See the logfile:

  • I'm a step further now, deleting the nand table in kernel's device tree src, like the wetek play kernel patch do.

    Now I think am very close to start LibreElec's Sysroot. (written to sd part2).

    Please have a lock at the photo to fix my bootargs, to start SYSTEM :/

    thank's a lot ...