DVB-T2 (HEVC, H.265) with LibreELEC (ODROID C2, Raspberry PI 3)

  • Ich musste die SD-Karte wechseln und finde keine Sender mehr. Ich kann bei "Fourth "Vordefinierte Muxe zuweisen"

    Suggestion: generic all" genau dieses nicht auswählen. Habe nur Generic-auto, ganz viele Länder, auch Germany mit den ganzen Regionen. Wenn ich nun Germany Berlin auswähle und dann auf DVBT2 die Muxes ändere findet er trotzdem nichts, bzw. der Scan ergibt einfach nur einen Fehler.. Hat jemand vielleicht die Einstellungen für Bandbeite Constellation Transmission Guard Hierarchy etc. damit ich die manuell hinzufügen kann?

    Danke!

  • twokay : ich verstehe nicht wirklich was nicht funktioniert ...

    .

    Die Einstellung bei mir für z.B. DasErste HD in TVheadend Server Konfigurationsmaske erreichbar über den rowser mit http://<ip-adresse>:9981

    Konfiguration -> DVB-Inputs -> Muxes

    .

    Dort ist der Mux 482 MHz für "DasErste HD" ausgewählt -> Bearbeiten zeigt:

    .

  • ... Raspberry Text from original Blog entry had to copied here, as text became to long:



    Raspberry PI 3




    Same configuration like with ODROID C2 but with this changes



    LibreELEC v8.0.1.MR


    .


    Test


    Before v8.0.1 MR while playing DVB-T2 top showed


    - Load is high ("load average: 4.38", should presumably be below 4 on the 4 core ARM CPU of the Raspi)


    - CPU utilization near 90% (see %Cpu0..3 .") but there are also still idle times "8.1 id to 10.5 id"


    - SD card mass storage seems to be no bottleneck as no wait IOs can be seen "0.0 wa"


    - also memory seems to be sufficient "326940 free" and no swapping "0 total"


    .


    With v8.0.1 MR this changed to


    - Load is lower ("load average: 3.60", should presumably be below 4 on the 4 core ARM CPU of the Raspi)


    - CPU utilization about 50% (see %Cpu0..3 .") and respective idle times "~40 id"


    - SD card and memory unchanged.


    - Main Processor temperatur is mostly above 80°C and below 85°C


    .



    top - 16:20:00 up 2 min, 1 user, load average: 3.46, 1.45, 0.55


    Tasks: 143 total, 1 running, 142 sleeping, 0 stopped, 0 zombie


    %Cpu0 : 49.3 us, 4.2 sy, 0.2 ni, 42.5 id, 0.0 wa, 0.0 hi, 3.9 si, 0.0 st


    %Cpu1 : 51.5 us, 4.5 sy, 0.4 ni, 43.6 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st


    %Cpu2 : 53.2 us, 6.4 sy, 0.9 ni, 39.5 id, 0.0 wa, 0.0 hi, 0.1 si, 0.0 st


    %Cpu3 : 51.6 us, 5.1 sy, 0.2 ni, 43.0 id, 0.0 wa, 0.0 hi, 0.1 si, 0.0 st


    KiB Mem : 753328 total, 376012 free, 181224 used, 196092 buff/cache


    KiB Swap: 0 total, 0 free, 0 used. 516376 avail Mem




    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND


    537 root 20 0 873800 163204 32512 S 217.2 21.7 4:10.68 kodi.bin


    512 root 20 0 332608 27128 9076 S 7.6 3.6 0:11.31 tvheadend


    107 root 1 -19 0 0 0 S 1.4 0.0 0:01.44 VCHIQ-0


    770 root 20 0 2820 1656 1444 R 0.3 0.2 0:00.22 top




    LibreELEC:~ # cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq


    1200000


    LibreELEC:~ # cat /sys/class/thermal/thermal_zone0/temp


    84358


    LibreELEC:~ # vcgencmd measure_temp


    temp=84.4'C




    .


    Next step test over clocking (to be done) ...




    mount -o remount,rw /flash


    vi /flash/config.txt


    # where changed


    arm_freq=1350


    core_freq=500


    over_voltage=4


    disable_splash=1


    :wq


    reboot




    # current main processor frequency


    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq


    # maximum main processor frequency


    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq


    # current main processor temperatur


    vcgencmd measure_temp


    # current main processor temperatur


    cat /sys/class/thermal/thermal_zone0/temp




    .




    Deprecated Stuff



    Bluetooth keyboard (apple)


    Keyboard is needed to get wifi connection running, to avoid timeout [Error: Invalid arguments] with WPA key input. As no wifi is available on ODROID C2 and also bluetooth is missing this is not an issue.


    .


  • Danke, genau das meinte ich! Wenn ich alles auf Auto habe, findet er den ZDF Mux nicht, der ARD-Mux ging jetzt nach dem 50-sten Mal. Anscheinend ist bei mir, obwohl direkt in Berlin, das DVBT2 Signal sehr schlecht. Würde also gerne die Sender händisch eingeben mit den ganzen Werten, weil gibt ja nur die 2 unverschlüsselten Muxe.

  • Btw. the Xbox One Digital TV Tuner is a very cheap DVB-T2 capable tuner which is being supported by LE since 8.1.1 Beta. The tuner is about EUR 13,- on Amazon!

  • I followed the instruction of Melibokus and it worked out very well for me :)

    To avoid issues with DVB-T2-stick I did lots of researches, to find out which one is available (affordable) and which one is supported by Libreelec. Finally I purchased a Geniatech T230C (~30 €) which worked out of the box with Wrxtasy's Media Build Edition.

    As I connected a 2.5" HD-Drive and a DVD/Blu Ray Drive I have to use an external powered USB-hub. I experimented with direct connection to Odroid but it did not work.




    Thanks for this really helpful and very comprehensive instruction :thumbup:


    Fasterix

    Edited once, last by Fasterix ().

  • Helo, please anyone has backup of raybuntu's repository? The link from github seems to be dead.


    He's working on CoreElec now, you should be able to find builds of his that are still maintained there.

  • Hi there,


    thanks for your great work, I want to set up my Odroid C2 with August T210 stick exactly like you wrote it.


    Unfortunately I'm stuck with getting tvheadend server and client as raybuntus repo is somehow ... down. I already tried to use repository.kodinerds.zip from raybuntus CoreELEC repo, but it doesn't work.


    Is there a way to get tvheadend server and client?


    Any suggestions highly welcomed.

  • Hi Mickey450,


    unfortunately I was not working on oerlie project intensively in the last months and am not up to date with solutions for the ODROID TV-stick driver topic.

    My current working solution uses the latest Raspberry PI 3 B+ as tvheadend server, where the USB stick runs out of the box. ODROID is only the tvheadend client in order to have its hvec decoding capability available. By the way due to lates improvements in libreelec software and Raspberry PI 3 B+ increased computing power a configuration with Raspberry PI 3 B+ only is near to day2day useabilty. Last remaining problem is some judder (ger: ruckeln) eg. with landscape pans (Landschaftschwenks, d.h. bei schnellen Bildbewegungen, auf deutsch wär's doch einfacher:-).

    Zurzeit plane ich wieder tiefer einzusteigen, wenn libereelec 9 bereit ist. Auf dem Raspi migriere ich gerade dahin (kämpfe aber noch mit IPTV).

    I currently plan to proceed with the project when libereelec 9 is available. I moved to libreelec 9 alpha 8.90.6 on Raspi, but struggle with IPTV implementation.

  • Currently I work on the migration of my installation to libreelec 9 alpha, where some rework on the former IPTV pipe solution is needed, as ffmpeg which was available with libreelec 8 directory /usr/bin is currently not available with libreelec 9 alpha (but probably in future as mentioned in this post by CvH ) .

    My solution is inspiered on the kodinerds m3u lists and uses the ffmpeg binary from ffmpeg-tools addon as suggested by CvH below. Two commands have to by issued on command line interface:

    • cd ~/downloads
    • wget bit.ly/kn-pipe-tv
    • sed s/usr/'storage\/.kodi\/addons\/tools.ffmpeg-tools'/g kn-pipe-tv >kn-pipe-tv-adapted

    Finally add/change in tvheadend IPTV server configuration (port 9981) under

    • >Configuration>DVB Inputs>Networks>[network] Edit>
    • URL: file:///storage/downloads/kn-pipe-tv-adapted

    In addition a configuration hint as I assumed today (after switch to winter time last night) some time trouble.

    Time server is configured with libreelec configuration using the service of the Physiskalisch-Technische-Bundesanstalt:

    • >Einstellungen/Configuration>Libreeelec>Einstellungen>Netzwerk>Zeitserver (NTP)
    • Erster Zeitserver: ptbtime1.ptb.de
    • Zweiter Zeitserver: ptbtime2.ptb.de
    • Dritter Zeitserver: ptbtime3.ptb.de

    Edited 4 times, last by melibokus ().

  • that isn't working anymore, you need the ffmpeg-tools addon + change the path to that

    ... oops, you are right - but the description above does already consider the ffmpe-tools addon. So I changed the hint concerning the "Emby addon".