FFMPEG path tvheadend on Libreelec

  • Hello I have HTS Tvheadend 4.2.5 ~ LibreELEC Tvh-addon v8.2.113 , on my Evolveo H8 android box. I installed Libreelec on SD card and from it booting KODI 17.


    I have m3u IPTV links and some one FAILED scan on MUXES screen. I have find solution to decode links by script:


    Code
    1. pipe:///usr/bin/ffmpeg -loglevel fatal -i INPUTLINK -vcodec libx264 -acodec aac -strict -2 -mbd rd -copyinkf -flags +ilme+ildct -fflags +genpts -metadata service_provider=STRING -metadata service_name=STRING -f mpegts -tune zerolatency pipe:1


    I try but dont know if it work or not. I like to know if you can help me find path to FFMPEG , or if it is not installed how to install it. thank you.

  • This won't work, you need an full featured ffmpeg binary that is not available at LE.

    Temp workaround, install Emby Server addon, it has an ffmpegx that could be used for piping.


    pipe:///storage/.kodi/addons/service.emby/bin/ffmpegx


    An ffmpeg "addon" is at work for LE9.

  • Can I install FFMPEG addon in LE 9?

  • As with most Linux programs <program name> -h should give you the commands to use. Alas some don't, so if it doesn't work try ffmpeg --help

  • Yes I tried this

    Quote


    ffmpeg -i mystreamip -vcodec copy /root/channels.mp4 -t 00:00:59

    and recorded very fine..thanks for adding ffmpeg addon. how can record from pvr simple using ffmpeg :shy:

  • Hi,

    I would like to ask how can I use ffmpeg in TVHeadend with PIPE?

    I need to insert my URL stream like this one, but does not work for me.Do I have to change the path for ffmpeg or something else?

    Code
    1. pipe:///usr/bin/ffmpeg -loglevel fatal -i http://my_stream -vcodec copy -acodec copy -f mpegts -tune zerolatency pipe:1
  • You need to change the path to the ffmpegx location. Just (re)read this thread.


    this just works if your playlist is manual created, the majority is just some url that get updated


    a "proper" (in terms of workaround) fix ffmpeg: add compatibility script by CvH · Pull Request #3163 · LibreELEC/LibreELEC.tv · GitHub to add the possibility to use standard linux paths

    I solved my issue with the following steps :

    First I installed ffmpeg-tools. Then just wrapped and insert my url streams in tvheadend like this

    pipe://ffmpeg -v fatal -i http://my/stream -vcodec copy -acodec copy -f mpegts pipe:1

    Everything works flawlessly.