[7.0.3.012l] LibreELEC 7.0 for S905/S905X

  • Do you understand the word "patience"? I now have almost 0 time for developing, let alone testing. For the impatient I prepared a build with updates from 8.0 branch 2 days ago (no audio changes yet): 7.0-devel


  • Do you understand the word "patience"? I now have almost 0 time for developing, let alone testing. For the impatient I prepared a build with updates from 8.0 branch 2 days ago (no audio changes yet): 7.0-devel


    [hr]


    Thank you so much for "your Patience"


    Patience:The ability to wait, or to continue doing something despite difficulties, or to suffer without complaining or becoming annoyed:

    Edited once, last by kostaman ().

  • Hi kszaq


    thanks for this build !


    My first impressions :
    - huge sound "crack" when LE starts (using a sound bar w/ optical)
    - GUI starts at 59.94 the first time, but can be changed to 60 fps


    I tested a few x264 / x265 files using NFS, playback is perfect (not a single skip / drop and 'pc' stays at 0).

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

    Edited once, last by Fredouye ().

  • I tested "http://kszaq.libreelec.tv/s905/7.0-devel/" with 4k hdr videos:


    4k 24hz many little stutter
    4K 50hz no video out.


    Better overall image sharpness.

    Edited once, last by saltanar ().

  • After more testing (~ 20 1080p files, x264/x265, 23.976 and 50 fps, passthrough to SPDIF), I downgraded my 2 S905X boxes from 8.0.1 to this build ;)


    - absolutly no stutter (even with LE >= 8.0.1c I had some stutter when seeking into a file, or bringing up the OSD)
    - picture quality (black levels, contrast) on par with 8.0.1c


    The only minor issue for me is the sound "crack" when LE boots.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • I'm also back from LE 8 to this almost perfect build.
    I had three freezes with 1080p x264 video. In the middle of video freeze and few seconds after black screen. Need to unplug device from power. It happened also on disabled temp sensor version.
    I checked my settings and realized that Sync playback to display was active. Maybe this one gave me freezes.
    Kszaq says it used default advancedsettings with 175 ms audio delay for 24p playback.
    Default setting for 24p is 125 ms


    (display has 125 msec latency at 23-24 Hz)
    advancedsettings.xml - Official Kodi Wiki


    I did some tests on few videos and the delay in my case is definitely 125 ms.
    Most files stays in sync (expect video files E-AC3 streams) that need manual adjust in video settings.

    TX5 PRO S905X

    Edited once, last by yatoya ().

  • You are quoting an example here, not a default setting.


    I'm quite sure about 125 ms and no, it's not an example in this case.
    I did test with advancedsettings.xml script with values 0, 125 and 175 and this:


    does the job but I like to be precise so I compared sync on a couple of videos and the 125 ms is the proper value if advancedsettings script is not present.
    I'm not questioning kszaq. I'm just saying that on my box it's 125 ms delay.
    Maybe someone will find it useful.

    TX5 PRO S905X

    Edited once, last by yatoya ().

  • Here's a new build I did based on kszaq's source after downgrading from LE8 due to 10 bit color (krypton cuts 10 bit color down to 8 bit initially resulting in some noticeable banding with 10 bit sources and other issues).


    This is using the current kernel and LE8 changes (up to 8.0.1h + 1 commit) of kszaq's merged into his LE7 branch, including the "always render gui," drain, and audio patches.


    This also includes the patch for 2160p 4:4:4 support, so if you've run LE8 prior to 8.0.1h and had 2160p issues with the patch in place, it isn't for you. I can't replicate the reported issues and need this patch for some of my uses, so kept it in.


    LibreELEC-S905.arm-7.0-devel-20170424235814-r23789-gc49f56a.tar | openload


    This is the best picture quality my box has ever had (Krypton definitely has some downfalls for these amlogic devices). Thank you kszaq!

    Edited once, last by blinkmxq ().


  • Thanks for this build, I'll test it later today (current 7.0.3.12 with Nougat kernel being IMHO the best build to date) !

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND


  • I have installed 8h on internal. Is it somehow possible
    to get back to 7j and how?


    I think you just to burn 7j to an SD card, boot from it and then run installtointernal (this will format your system and data partitions).

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • I think you just to burn 7j to an SD card, boot from it and then run installtointernal (this will format your system and data partitions).


    Okay, but that is just a new installation and reformatting everything.


    Is not there a way to do it without losing all addons, libs, ... etc.?

  • Okay, but that is just a new installation and reformatting everything.


    Is not there a way to do it without losing all addons, libs, ... etc.?


    Take a look at the /storage/.kodi/userdata/Database folder, you may have some backups of your 7.x installation.

    2 x Mini M8S II S905X 2 Gb/8 Gb @ LibreELEC 8.2.3.1 running from NAND

  • How can I install your build on a SD card? Ive been using img.gz files and Rufus but this one is *.tar and I cant find a way to install it.
    P.S. Did it using update. Testing now.

    TX5 PRO S905X

    Edited once, last by yatoya ().