Create remote.conf from scratch

  • I´m talking about keyboard.xml stored in /Userdata/keymaps/ and remote.conf stored in config folder.

    Both files working together, but I don´t know how.

    Just downloaded the package and followed instructions to install

  • I tried on a Minix U1 but when I type dmesg-c no code is shown (like in the previous post relative to Minix U9). Anyone knows how to do?

  • I followed steps 1 and 2 exactly, but when I attempt to type remootecfg remote.conf into KiTTY, I receive this error:

    Open file remote.conf is failed!!!

    What am I doing wrong?

  • I had the same problem. Try

    remotecfg /storage/.config/remote.conf

    Alternately, you could probably cd to the /storage/.config directory and the provided example should work. The problem is that your dev doesn't have a symlink to the remote.conf file to make it universally accessible from anywhere (at least, I believe that's the problem).

  • Thanks for this guide!

    I have a WeTek Pro Remote, and using this guide, created the following remote.conf:

    May look into swapping one of the buttons to open the search dialog box, but other then that, VERY SATISFIED! Cheers!

    Edited 2 times, last by twf85: corrections ().

  • Hi!

    Maybe somebody here can help me.

    I have Xtreamer Whizz and I upgrade it to LE 8.2.

    Couldn't find remote.conf so I decide to make it from scratch.

    I do everything like in manual, but when I send dmesg -c, I got different kodes in reply, depend of the key I press on the remote.

    remote: Wrong custom code is 0xXXXXff00 (XXXX is changing depending of key)

    So I can't get factory code.

    Any suggestions?

  • Hi there!

    I own an Beelink Mini MX Ver 1.0.

    (2G/16G Amlogic S905 Quad Core 2.4GHz/5.8GHz HDMI 2.0 Bluetooth 4.0 Support Gigabit LAN)

    At the moment i'm running [] LibreELEC 8.2 for S905/S905X on the box. I installed it to internal memory and it's working like a charm!

    My question is... the remote I'm using it the following remote. But it's not working that great anymore. Some buttons don't react every time I use it...

    And I would like to have a remote with some more function-buttons so I could program them to do some other kodi-functions.


    I have a few questions...
    Can I just buy an other remote? What remote do you guys advice? How do I get kodi to recognise the remote?

  • You will have to search this forum, some time ago, someone using a Logitech 650, set it up using the Pivos xios profile, the pivos has play stop buttons. then you have change the codes, search setting up a remote from scratch. I have forgotten how to do this.

    Or, you could install coreelec, it used to come with some preinstalled remotes, but the latest version, you need to ssh to re enable them

    I used a Mecool KIII profile on my Logitech 350.

    Or just get a wifi remote with llearning functions

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • Hello, anyone can help me to work the remote in x96 mini after installing atvXperience ROM! so here is the LOG attached for the android from this command when I connected with ssh:

    logcat -v time -f /dev/kmsg | cat /proc/kmsg > /sdcard/log.txt

    I changed the factory_code to 0x40400001 but nothing works after reboot! Also I tried keymap addon in kodi and also nothing happens : /

  • Hello, anyone can help me to work the remote in x96 mini after installing atvXperience ROM!


    No Libreelec or anything similar on the device so why you'r asking for Support Here?

    Maybe better to ask your question at the atxXperience Forum ;)



    Edited once, last by Nicolas ().

  • Thanks for replying, I thought it's a thread for creating remote conf from scratch :) I posted a problem linked to it! Is the ROM installed important to someone's problem ? Sharing knowledge is independent of what you offer to people. Thanks for your comprehension.

  • Sharing knowledge is independent of what you offer to people.


    Maybe I am wrong, but I am Not Sure configuring a remote on Libreelec works the Same way as on AndroidTV...

    So, maybe better to ask on the Support Forum from the Software you are using.

    For example...

    On Libreelec some Buttons working on 9.0.2 are Not working on 9.2.1 anymore due to some Changes.

    But, maybe someone can Help.