[SOLVED] Chromiun addon crashes on certain sites (including Amazon)

  • Hello,


    i`ve installed a fresh image of LE master from yesterday and then installed the latest chromium addon from Kodinerds repository (Chromium v55.0.2883.75).


    On certain sites (including Amazon.de/Amazon.com) I get an error from chrome itself: "Aw, Snap! Something went wrong while displaying this page".


    I do not get more information about the exact error, only a link to google for solving it (clear cache and so on - but does not help).


    Sites like LibreElec.tv and Google work normally.


    Settings are at default. Only rendering is changed to AMD and "default" due to an AMD APU.


    It`s a complete fresh install.


    Is this a known bug? Can anyone reproduce this ?


    Thank you !

    Edited once, last by Thomas233 ().

  • Yes it is a known bug. Chromium version in Libreelec 7.0.104 is broken, I would like to roll back to version 7.0.103 which worked fine but so far I have not had a reply if this is possible or how to do it.

  • Hi marv,


    yep that works :):D thank you !
    [hr]
    The only thing is: I cannot get hardware accleration to work. I have an AMD 5350 APU. Changed settings to hardware accleration "AMD" and "force" or "default" in chrome addon config, but chrome stays in software accleration mode. Therefore I have no smooth playback and also no HD signal for Amazon Prime.


    Do I have any chanches to get hardware accleration work with this APU and LE ?


    Thank you !

    Edited once, last by Thomas233 ().

  • Yesterday I managed to find an old openelec v 6.0.7 based on Chromium 48.0.2564.82. I enabled VDPAU in the options, copied in the chrome DRM .so file and it works fine. Video play back of Netflix is smooth and no tearing.

    • Official Post

    p.s. If you are installing a Chromium add-on from the Kodinerds repo, please ask Kodinerds for support.

  • Thank youI
    installed this -
    "@ marv_el
    can you try this chromium version?
    https://www.dropbox.com/s/agwsduci3h2tde...4.zip?dl=0 "


    No more Aw snap error but flash did not work so installed the following -
    "@ LaLadaI had the same problem. I solved it this way:
    1) Download https://fpdownload.adobe.com/pub/flashpl..._64.tar.gz
    2) Unzip the file libpepflashplayer.so
    3) The Copy libpepflashplayer.so to /storage/.kodi/addons/browser.chromium/bin/PepperFlash/ "


    Chromium and flash work, and no aw snap error.


    Thank you, thank you, thank you!

    Edited once, last by mxlance ().

  • Groundhog Day..... :D - the "AW Snap issue" is back (with Amazon Prime and LibreELEC repo Chromium Addon).
    Is there a chance to see a more recent version of chromium @Irusak ?


    Many thanks in advance
    debutanker

    Edited once, last by debutanker ().