Tvheadend nightly builds for LE

    • Official Post

    it is not dead, but its not well maintained at the moment, perexg is really missing :)


    From the stability point of view VDR is perfect but the whole tools are garbage from 10-15 years ago and the whole eco system (ofc some extensions are modern) is still in 2005. If VDR would enclose some plugins (like satip and vnsi) and finally add some proper webinterface it would be already in good shape. But unlikely to happen because the maintainers are also still in 2005.

  • I’ve been using tvheadend for quite a while. Without major complains.

    Good kodi integration.

    Spawning ffmpeg for stream transcode and using m3u playlist to access the channels in my mobile devices. ( there’s a very good client for idevices in the Apple Store ).


    Been keeping tvheadend updated with the nightly builds, or my own builds taken from GitHub.

    It is true that no official new versions had Been released, but 4.3 betas are very stable.


    No interest here in changing 😉

  • Spawning ffmpeg for stream transcode and using m3u playlist to access the channels in my mobile devices.

    Does Tvheadend have a way to transcode a recording from MPEG2 to H264 on disk (not on-demand via a stream profile)? I think that's the one thing it was missing for me when I looked at it a 4 or 5 years ago. I think it was hacky like MythTV's transcode, except the transcode solution I have in MythTV also broke commercial skipping.

  • I use tvheadend for 8 or 10 years and I like it very much.

    I have some problems with tvheadend4.3 in DVB-S, The same does not find all the frequencies found in tvheadend4.2.

    In both tvheadend I have a problem with the lack of audio audio in some channels.

    Tried help on the kodi forum.

    Audio stream none

    More without solution.

    If anyone here can help to resolve it, I will be very grateful. :thumbup:

    It is useless knowledge if not shared the world.

  • Does Tvheadend have a way to transcode a recording from MPEG2 to H264 on disk (not on-demand via a stream profile)? I think that's the one thing it was missing for me when I looked at it a 4 or 5 years ago. I think it was hacky like MythTV's transcode, except the transcode solution I have in MythTV also broke commercial skipping.

    Nope. For transcoding recordings I had to create an addon for kodi that uses nginx to serve a cgi that spawns ffmpeg to list and transcode files from a directory.

  • Please, tell me more (the only stream profile I ever managed to use is "pass")

    A way to do it is to create your own small script...not sure how your setup is but you might need to create 2 profiles...1 for your MPEG2 streams that will run the script to transcode,comskip or whatever you want to do with your recordings and another for your h264 streams to leave as is...

    If it was for my personal usage I will go another way...just leave 1 profile for all recordings and set script to do what you want...using ffprobe...ex if video_codec = MPEG-2 video then continue script and run ffmpeg command else exit script..

  • Sorry, I was referring to (what I think is) real time transcoding of live tv (stream profiles/codec profile) in order to serve lower bitrate content to mobile devices connected to cellular data. I never managed to configure that in tvheadend, I'm not sure it's possible at all on a tv box (e.g. the "webtv-h264" codec profile is disabled and cannot be enabled).

  • Sorry, I was referring to (what I think is) real time transcoding of live tv (stream profiles/codec profile) in order to serve lower bitrate content to mobile devices connected to cellular data. I never managed to configure that in tvheadend, I'm not sure it's possible at all on a tv box (e.g. the "webtv-h264" codec profile is disabled and cannot be enabled).

    Not sure what you mean by disabled but the last time I looked it was a bit confusing..I am on Rpi but codecs available for transcoding in tvheadend for rpi don't work with Rpi..like libx264 encoder...I only managed to get OMx to work but not with stream transcoding....just with recordings and that was not through codec profiles but through ffmpeg command..so something is broken or Im doing something wrong..

    Regarding transcoding I did manage to make it work with tvheadend stream urls and ffmpeg pipe but rpi struggles so I gave up...was more for experimenting then that I need transcoding..

  • There's an issue with Subtitles on TVH 4.3 which are not displayed on some TV channels. The settings (all I could find) is exactly the same as on TVH 4.2. The affected TV channel's Subtitles has different look (font type and size) on TVH 4.2 in comparison with Subtitles on other channels.

    Does anyone know why this happens (the different Subtitles look ) and what should I check / configure to make it working on TVH 4.3 (to display Subtitles on affected channel)?

    Edit - VLC is able to display the subtitles properly.

    Edited 3 times, last by ghtester ().



  • so it's not just me ;)

    If you r using rpi that wont work..just delete that libx264 profile..you are supposed to create new codec profile with omx_h264..then set that when you create new transcoding profile but even that is not working..only audio is transcoded and no video..I m sure it used to work before with older builds..As I understand it..Tvheadend uses it s own ffmpeg build and something is broken there as Omx h264 works on Ffmpeg provided with Libreelec

  • No, it's not an rpi, it's a tv box based on the amlogic S905D

    You can probably transcode too but don't use the codecs profiles cause I m sure CVH told us they are broken on some post few months ago..

    Use FFmpeg pipe options..

    Just create new streaming profile choose mpeg-ts spawn/ built-in and add your ffmpeg command in their or by a script..

  • AML S905 does not have the horsepower to do "proper" transcoding. AML has a GPU encoder but no driver for it because AML does not care :D

    remuxing ofc is easily possible, so *.ts -> *.mkv etc is no problem

    On rpi it just works for few minutes then it just stops

    Code
    [  ERROR] spawn: Exiting normally, received signal 15.

    when it works it works fine no buffering or any issues