Tvheadend nightly builds for LE

  • the folder 9.0 contains builds for LE 9.0 (currently 9.0.x)

    I hate to sound like a broken record, but could you kick the build system to build a newer tvh for 9.0?

    Otherwise, is there an easy way to just cross-compile it without building the whole distribution?


  • but could you kick the build system to build a newer tvh for 9.0?

    not that easily because my build server has just limited resources and I can't build 9.0 + 9.2 at the same time due storage problems

    Otherwise, is there an easy way to just cross-compile it without building the whole distribution?

    yes (first time ~1h, second time with filled cache ~2-3min)

    git clone LE-Tvh
    cd LE-Tvh
    git checkout 9.0/tvh-4.3
    PROJECT=Generic ARCH=x86_64 scripts/create_addon tvheadend42

    ^^^ example for Generic, for other archs see here Compile []

    then edit packages/addons/service/tvheadend42/

    change PKG_VERSION to the commit from Tvheadend git

    PKG_VERSION_NUMBER is not that important but could be manually adjusted too

  • Hotbird 13E

    With Tvh 4.3 there is no sound on the MyZenTv 4K channel. With Tvh 4.2 there is sound on the MyZenTv 4K channel.

    I use Denon AVR .It also works with Tvh 4.3 when I connect it directly to the Tv. Sometimes the sound is cut of.

    Edited 4 times, last by crazyturk (August 15, 2019 at 9:10 PM).

  • Guten tag CvH,

    I've been having a crack at compiling TVH43 myself and wondered if I could get a few tips from your good self.

    I changed the PKG_VERSION to use tvh master commit ebb0968 from 2/8/19 (as that was presumably the one you used to compile 1804 for the RPi4) but didn't change any of the rest of the code base for the package.

    The compile failed applying patch 2, patching include path libhdhomerun/hdhomerun.h to hdhomerun.h in tvhdhomerun_private.h.

    I modified the patch to change the path for this include in the correct files.

    Patch 3 was no longer needed so was deleted.

    Do you use any newer/older commits for any of tvh43's dependencies such as libhdhomerun, or have you built from exactly the same commits that LIbreElec used for tvh42? If so, which dependencies did you use or think was a good idea to use?

    Vielen dank,


    Edited 3 times, last by sihy: More detail. Removed waffle. (November 13, 2019 at 7:37 AM).

  • Unfortunately it sees the HDHomerun quad tuner but won't find some of the services from some of the muxs - ah well, back to the drawing board!

    Also, a test recording started then stopped after a minute or two with the SNR for the tuner at 0%. Reverted back to TVH4.2 and all seems back to normal. I guess I should just leave the compiling to the experts!




    For anyone else finding this, the TVH43 HDHomerun issue can be fixed with the patch here: Bug #5689: Low signal channels cannot be tuned in HDHomeRun - Tvheadend

    Edited 3 times, last by sihy: Status update Fix for HDHR issue (November 20, 2019 at 11:40 AM).

  • Hi CvH,

    I have your latest 9.2 build 4.3-1854 ~ v9.1.901.444 installed and working well.

    The kodi addon updater is saying that the LE add-ons repo has a newer verson

    Are you able to bump the version number in the next 4.3 nightly to avoid accidental update in the interface?


  • the folder 9.2 contains builds for LE 9.2 (currently 9.1.002)

    - we have there no AML anymore (till LE10 with proper new drivers/kernel) so there are no builds for LE9.2 based at aml

    the folder 9.0 contains builds for LE 9.0 (currently 9.0.x)

    I know the Wetek Play 1, having an Amlogic AML8726-MX chip, is not supported on newer versions of Libreelec,

    but i just wanted to experiment with it :)

    Using the Libreelec 9.0.2 build from here libreelec-wetek_play.arm-9.0.2.img.gz

    and the TVheadend build from here 4.3-1774-01.03.2019

    I can get the TVheadend server working fine on my Wetek Play.

    I can now view the various channels on my laptop - by logging into the TVheadend server residing on my Wetek Play.

    and I could also view the channels using TVheadend Client on my raspberry pi 2 (it runs Libreelec 9.2.0)

    But i can't seem to be able to run TVheadend client on my Wetek Play (the only client available in the repository is
    - the message i keep getting is that "TVheadend client is refused access to server", and device hangs on "PVR manager is starting up"
    I tried leaving the default http connection in the settings at but that didn't work,
    and I tried using the same URL as my laptop, including using the same username/password, but to no avail.

    Any suggestions?

    Edited 2 times, last by callagg2: ah, i got it sorted. i was using the wrong port :-( I should have been using 9981 not 8080. All working now :-) Thank you all at Libreelec for all the work you put in on this software - I know I certainly do appreciate it! (December 22, 2019 at 12:49 PM).