RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • escalade

    very nice build, love it!

    on my htpc i want to run virtualbox inside a docker image (for ugly Windows vms...). But this requires a running "vboxdrv" kernel module on host.
    Is it possible to compile this extra module for your build? :rolleyes:
    I think this would be a nice feature. Specifically for all, who want extra emulation and virtualization stuff... :blush:

    A working kvm in docker or something else, would be also ok. (needs another necessary module on host)

    Hope you, or someone else can help


    Edited once, last by scapulares (January 14, 2017 at 10:30 PM).

  • scapulares

    It's possible, but I'm not interested in doing it.


    - Fixed issue with audio device not being release by Kodi when launching Emulationstation
    - Updated ResidualVM

    I've also added a way to specify url to the .deb needed for installing Spotify in the latest release. When starting it for the first time, do so from ssh like this:


    The PKGBUILD I'm using to get the latest download url from is out of date and the old version seems to be removed.

  • I see, can reproduce here as well. Looks like the window manager isn't giving it focus. What you can do is press ALT+F10 to unmaximize the window, that seems to make the buttons work.

    Regarding your input, looks like you've upgraded from the previous build. I can't overwrite the configuration files during upgrades so you'll need to remove the old config to get the new one. Can't understand what's happening in RetroArch for you, as the controller seems to be detected and loads an autoconfiguration for the DS4.

    No I did not install by upgrade. Yesterday I spent ample time installing and hard resetting different versions all the way back to the 12-8(somewhere around there) build. And even openelec official and a alpha libreelec trying to get stuff to work. I eventually booted up my arch and used gparted to delete and format both system and storage. Extracted the update from the 13th put kernel and system with the md5 on system and rebooted to a fresh install. I have to manual install because I have LVM and the installers can't see past it. Before when I would "fresh install" it would be an update followed by hard reset but this time I had issue so I went the long way to ensure that it was a truly fresh install. I don't use residualvm and didn't know it was an emu. The log name sounded like it might have been a log you might have wanted so that's why I even mentioned it. In the builds that worked for me RetroArch would pop up with wireless controller (and dolphin in the controller config screen on the current build) which is a config file name. But in the RetroArch logs I posted it says similar to ps4 controller by bluez. I think around line 181. On my gdrive the file RetroArch-old is for absolutely fresh install and the ra log I posted today does have my ra.cfg in the config folder but that was the only file I added since I first posted about the input issue. During my self diagnosis I even broke out my old Dell Inspiron to test had same issue. I could probably get logs from that PC if you like. On the Dell tho I only was testing the dbus notification which also did not work

    Sent from my Nexus 6P using Tapatalk

    Edited once, last by MoHawka (January 15, 2017 at 3:08 AM).

  • Hello Folks,

    i've been wondering if it is possible to search only through this single thread, i didn't find any possibility. I wanted to know how i can ad the scumm Emulation to the emulation station menu. I know that i can add new entrys to the es_systems.cfg config file, but i don't know how the command line for the scumm core so the emulation station will scan my directory for my scumm games. The second thing on my pi3 is that when i quit the uae4arm than i only get a black screen. Is there any way to solve this problem?

    Thank you in advance.


  • MoHawka

    Well, the es_input.cfg you posted already contained the mappings of the last ds4 added to it, so it should have worked. As for RetroArch, you can try mapping it manually from the menus then generate an autoconfig and post that. 4.10 breaks ds4 mappings and will need a lot of fixing.

    DoC JoNeS

    For example:

            <command>sh %ROM%</command>

    Then you create /storage/roms/scummvm/monkey1.start:

    /usr/bin/retroarch.start -L /tmp/cores/ /storage/roms/scummvm/monkey1dir

    As for the uae4arm issue, you will need to post more information. What's the state of your system? Why is there a black screen, is Kodi not running? Look at /tmp/uae4arm.log, look at the process table, look at /usr/bin/uae4arm.start for clues.

  • Good job for the work escalade.

    Unfortunately, I can't install it on my atom pc.
    The installer doesn't start and displays this error message:

    systemd[1]: Caught <ILL>, core dump failed (child 229, code=killed, status=4/ILL).
    systemd[1]: Freezing execution

    Maybe, I need to try with Generic build.

    Have a nice day ;)

    Edited once, last by abobier (January 15, 2017 at 4:46 PM).

  • Can someone please tell me how to manually pair moonlight, I'm on latest libreelec repo version. Tried SSH by running ./ running normally fails to pair. Tia

    Sent from my SM-G925F using Tapatalk

    Edited once, last by dazzlerellis (January 15, 2017 at 6:01 PM).

  • Hi All
    Stumbled upon this build and so far it's great. I'm having issues with the sound in emulationstation.
    When I setup the asound.conf file my system never loads kodi, and kodi just loops a crash. I have to rename/remove the file and kodi loads fine.

    My kodi is connected to my screen via HDMI. My system has 2 HDMI ports and I'm sure I'm on HDMI0.
    I have my Kodi sound set to "ALSA: HDA Intel PCH, SAM SAMSUNG on HDMI" and audio works fine.

    I have edited the sample asound.conf to this:pcm.!default {
    type plug
    slave.pcm {
    @func getenv
    vars [ ALSAPCM ]
    # Device name can be found using the command 'aplay -L'
    default "hdmi:CARD=PCH,DEV=0”

    output from aplay -L

    hdmi:CARD=PCH,DEV=0 HDA Intel PCH, HDMI 0 HDMI Audio Output
    hdmi:CARD=PCH,DEV=1 HDA Intel PCH, HDMI 1 HDMI Audio Output
    Any help would be greatly appreciated.

  • Hi escalade,

    i've managed to load my scumm games via the retroarch core. You can launch the games once they were added in the scumm gui or manually in the /storage/roms/bios/scummvm.ini if you use a simple file with only a single line with the title of one of the sections genereted in scummvm.ini in double quotes (like "atlantis"). You can use these files as "roms" in emulation station config by using the command line "/usr/bin/retroarch.start -L /tmp/cores/ %ROM%". Just use the extension of the files you've generated before (like ".scummvm" or ".start"). Beside of this method the seems to only work with ".exe" files. That was what i found out searching for infos in different forums.

    The problem with the uae4arm maybe lies within the HDMI Settings change i can see in emulation station log:

    Powering on HDMI with explicit settings (CEA mode 31)
    Powering on HDMI with explicit settings (CEA mode 16)

    I get back to emulation station after quitting uae4arm but my screen stays black. I can hear the menu sound and even can go back to kodi blindly by pressing the menu butten, going down 4 times and then press the "select" button. After quitting emulation station i can see the kodi menu normally and if i start emulation station again all seems to be normal there again, too.

    Thank you for your help in advance.


  • SuperKing

    Post your /tmp/emulationstation.log. Do you get sound running "speaker-test" from CLI?

    DoC JoNeS

    Cool, that sounds like it will work better.

    As for uae4arm, you could copy the script from /usr/bin/uae4arm.start and then run the commands manually to debug the issue. I use "tvservice" to switch to 50Hz for perfect scrolling in Amiga games.

  • Thanks Escalade for the build I've been using it for the past week its great!

    Trying to get Sonarr working, I just noticed it needs mono to work, can anyone point me in the right direction?

  • Thanks Escalade for the build I've been using it for the past week its great!

    Trying to get Sonarr working, I just noticed it needs mono to work, can anyone point me in the right direction?

    There is an add-on in official LibreELEC repo.
    escalade: After final release of LE 8 and Kodi 17, will you continue to work on this build with nightlies of this software?

    Edited once, last by RShT (January 16, 2017 at 7:15 PM).

  • Thanks for this!! Looks awesome so far. I know it's a long shot but is there any chance we can get a LE Beta 7 release? I unfortunately have handshake issues(green static/screens) with RC3 which I can't seem to fix. When I use Beta 7 I'm clear of any issues.

    Maybe a quick walkthrough on how to compile one would also be amazing :)

    Thanks for your time on this!