RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • 20200604 images:

    • updated and fixed up cava
    • fixed up ncurses so there's proper color in terminal programs
    • added mupen64plus-next-libretro PR's that upgrades it to 2.1.0 and adds parallel-rdp
    • added ecwolf-libretro and boom3-libretro
    • tried to make a better moonlight icon (it's logo really sucks, anyone with artistic talent can make a better one?)

    Unfortunately, I'm experiencing some bugs with this build (generic), Steam downloads but cannot open afterwards. Cannot launch Emulationstation from within Kodi. Scraped games in Emulationstation are removed and have to redo scraping process after reboot/shutdown from desktop mode.
    Audio is working when PC's started (HDMI), but if i switch HDMI source on my TV and then going back to RetroELEC NUC the audio isn't working until next reboot.

  • escalade Could you please reenable the script that restarts kodi, as soon as it hangs? Kodi hangs a lot in your distro.

    Thanks that kodi is still included in your distro while it seems your focus moves to something else.

  • Hi Escalade,

    would you be willing to share you latest code (via github) ? I can't promise if I find the time to do it, but I'd like to look into the HDMI/CEC issue. The system is kind of useless for me, if I always have to go through a reboot when switching back to kodi.

  • escalade i see you have updated the Skylake versions, will you update your generic soon as well? At the moment the current generic version is pretty full of bugs, as mentioned above.

    Tried to boot / install one of your Skylake builds on my Pentium G4600 CPU based system (ASUS H270i motherboard), but once it got to the "please wait 5 seconds for the installer to run" boot menu, it just froze and I had to do a hard reset. Same USB key was able to install LibreELEC and your RetroELEC versions so doubt it's a USB issue.

    Edit: however, the HDMI bug seems to be "gone", ie it's not present on my G4600 setup, so could be a NUC thing (as mentioned on libreelec's frontpage, there seems to be an issue with audio and NUCs).

  • New generic build uploaded!

    - 5.8.0-rc5 (also updated firmware so newer nvidia cards might be useable now)

    - Added Spotify Connect functionality, run this command to enable: # systemctl enable --now librespot

    - Added Snapcast multi-room audio, to make your pc a client: # systemctl enable --now [email protected] (replace with your Snapcast server, can be if pc is the server) to make your pc a server: # systemctl enable --now snapserver (librespot will automatically pipe it's audio into the local Snapcast server if it's running)

    - Added Shairport Sync, to enable: systemctl enable --now shairport

    - Added gmrender (resurrect) DLNA, to enable: systemctl enable --now gmediarender

    - Some under the hood changes to Pipewire/GStreamer/Pulseaudio to make them all fully functional

    - Updated Retroarch packages, libretro cores, Mesa 20.2-git, RPCS3

    - Added ResidualVM emulator

    I also identified some issues with the Pulseaudio modules switch-on-port-available, that could cause issues when connected to an AVR or Soundbar. Hopefully that'll fix the remaining audio issues, there isn't any bugs with the NUC AFAIK.

  • escalade

    Thanks for the new generic image! I installed it, still having reoccurring issues even after a full wipe. I am running this on a m004u chromebox and have constant freezing with Wayland Desktop and Emulation Station (oddly Retroarch loads fine). I tried even bringing up youtube in Wayland and it mentions it is downloading firefox and nothing ever happens. Usually it freezes with Flickering though is this this hardware just not meant to run with these newer images? The icons on Wayland Desktop are all cutoff about halfway through the icons though Kodi displays perfectly. I enabled logging and here is my debug after a reboot: Retroelec emulation station and desktop freeze -

    I noticed for retropie emulation station they added back the OpenGL 1.4 renderer which I ignorantly assumed was the main issue and would be somehow injected into the Generic Images automagically. Add back OpenGl 1.4 renderer by tomaz82 · Pull Request #662 · RetroPie/EmulationStation · GitHub

    I have an Intel NUC that had the previous generic version which the hardware seems to be a little more compatible but I couldn't get the flatpack of Steam to work. Since the NUC I use as my main device, I will eventually roll out the other image hopefully next week..



    Edited once, last by chadj77 ().

  • @escalade

    I just installed the generic image on my intel 7th gen nuc. Looks fine so far but i have some issues with it. The steam client installation went fine but when it asks me to enter my steam account its lags terrible. I enter two or three letters but the are not shown. I have to click on the field field again to see them. Also entering a @ doesn't work. Another point is how can you do audio passthougth. I have a onkyo receiver connected via hdmi. What i need to do to get passthougth. The option in kodi itself ist grayed out. I also tried to connect a xbox wireless controller but that didn't work. Should this work out of the box ? For libreelec this was nessary to get it working. echo 'options bluetooth disable_ertm=1' > /storage/.config/modprobe.d/bluetooth-disable-ertm.conf



  • Hi, I'be recently installed the last available image in a Rpi4 2GB and I have to say it has been great so far. I'm specially fond of the pulseaudio BT codecs patch since with LDAC my headphone is so much better than with the standard Libreelec SBC.

    But now I'm trying to play 1080p HEVC 10bit videos and the only thing I can see are Kodi crashes.

    Is there anything I can do to fix it?

    I've uploaded a log here:

    Thanks for the work anyways.

  • Just tested this build and I confirm that EmulationStation can now be launched from within Kodi again. But, there's no audio in Emulationstation/Retroarch (but works in Kodi). Also, since the switch to Pulseaudio, there's no option to use Audio passthrough in Kodi so can't use my AVR properly.

    Edit: noticed that when the screensaver starts (noticed in ES), it cannot be removed by using the gamepad, a keyboard is needed to get rid off it.

  • Hello, very good ... I am new to this ... After installing retroElec, Emulation started but the xbox360 controller does not detect me, good or if it detects it but tells me not configured, how can I access to configure it? Thank you very much and I know that the same has been answered already .. but I can't find it ..

    Edited 2 times, last by ambit ().

  • EDIT: Resolved. Found default.cfg in ~/.config/retroarch/savefiles/mame2003-plus/cfg

    How to restore default mame2003plus in game keys on my RetroELEC installation on my Raspberry Pi?

    I stuffed up the in-game options key settings (the ones normally invoked eg. with TAB). I made 'select' Nul - which makes it a bit hard to fix things.

    But, I can't figure out in RetroELEC which CFG file to delete to revert back to default. RetroELEC seems to have slightly different paths to standard RetroArch/RetroPie.

    Which CFG file can I delete? I've tried /storage/.config/retroarch/retroarch.cfg but that didn't reset it. The keys on the mame2016 still work, so it's something core/system specific, but I just can't find it.

    Can someone point me in the right direction on RetroELEC?


    Edited once, last by kidhazy: solved ().

  • Has anyone had any luck trying to install the scraper Skyscraper GitHub - muldjord/skyscraper: Powerful and versatile game scraper written in c++ on RetroELEC on a RPI4 build?

    Given the RPi4 image is fairly locked down I couldn't do the manual apt-get install, and I couldn't get the wget install working either.

    I've just started to get back into retro gaming and want to get some of the Video Snaps to jazz up the EmulationStation frontend and SkyScraper appears to be one of the easy ways to scrape for the videos for the Mame games.


  • You cant install anything since it's so locked down, you'd have to re-compile with Skyscraper I believe. Never done anything like that myself so can't guide you through how to do it though I'm afraid.

  • Resolved: Found mame2003_plus core here index - powered by h5ai v0.29.0 ( Manual download and copy worked.

    Is it possible to get MAME2003_Plus core installed and working on the x86 Generic build?

    I've got a working RetroELEC build on a RPi4 with MAME2003_Plus ROMs and config. I was looking to see if I could easily transfer/build it on to a spare laptop.

    I've installed RetroELEC-Generic.x86_64-9.2-devel-20200716014709 build, but it doesn't have a MAME2003_plus core.

    I'm looking to reuse my existing MAME2003_plus ROMs (on a shared NAS), so looking to get the 2003_plus core installed on the generic build rather than a different set of ROMs.

    Is this possible?

    The RetroArch Online Updater interface on RetroELEC doesn't show the option to download cores, and I haven't been able to find it anywhere to download.


    Edited once, last by kidhazy ().

  • Comparing the RPi4 and generic x86 builds I've noticed that when switching between environments (LibreELEC/ES/MAME) on the x86 build it quickly switches to the desktop screen (with the car background) as it transitions between systems.

    I don't see that transition on the RPi4 build.

    Is that just a quirk on the generic x86 build, or is it something that can be configured to just display blank during the transition?

    I notice this when: selecting EmulationStation menu item in LibreELEC; Starting a MAME2003plus game within ES; exiting game/Retroarch and returning to ES. I don't notice it when I leave ES and Start Kodi via the ES menu.

    This is version 20200716014709 of the Generic.x86_64 build.