RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Dear Escalade,

    right now i installed your last image for my RPI 4. It's really awsome! Thank you very much for your hard work since so many years!

    Btw there are 2 things i found


    1. The installation procedure doesn't create the Storage Partition correctly. So i had to delete the unfinished partition on my sdcard and create it by myself. After this i had to correct the UUID in the relating init file. After this everything was working like a charme.


    2. In the desktop mode i am not able to change the sound output for my device. In Kodi the sound is working very well.

  • Samui


    Glad you like it :)


    1. I'm using F2FS for the storage partition these days, perhaps you were trying to mount it as ext4?

    2. Check that you have dtparam=audio=on in /flash/distroconfig.txt, it's needed to enable the ALSA driver so Pulseaudio can work. I think Kodi accesses the hardware directly.


    slacker666


    I'll have a look at the logs later a bit pressed for time atm.


    Bub4


    There aren't any upgrade procedures, this is a simple hobby project. The LibreELEC upgrade procedure doesn't touch the storage partition though, so losing any config is unlikely. No guarantees though, it might burn your house and give you covid19. Use at your own risk :P


    Shaboobala


    This build uses the "nouveau" open source nvidia driver, I don't think it supports the 1060 properly.


    Hydrosaure


    I still have a ton of uncommitted work and not enough time to clean it up atm. I've uploaded a backup of my source tree under the "src" folder on my gdrive. Fetch my latest arch-build container and I think it might have a good chance to build :D

  • quick question escalade .. any rec's on doing upgrades for your builds short of a re-install? or is it just backup the userdata folder, install to system drive, copy userdata folder back?

  • @JA

    This is the same problem happened to me. When i checked the file system on the sdcard in Linux, the F2FS partition was shown with an exclamation mark. There was no way to extend it. So i deleted the partition and replaced it with the standard ext4 partition and replaced the given UUID in the config file. After this the system was booting well.


    Edit: Installed the F2FS Tools in Linux and formated the partition again. Also had to replace the UUID again.


    escalade

    Thank you very much for your very fast reply with the solution for my small problem :)

    Edited once, last by Samui ().

  • escalade


    i am using an ASROCK J4105 with your generic image, too.. There is a DVB-S2 card installed. With the dmesg command i can see that my card is recognized.

    With the VDR addon, the system is crashing and rebooting in a loop, because the VDR VNSI Client cannot connect to the Backend.

    It shows connect - disconnect continious and after several tries the system is crashing. If i am installing the TVHeadend, i even cannot

    access it with my browser via the port 9981.

    Maybe you can give me a little support for this issue? Attached some logfiles.

    Files

    • Logfiles.zip

      (112.29 kB, downloaded 47 times, last: )

    Edited once, last by Samui ().

  • Okay. Decided to play around with that box again tonight. First thing, I updated to latest build by placing your image in /storage/.update .. worked like a charm.


    Next, like with previous build and this build GUI audio works fine right off the bat. However I tried to play a video and nothing. So i wanted to test your instructions of making it like vanilla LibreELEC by placing "KODI_AE_SINK=ALSA+PULSE in /storage/.config/kodi.conf". There is no file like that on my system. I tried to make a file and got this error.


    bedroom:~ # nano /storage/.config/kodi.conf

    nano: error while loading shared libraries: libncurses.so.6: cannot open shared object file: No such file or directory


    What am I missing?

  • bedroom:~ # nano /storage/.config/kodi.conf

    nano: error while loading shared libraries: libncurses.so.6: cannot open shared object file: No such file or directory


    What am I missing?

    I get the same error when trying to execute the "nano" cmd on my HTPC with the latest version (RetroELEC-Generic.x86_64-9.2-devel-20200420000513.img.gz), I suggest you revert back to RetroELEC-Generic.x86_64-9.2-devel-20200409214701.img.gz where it worked fine.

  • Hi Escalde, all,


    I've asked this question here before and also keep checking with Dr Google :"Firefox and non-latin fonts under wayland."


    Does anybody have a hint how to get FF to display non-latin (chinese in my case) fonts ?


    I've installed the complete Noto fonts package. They are shown as available in FF's preferences.

    But, FF does not render any chinese website correctly. All I get is those broken rectangle-like symbols.

    It works fine with my Ububtu Desktop under X - using the same FF.


    Any help/hint is appreciated.

    Edited once, last by mtk1 ().

  • pletopia


    You can create the file by simply doing echo KODI_AE_SINK=ALSA+PULSE > kodi.conf


    I've uploaded a fresh generic build which fixes the ncurses issue and adds a proper bemenu config, press ALT+D in Sway to activate. Also added a nice 4k Lamborghini wallpaper :)

  • Hi Escalade,

    I also installed your newest generic build right now, too. It's really fantastic with the additional desktop mode.


    Because i asked the question before and provided the logfiles also, i would like to ask you again. In your older releases were the dvb drivers included. Are they still in the actual builds or what else could be the reason for the issues i am having now with the TVHeadend and VDR?

  • You haven't provided the correct logfiles as stated in first post. I really have no idea about DVB or what's required. I'm quite out of sync with LE but I think everything should be included.

  • You are absolutely right, i am so sorry about the wrong logfiles. That was my fault!


    But right now i installed your latest release. With this one it is suddenly working!! You are the BEST!!


    But there must be a difference between this Image now - RetroELEC-Generic.x86_64-9.2-devel-20200424193105.img -

    and the other 2 images. Because they are crashing!!


    Also the release for the RPI4 before this one - RetroELEC-RPi4.arm-9.2-devel-20200423233226.img - crashed,

    when i activated the VDR VNSI Client. By the same way like the generic images before.

    Unfortunately i had no time until now to install and check this actual - RetroELEC-RPi4.arm-9.2-devel-20200423233226.img - release

    on my RPI 4 now but will do it tomorrow.


    Attached the complete needed logfiles from the working and the crashing image.


    EDIT:


    Installed right now the latest image for my RPI4 and enabled the VDR VNSI CLIENT for connect to my Asrock with your

    latest - working - Generic Image. Some seconds after enabled the client, the system is crashing and restarting Kodi in a loop.

    After disabled the client again, no trouble anymore. Maybe you can insert the changes like in the new generic image if possible there, too?

  • Using KODI_AE_SINK=ALSA+PULSE is a bad idea because Kodi will then attempt to lock the ALSA device. To allow this, there's some scripting that releases the soundcard from Pulse on Kodi start. It should be undone when closing Kodi, but I suppose this can be flaky.


    Bottom line, just use Pulseaudio. Once configured correctly, all applications will just work (TM). There's pavucontrol on the desktop, configure your soundcard there. Try booting from a clean USB stick, sound should just work (tested OK in vmware and on my NUCs).

  • Hi there is it possible to update the normal libreelec with this? Or do you have to do a fresh installation?