RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Gotcha. So double whammy here in that my CPU is not only too old, but the wrong architecture, and my GPU is too new.


    Guess I have some learning to do.

    My images are built and optimized for the Intel Silvermont architecture which is now 7 years old. Anything older than that probably won't run and you'll have to build for yourself. Newer generations of nvidia is not supported, as I'm now using the open source nouveau driver. Nvidia Wayland support just isn't there yet.

  • escalade


    Thank you very much. I just finished installing it and there were no issues anymore.


    <edit>Only thing I haven't been able to find yet is how to create a menu item for emulationstation in other skins. I was previously using a kodi command set with: XBMC.System.Exec(/usr/bin/emulationstation.sh)


    When I attempt this now nothing happens when I click the menu item. It launches fine when I use Estuary.

    Edited once, last by bdunning ().

  • Thank you. Installs fine now, but won't start.


    Docker and alsa-config service fails to start.


    Then hangs after Started Update UTMP about System Runlevel Changes.


    Let me swap out the vid card with something older...I have an 8800GT floating around I can test with.


    Failing that, thanks for the build, but this was a test to see whether the SW will do what I want. It wasn't the final HW I was going to use save for the video card.


    For the record, all my HW is as follows:


    Asus P6X58D Premium

    i7-970

    12G of RAM (just because it's what I had)

    1TB SSD off onboard Marvell controller

    GTX 1650


    EDIT:


    I've swapped the card and I now get a boot loop with last message of systemd-shutdown: Failed to finalize loop devices, ignoring. I did re-install after swapping that card with the same result.


    I have used a current build of Lakka by itself and it seems OK (running in live mode anyway). I'm going to test a standalone build of Kodi as well.


    All that said, if you're interested in trying to get it working, I'm willing to do whatever required. However, as it's not the end all be all HW I'll be using, no need to spend time working on a one-off.


    Thanks for what you've done already though.

    Edited 2 times, last by Railgun ().

  • thanks so much for the more vanilla build, i can get it to boot but the next question ive got is probably pretty rudimentary. How do I enable my game pad to work in emulationstation? Thanks in advance.

  • thanks so much for the more vanilla build, i can get it to boot but the next question ive got is probably pretty rudimentary. How do I enable my game pad to work in emulationstation? Thanks in advance.

    You need a keyboard and then you can navigate to settings (Ctrl key) in ES and from there choose "configure input" to configure your game pad.

  • Liquidmercury  Railgun


    Try this build: x86-64 – Google Drive


    It's compiled with -march=x86-64 like regular LibreELEC. Your mileage may vary with recent generations of nvidia cards though.

    Just tried this version and seems like you fixed the scraping issue in ES and also quit to kodi works now so that's great! However, it seems as when I start a game from ES it won't start just exits back to ES in a second (I see "Sway" showing up for a sec), but if I start the very same title from Retroarch it works and I can play. Any ideas what I'm missing?

    Thank you in advance!

  • was there an issue with rom scraping previously? currently when I attempt to scrape it spits something out at me but for the life of me cant remember what it actually says. I can look again if needed. Thanks in advance.

  • sorry to bug with seemingly mundane questions had your competitors build pretty much figured out but made the switch due to lack to development and I must say its very polished. Keep up the good work, but is there a genesis emulator included or is that something that I need to add via retroarch.

  • There is, but seems I forgot to add a platform for it in es_systems.cfg. I've uploaded a new build with that added, but after updating you'll need to add it to your local /storage/.config/es_systems.cfg, you can see the new addition in /etc/emulationstation/es_systems.cfg.

  • one more question for you, where do the bios files for say psx need to be located, ive got them in the bios folder but on launch it still says they are missing.

  • also one more question, having issures building the docker, im assuming thats needed for ps2 and such tried onece before and im having issues either that or i misplaced the bios files