[S905x] Tanix Tx5 Pro

  • Hi All,

    I think a dedicated topic for all Tanix Tx5 Pro owner is a good idea :)

    I'm new owner of this box... and i have install LE with a little difficulty and I succeeded thanks to this forum on kostaman Post

    At first small presentation for this box 

    TX5 PRO Amlogic S905X 2GB+16GB

    Operating System : Android 6.0.1 Marshmallow (last firmware Oct.2016)
    CPU : Amlogic S905X Cortex A53
    Processor : 1.5GHz
    GPU : Penta-Core ARM Mali-450
    RAM : 2GB DDR3
    ROM : 16GB EMMC

    Now For install LE in Tanix Tx5 Pro :

    Actually you have 3 method for install LE but just 1 work with Tanix Tx5 Pro (again thank you to Kostaman for explain) :

    1. Toothpick method: disconnect the power supply, insert card/drive, use a toothpick to push reset button and connect the power while holding the button. Wait until LibreELEC logo appears and release the button. Used With and Without Device tree. --> Failed (with just the boot animation and no further).

    2. Recovery method: boot into Android, insert card/thumb drive and choose Reboot to recovery.(Had to use an APP)
    Your box should boot into LibreELEC. --> Failed 

    3. Recovery method (take 2nd variant): if you have "Update" app pre-installed open it, insert SD card with LE/connect USB drive, and choose any ZIP file in the app for update. Your box should reboot to LE. --> Worked

    Just imput a Fake.zip in your SD Card with LE, go to update app on android, Select Fake.zip and press Update.
    The box restart and install LE on SD Card

    This method work successfuly for LE Jarvis or Krypton

    Concerning my experience on the different Build (Jarvis or Krypton).
    At First for test i have install JARVIS all work perfectly (just a small problem for turn on wifi for test but i use RJ45) -> Install with "Clean Install with RUFUS"
    Second Update Krypton i have try to update Krypton --> Failed box wont boot on SD Card
    I try Clean Install with RUFUS --> Worked

    Actually i run Krypton on my SD Card and all work perfectly Wifi / Addons / Skin / DB ect...

    Last Point : The Remote

    Tanix Tx5 Pro have a "simply" remote without Play / Pause / Stop button It's boring with LE for good multimedia experience.
    Personnaly i have a Logitech Harmony.
    Logitech Harmony know Tanix Brand and Tx5 Pro Device that is good :) but always not Play Pause Stop button :(
    For resolve that a small trick add device MCE keyboard (or Windows media Center) on your Harmony and configure Play Pause Stop button with (need add USB IR Recever on your tv box) Worked Perfectly

    ps : Sorry for my bad english hope all it's clear :)

    Edited once, last by Deki (December 8, 2016 at 7:44 AM).

  • #483

    TX5pro-9377卡刷 – Google Drive

    26th October 2016 Firmware SD Card Flash.

    Flash at your own risk.
    What a Nightmare
    I just found out from our Russian Friends at 4pda.ru
    There are 3 Different wifi modules for the TX5Pro : Qualcomm QCA9377 or QCA1023, Ampak AP6255 or Fn-Link 8223A
    Instructions below link.
    Check your module Tanix TX1 /TX3 / TX3 Pro / TX5 / TX5 Pro [Android] - 4PDA
    Command dmesg | grep -i 9377
    You will get something like what i got below. :D

    root@p212:/ # dmesg | grep -i 9377
    [ 86.902191@1] WARNING: CPU: 1 PID: 6637 at /media/zhao1/release/oranth/s905x_oranth_tx5Pro_9377/hardware/wifi/qualcomm/drivers/qca9377/AIO/drivers/backports/net/wireless/reg.c:1388 wiphy_apply_custom_regulatory+0x1c4/0x1f8 [cfg80211]()
    [ 87.100803@0] Host SW:, FW:, HW:QCA9377_REV1_1
    [ 203.937724@0] wlan: [4:E :WDA] scan complete - scan_id a006, vdev_id 0
    [ 4029.105394@1] WARNING: CPU: 1 PID: 9235 at /media/zhao1/release/oranth/s905x_oranth_tx5Pro_9377/hardware/wifi/qualcomm/drivers/qca9377/AIO/drivers/backports/net/wireless/reg.c:1388 wiphy_apply_custom_regulatory+0x1c4/0x1f8 [cfg80211]()
    [ 4029.168234@1] Host SW:, FW:, HW:QCA9377_REV1_1

    Edited once, last by kostaman (January 10, 2017 at 11:26 PM).

  • Hi,
    I have been looking for a s905x based box, with gigabit LAN and (hopefully) also 802.11ac 5GHz wifi. Some TX5 Pro boxes seems to have ac wifi, but none are with a gigabit LAN (which I plan to use, like you...).

    I did notice several TX95 boxes "around", all seems to be with gigabit LAN, and one even mentions having ac wifi. Does anyone here know if this TX95 box is similar to the TX5 Pro? Will it run also LlibreELEC "out of the box"... ?

    ( Examples: EWKb77  Tanix TX95 Amlogic S905X 2G/16G Android 6.0 TV Box )


  • I tried Kekilo TX5 Pro. The same issue with boot (only fake update.zip helped). I see no difference in terms of performance in comparison to S905. LAN 100MBit - this is weird. Device slightly more compact than other S905 boxes. With custom remote.conf you could make it work with any remote. In my case I have LibreELEC on usb thumb drive tuned for Beelink MX64. I changed just dtb.img to load libreelec on TX 5 Pro with the same remote configuration as i already have. There is no hardware support for h264 Hi10P (the same as on S905). Kekilo TX5 Pro has 802.11ac (as stated on box), but I didn't test how fast is it in real world.

  • rafi, don't buy s905x if you don't need HDR output, there is no performance difference between s905 and s905x based on my experience.

    Be aware when choosing S905 Chip Boxes , you will not have a Temp Sensor with LE using the Temp Sensor Disabled versions.
    Not using the Temp Sensor Disabled Versions will cause freezing during boot up.

  • I have this and was also looking for Gigabit ethernet. However, mines connected using wifi and I'm getting a steady 105meg with no buffer or problem at all. Also running LE off SD so I can dual boot. I'm not overly fussed over Gigabit ethernet now.

  • Hello...

    Do you experience any issues with this box?

    I had a Mini M8S II and i had installed 7.0.3.xxx versions with or without Temp sensor readings...

    I had many restarts of Kodi (not LibreELEC)...

    I bought a Tanix TX5 Pro box and i installed LibreELEC 7.95beta5 version temp sensor enabled... I still have restarts but less than those i had with Mini M8S II...

    Best regards...

  • Link to read #1

    I haven't gone Krypton with this box

  • logicheart

    I've been running Tanix TX5 Pro for about 3 months with different LibreELEC versions and never experienced that.
    First of all try another power adapter and make sure it's connected properly.

  • A bit off topic but do you suggest getting this tv box? Just saw a deal on geekbuyng where it's only $48.99

    I had 2 of these go bad on me.

    Red standby light stayed on and box was un responsive.

    I opened it and heated up the internal flash memory with a Heat Gun to reflow the solder which fixed the issue.

    Pretty good box with Qualcomm Wifi but be aware these TX5Pros come out with 3 Different wifi chips.

    Don't quote resellers in the forum.