S802/S812-Libreelec images for 7/8/9

  • Hi Demetris,

    I would like to kindly as for help.

    On my Minix X8H-Plus I have problem with device freeze. From my point of view looks like device get freezer only if is connected to the network (and doesn't matter if is connected via LAN or WiFi). Only what I can do after that is unplug device from power.

    Logs after restart from device freeze you can find HERE and HERE.

    Second problem what I have is issue with Shutdown/Standby of device. when I turn off device I'm not able to switch on again. Unplug device from power is (again) only option to get device working.

    Thank you for your help.

    Edited once, last by kodlz ().

  • Can you try booting lakka and tell me if you have the same issue on your S802(M8)?

    Hi Demetris thank you for getting back to me, unfortunately lakka won't boot for me. I tried burning with etcher and Rufus and both with SD card and usb flash drive and all resulted the same, boots up my box's splash screen then goes to a black screen for maybe 5 seconds or so and then tv loses signal from the box. I left all like that for 20 minutes just in case it was installing but nothing happened.

    I now have the original firmware including u-boot.bin if this will offer any information for you? I also have the custom ROM that was made specifically for the box by finless Bob over at freaktab which was based on a later released manufacturers firmware which I don't have unfortunately but bobs ROM is rock solid

    Many thanks and all the best


  • Good morning Demetris

    Again thank you for getting back to me.

    I installed the latest of your builds that work for me 8.0.2b and then used the .update folder to flash LAKKA. Now it did flash and boot however the GUI is all mashed up, see pic in this link

    Dropbox - IMG_20180218_111459.jpg

    For some reason it kept throwing me an error if I tried to upload the pic directly

    As always very much appreciate you taking the time to help

    All the best


    EDITED: I started playing again with the cheap AKASO M8S S812 box and funnily enough it does exactly the same as my old M8...

    It will run your 8.0.2b build but the minute I try to run 8.2 they both boot with the "a start job is running for load kernel modules" on the M8S it displays for about 50 seconds and then boots to libreelec

    On the old M8 it will display that for nearly 5 minutes

    On the M8S I have just noticed that 8.0.2b shows WiFi access points but 8.2 it does not.

    I'm going to try the old M8 and see if thats the same.

    As a side note both box's are very VERY similar in specs, I can boot the M8S from SD fine. After flashing LAKKA to the M8 it does appear it wants to boot from the SD but I receive the following...

    Filesystem corruption has been detected!

    To prevent an automatic repair attempt continuing, press and key or power off your system within the next 120 seconds

    So I left it and received....

    CP437: invalid argument

    Fsck.fat 3.0.28 (2015-05-15)

    Open: read-only file system

    E2fsck 1.43.4 (31-jan-2017)

    Fsck.ext4: read-only file system while trying to open /Dev/mmcblk0p2

    Disk write-protected; use the -n option to do a read-only

    Check of the device

    Forced fsck failed. Your system is broken beyond repair

    Please re-inspection libreelec

    EDITED: I flashed the old M8 to the original android ROM and then flashed up to your 8.0.2 before finally updating to 8.2 using .update folder.

    I left it though the "a start job" msg and sure enough it also does not display WiFi access points the same as the M8S

    WiFi works fine in 8.0.2b. can't believe it's taken me so long but I usually have it hard wired

    Edited 3 times, last by chunk1982 ().

  • thanks for the feedback, so its not the kernel at fault here but appears to be something wrong with initramfs & bootloader.

    Can you flash S812 bootloader on M8 and try to boot from sd again?(dont expect to fix anything else but boot from sd should work now-theoretically)

  • thanks for the feedback, so its not the kernel at fault here but appears to be something wrong with initramfs & bootloader.

    Can you flash S812 bootloader on M8 and try to boot from sd again?(dont expect to fix anything else but boot from sd should work now-theoretically)

    do you happen to have one i can flash please??

    many thanks and all the best


  • A little update and some more information for you Demetris.

    After several soft bricks of the old M8 I gave up trying to flash an S812 bootloader lol so went back to messing about with them on your libreelec releases.

    8.0.2b was the last one that WiFi worked on both box's but noticed on BOTH box's that 2 CPU cores seem to be "frozen" at a clock speed on boot and never seem to fluctuate. It's not the same 2 cores every boot though, this could explain why my old M8 kept crashing every now and again.

    After noticing this I flashed the oldest release I had for the M8 which was S802 8.0.1a of your build and everything works as it should on it including all 4 CPU cores.

    Is there anything I can send or I can do while on either 8.0.1a or 8.0.2b via SSH commands to give you any more information?

    As always very much appreciated for all your time you put in maintaining these devices

    All the best


  • hmm i will check your report out on my boxes with latest release, if its valid i will release new images soon.

    In the mean time can any of you guys check if cpu is indeed stuck on running 2 threads only? Gracias

  • I've been trying to load the latest LibreELEC-S812.arm-17.6_20180122-LAN_100.img.gz onto my Matricom Q2 using the toothpick reset method to no avail. I've flashed the .img file using the LibreELEC tool for the Mac. I also wrote the .img using the MacOS DiskUtil terminal commands to both an SD and a USB and inserted both into the Q2. All of my attempts have resulted in only the Android Recovery page never a boot from the SD nor USB. I tried both reboot options on the recovery page but they each brought up the Matricom GUI.

    I've verified via adb that the contents of both the SD and the USB are located off of /storage as udisk0 and udisk1.

    I want to run from the SD or the USB and leave the Android side as it is.

    Reading previous posts on installing LibreELEC on the Matricom Q2 seems to indicate that the toothpick method loaded the .img file directly.

    Is it necessary to install a dual boot utility on the Matricom Q2 before the toothpick method will load and run either the SD or USB .img? If so, I'd appreciate a working link to it.

  • My cheap M8 (S812) booted from SD out of the box but I use either etcher or Rufus to burn my SD cards, granted these are windoze programs, do you have access to a windoze laptop or PC you could try on?

    All the best


  • Paul,

    Thanks for responding. I brought up BootCamp and wrote a USB using Rufus. Same result - Q2 didn't boot from it. Both Rufus and the LibreELEC change the USB from 16GB Fat32 to MS-DOS (FAT16) with the resulting size change. So I guess that's by design.

    Perhaps someone who had success loading a Matricom Q2 will fill me in.



    Edited 2 times, last by Selz ().

  • Hello,

    I am new to this forum.

    I would like to ask Demetris !!!

    I have a Beelink M8 S802 box and installed the "LibreELEC-S802.M8.arm-8.0.RC4.img" which has kodi 17.1
    I would like to update to kodi 17.6 is this possible and if yes.. via which "img.gz" file.

    I tries the s8X2 versions but i get an error ........................ s8x2 is not compatible with s802 .... and it asks for a "/.nocompat"

    is it ok to proceed or there is another way or fie to update to a later version of kodi than 17.1

    Thank you in advance.


  • there is a .nocompat file download link in the pinned post with instructions.

    Use the S8x2 M8 file.

    You could download the update as a .tar and place it and the . nocompat file from first post in your .update folder 😉

  • Is anyone else having trouble with powering on the device? I have a number of Matricom Q (M8) & Q2 (M8S) boxes that are running this image very well. The only issue is that once you power off they will not power back on. I have to repower to get them back.

    Amy ideas? Thanks.

    I'd appreciate if you could tell me how you installed "this image" on your Matricom Q2. Are you running it from NAND or from an SD/USB which is the configuration I'm looking for.

    Thank you.

  • kodlz disable CEC

    I'm not sure if this help me, LE not freezing so frequently, but still is freezing.

    And when I turn off device I'm not able to switch on again. I still need unplug device from power.

    Edited once, last by kodlz ().

  • Selz that image is not mine! why you ask support here? O.o

    kodlz Try to flash a "branded" bootloader compatible with your device,but am not going to hand hold you through this though.Google is your friend.

  • Demetris

    I recently upgraded my MX-III 2GB/8GB (S802 AP6330) unit which was running LibreELEC-S8X2.arm-8.0.2-S82 with the following file


    The upgrade went fine and the system is running fine mostly, however there are a couple of issues

    1. Bluetooth does not work. This is the same unit for which you fixed the BT support a while ago here. The Bluetooth menu reports "No Bluetooth Adapter Found"
    2. CPU runs at 100% and on connecting to the box over ssh and running top, I noticed that the process brcm_patchram_plus is the culprit taking one cpu (of the 4 available) to 100% utilization. I can kill the process and then unit performs normally until the next reboot

    Can you please advice how to fix the two little issues. Let me know if you would like to see any logs and I will upload them.

    Thanks a lot for keeping these old little boxes still going strong.

    Kodi 18.9 x64 Windows | LibreELEC 8.2.3 MX-III 2GB S802 by Demetris | CoreELEC 9.2.5 Amlogic-ng S905X