S802/S812-Libreelec images for 7/8/9

  • yes looks like your system doesn't like the mali userspace libraries we use anymore

    could be something i changed in the kernel config but i dont have any 1gb S8X2 to test sorry.

    it is fine :) , just take down the images so none else get a black screen on their device.


    is the kernel and kodi patches the only things you need for the same performance in for example debian (armbian) ?

  • it is fine :) , just take down the images so none else get a black screen on their device.


    is the kernel and kodi patches the only things you need for the same performance in for example debian (armbian) ?

    I have a MXIII 1GB S802 and the LibreELEC-S8X2.arm-8.2.1-MXIII-1G works fine.

  • I have a MXIII 1GB S802 and the LibreELEC-S8X2.arm-8.2.1-MXIII-1G works fine.

    hmm what is the android firmware you are using ? (uboot changes with each one)


    E: fixed it by installing MBOX_112k4_sdcard.zip from freaktab and inputting the correct uboot script by serial (from the github).


    now only if cec worked (it did in the past with the same tv/ hdmi cable


    E2:

    setenv cec 1

    saveenv


    and cec works

    Edited 2 times, last by nicman23 ().

  • Firstly, thanks to Demetris for porting Libreelec to this box, and anyone else who may have contributed.


    I have a Tronsmart Vega S89 Standard 2G/16G with Amlogic S802, using this firmware: LibreELEC-S8X2.arm-8.2.2-MXIII-PLUS.img

    Things seem to work pretty well - except for Wired Ethernet (wifi seems to work ok). It seems to detect a connection, but then isn't able to get an IP address from my DHCP server. Since the Vega S89 can't get an address from DHCP it ends up with a 169.x.x.x APIPA address. When I plug the Ethernet cable into my laptop (instead of the Vega S89), all is fine, the laptop gets a DHCP IP address. Just in case, I have also tried using a different Ethernet cable, plugged into a different router/DHCP server. Same problem occurs with the Vega S89.

    (I have also tried the previous version firmware, ie. LibreELEC-S8X2.arm-8.2-MXIII-PLUS.img, with the same problem).

    Any assistance much appreciated.

  • I had the same problem. Then i used this LibreELEC-S8X2.arm-8.2.1-MXIII-1G and the Wired internet worked ok again.

  • For Tronsmart Vega S89 the correct image is S82 thats why your ethernet is not working

    All you needed to do is devote 5 seconds to read the OP

  • For Tronsmart Vega S89 the correct image is S82 thats why your ethernet is not working

    Thanks Demetris, I will give that a shot, and report back :)


    All you needed to do is devote 5 seconds to read the OP

    I read the OP in detail. Maybe it is just me but to me it is not clear that the S82 build is the one to use for the Vega S89. Reading other responses in this thread, I don't think I am the only one who was confused by this.

    Edited 2 times, last by nev-au ().

  • I've just tried "LibreELEC-S8X2.arm-8.2.2-S82.img.gz" and I can't get this to boot. Comes up with "File system corruption has been detected!" message. I tried different MicroSD cards and readers, also tried a different PC without luck. After the aforementioned message it will attempt a repair, but this doesn't work.

    Also tried Hmeeberg's suggestion .. "LibreELEC-S8X2.arm-8.2.2-MXIII-1G.img". Exactly the same issue as above.

    Hence there is something in the boot part of "LibreELEC-S8X2.arm-8.2.2-MXIII-PLUS" that is compatible with my Vega S89 - it boots and installs .. however I don't have the knowledge to know what can be taken from this and placed into the image I want to use (ie. "LibreELEC-S8X2.arm-8.2.2-S82.img").

    Cheers.

  • hi, i have a m8s box, and I don't know which image is the correct one for me (i've tried the 8.2.2 for m8 and m8s plus, but wifi wasn't working). what do you suggest me to do?

  • I have a friend's generic M8 box with the following specs -

    SoC – AMLogic S802 quad core Cortex A9r4 processor @ 2GHz with Mali‐450MP6 GPU.

    System Memory – 2GB DDR3.

    Storage – 8GB NAND flash + SD card slot.

    Connectivity – 10/100M Ethernet, dual band Wi‐Fi (2.4GHz/5GHz), Bluetooth.

    Video Output – HDMI 1.4b, AV.

    I would like to put LE onto this box and not sure how. With My S812 I had to load an older LE V7 build first and then SSH into the box and update with the S812 image tar file for V8. That worked well, but with the S802 I don't know.

    Looking for some help with this.

    Thanks

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • I don't have a link for it, the old link is dead. I do have this though: Loading site please wait... I tried it and it works just fine. It is Kodi 17.5. Thank you everyone.


    nev-au .


    This one worked for me on my Tronsmart S89 where the S82 version did not. I suspect the S82 build is corrupted.
    The linked above is one version behind current but I then updated.. Anyway its all there if you go back to pages 74/75.

  • I've just tried "LibreELEC-S8X2.arm-8.2.2-S82.img.gz" and I can't get this to boot. Comes up with "File system corruption has been detected!" message. I tried different MicroSD cards and readers, also tried a different PC without luck. After the aforementioned message it will attempt a repair, but this doesn't work.

    Also tried Hmeeberg's suggestion .. "LibreELEC-S8X2.arm-8.2.2-MXIII-1G.img". Exactly the same issue as above.

    Hence there is something in the boot part of "LibreELEC-S8X2.arm-8.2.2-MXIII-PLUS" that is compatible with my Vega S89 - it boots and installs .. however I don't have the knowledge to know what can be taken from this and placed into the image I want to use (ie. "LibreELEC-S8X2.arm-8.2.2-S82.img").

    Cheers.

    did you try redownloading the image?

  • nev-au .


    This one worked for me on my Tronsmart S89 where the S82 version did not. I suspect the S82 build is corrupted.
    The linked above is one version behind current but I then updated.. Anyway its all there if you go back to pages 74/75.

    hi Joffa, that is the one I originally tried, and it does install and run - however, wired ethernet does not work properly. It will not get an IP from DHCP. Have you tried wired ethernet by any chance?

  • did you try redownloading the image?

    I didn't actually, because when I did an archive test with 7zip archiver, no errors were found. But I should give it another shot just in case, will download again. thanks!


    UPDATE: I downloaded the file again (ie LibreELEC-S8X2.arm-8.2.2-S82.img.gz ). Performed a binary file compare with the original file .. and no differences were encountered unfortunately.

  • I do not want to install this build to internal memory - SD only. Anyone?

    MXIII-G, M8 and Beeklink MXIII Plus LE 8.2.2 - Demetris, Mecool M8S Pro+/Abox A1, Abox A1 Max Coreelec 9.0.2. Thanks to all.

  • Hi Demetris,

    I have an orbsmart S82 Straeming box,

    i have to try your image LibreELEC-S8X2.arm-8.2.2-S82.img to flash to the box with an SD Card.

    I push the On Button and the Reset Buttonn in the AV link.

    the Box bottet into bootloader i switch to flash from ext.

    and then i switch to flash from SD Card.

    But the problem is:


    this Errormassage:


    E:mount /dev/block/mcblk0p1 on /sdcard failed (no such file or directory), now to try read-only to mount again


    I have used the libreelec LibreELEC.USB-SD.Creator.Win32 Tool to burn the imaghe on the micro SDcard.


    Must i flash the lastest Stock image??? Is this an Bootloader Problem???


    How can i flash the orbsmart S82 per OTG Usb cable???