S802/S812-Libreelec images for 7/8/9

  • I wish there was a way out for you my friend but a clean install is the way forward

  • Hello Demetris,

    I work for now on my Tronsmart MX III with the version of 26 august. I notice that after intstalling I can't start the box with the remote. I have to press the start button on the box for a while so that there will be a soft restart. I didn't had that matter in a previous version.

    Tnx for your cooperation.

    Fixing it for your box then is breaking it for others. Is like a loop that never ends.

  • I have a MXIII-G too, for me DTS works using passthrough via the SPDIF cable. It does not work with HDMI.

    Hi on my MXIII-G 2/8 works DTS audio on both SPDIF and HDMI , in audio data settings, setup audio card xxxx-HDMI output

  • You cant, i have to do it from source then others will complain that they cant power on from remote

    Hi Demetris thank you for the answer. I will stick to the older version where there is no problem with shutting down the boxI

  • Hi Demetris,

    First off, I would like to thank you for suppluing the Libreelec images for my Tronsmart S89-H. I have been using them since Drieschel stopped developing them for my box and have never had any issues with them.

    However, yesterday I tried to update my box with this image you've uploaded: LibreELEC-S8X2.arm-8.2.RC3-S82.tar and after a restart I was confronted with the setup screen of OpenElec 6.0.1, with Kodi 16.4. Also, all my addons and settings were gone and I had to do the initial setup again.

    Can you please check whether you might have mixed up the images and uploaded an old one, using a new name?

    Best regards,


  • hmm i had a last look at audio passthrough issue and i think i nail it this time :)

    Will release new RC3 images soon, stay tuned!

  • For the guys with the MXIII-G's, are any of you able to test the lossless codecs i.e. DTS-MA or Dolby TrueHD at all? I've never had an issue passing through the lossy codecs, it's the 'HD' ones that aren't being decoded. gthebest - I'm guessing you have the audio settings correct? (enable passthrough, DTS & DD enabled receiver etc.?)

  • OK so for me, there's been a change. I'm no longer getting any white noise through the amp when playing any HD audio stuff. The only problem is, I'm getting no noise at all now. Again forcing it to the lossy codecs works fine. DTS & DD work no problem at all, so thanks for that.

    I'm not sure whether you're going to continue looking into this, but I appreciate the effort you've already made and thank you for all the existing work to get it to where it is!

  • I tested the rebuilt RC3 and both the digital noise and missing audio are back for DD/DTS sources. This only happens for the first few seconds of playing a file, then it works fine.

  • I can get it to install and run from microSD on my MXIII-G however I'm unsure how to install to internal NAND? I've read that there is an option to install to NAND in the shutdown menu of LibreElec but there is no such option in my build.

    Any advice how to install to internal memory? Would be nice to free up micoSD card and maybe a small speed improvement also.

    I'm running the LibreELEC-S8X2.arm-8.2.RC3-MXIII-PLUS build.


  • You have to flash a "zip" file from recovery (start your MXIII-G with the toothpick).

    I'have used LibreELEC-S8X2.default.arm-7.0-devel-20170124000114-r23703-ge207b78.zip, extracted the file LibreELEC-S8X2.default.arm-7.0-devel-update.zip it has inside and flashed it. Then you can upgrade using the "tar" files simply putting them in the update folder.

  • Demetris,

    Been using your builds for a while now on my MX-III 2GB (S802 based)

    I have been using S82 images on them flawlessly, everything works including bluetooth and wifi up until 8.2RC1

    On 8.2RC2 and RC3, the power off function is messed up. I can reboot correctly, but cannot power off.

    On Selecting the Poweroff, the system goes immediately into standby. if powered on again by remote, it powers up for may be a couple of seconds and then goes standby again. After a couple of tries of this, it comes out of standby.

    Secondly the CPU runs at 100% and on connecting to the box over ssh and running top, I noticed that the process

    brcm_patchram_plus is the culprit taking one cpu (of the 4 available) to 100% utilization.

    Please let me know if you have time to look at this. Let me know if you would like to see any logs and I will upload them.

    Thanks for keeping these old little boxes still going strong.

    Kodi 18.9 x64 Windows | LibreELEC 8.2.3 MX-III 2GB S802 by Demetris | CoreELEC 9.2.5 Amlogic-ng S905X

    Edited once, last by gujal ().

  • just login to box using ssh or putty and type # installtointernal then follow instructions

  • Demetris

    I have M8S box . I found LibreELEC-MX3G.arm- compatible with this box.Currently I have dual booted via SD Card. Got Jarvis running with no problem whatsoever. I tried to update it to Krypton with your latest

    LibreELEC-S8X2.arm-8.0.2-MXIII-PLUS.img.gz but will not work.

    1) Is old MX3G and MXIII different?

    2) Is there a tar file to update to Krypton?

    I am bit confused with whats happening with different boards and brands.

    Any help would be great.

  • .tar can be found here...