Gamestarter: Retrogaming add-ons (RPi/Generic)

  • If they work in RA but not in ES try to unzip the roms...for some reason some zipped roms don't work in ES or try to setup AEL...I never used ES again since setting up AEL...but never uninstalled it...ES is pointing to same assets as AEL so you don't have to keep 2 copies of artwork,it's easier to have roms within Kodi UI..

    thanks Mario77, I used to have AEL working (with the standalone addon) but its all broken now I have the repo installed. I will just use retroarch on its own for now.

  • thanks Mario77, I used to have AEL working (with the standalone addon) but its all broken now I have the repo installed. I will just use retroarch on its own for now.

    If you want to use AEL and you come from standalone gamestarter addon you should backup your AEL userdata folder, then delete the addon using kodi interface, delete AEL userdata folder and install it again from my repo or from AEL's official github. After that you can follow instructions in my github repo page in order to import all categories, including artworks and paths, working with retroach addon. Finally you must scan each sustem for roms.

  • Hi, my god, that so difficult to run this addon loooooooooooooool

    I don't understand anything of what happenned on my system...


    Here my config :

    -> Raspberry pi 2

    -> Blutooth dongle

    -> Madcatz CTRL

    -> Libreelec 8.2.1 so latest version

    -> Fresh install of retroarch (version 1.6.9 installed with the addon v8.169.6 )


    So the story :

    -> After create a udev file in .confg/udev.rules with :

    Code
    1. SUBSYSTEM=="input", ATTRS{name}=="GEN GAME", KERNEL=="event*",
    2. MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"

    gamepad is detected very well and configured in Kodi (Every button works)


    -> I launch Retroarch : it start and, after a few second only (maybe 10), crash and the rpi restart to kodi (a reboot from the beginning)

    -> I have downloaded the libretro package Lakka (as you mentionned on github) but, still rebooted


    Do you have any idea of what happened ?


    Retroarch.log : nothing here

    Retroarch_debug : see attachment but, I don't see anything strange


    Thanks

  • oh, I reply to myself lol : I've change in retroarch.cfg the input joypad driver from udev to linuxraw and no more crash !!!!!

  • I don't have an intel NUC so I can´t try it by myself, only thing I can tell you is to install Escalade's build and try to launch retroarch.

    If it works and you prefer to use Official LE release you can grab retroarch binary from that build and paste/replace back in my retroarch addon folder (/starage/.kodi/addons/game.retroarch/game.retroarch-Gen) in your LE oficial installation.


    Maybe my retroarch binary is not well compiled for Generic... That's why I am considering to use Escalade's ones instead compiling myself, he is a LibreELEC ninja!

    Thanks, will try to use Escalade's binary. He seems to use a NUC himself. Have to figure out how to extract the SYSTEM image, and then I'll see if it works.


    In Escalade's LE8 Remix post, I read this. Could that be the problem maybe (I'm not a Linux guru at all)? Does RA run in KMS mode on Intel GPUs in your addon?

    Quote

    RA will run in KMS mode by default on Intel GPUs. To use Vulkan, change the video driver in RA settings (restart of RetroArch required) and force disable KMS like this: Code

    # touch /storage/.config/retroarch/nokms


    This simply creates the file "kms", which the launcher script will check for and make adjustments accordingly. Remember to remove it if you like to use Vulkan or OpenGL again.

  • Thanks, will try to use Escalade's binary. He seems to use a NUC himself. Have to figure out how to extract the SYSTEM image, and then I'll see if it works.


    In Escalade's LE8 Remix post, I read this. Could that be the problem maybe (I'm not a Linux guru at all)? Does RA run in KMS mode on Intel GPUs in your addon?

    In latest Ra addon binaries have been extracted from Escalade's build so try it again please.

    About vulcan/KMS thing... I really don't know... maybe you can change some parameter in retroarch settings using GUI or by editing retroarch.cfg file.

  • Hi bite_your_idols.


    I can't open Retroarch latest on generic.

    Code
    1. /storage/.kodi/addons/game.retroarch/game.retroarch-Gen: error while loading shared libraries: libass.so.5: cannot open shared object file: No such file or directory


    Showing in log.

  • if you install yourself LE8 into generic device, could you please grab shared library "libass.so.5" and paste here a download link... That would help me a lot...

  • Thanks, will try to use Escalade's binary. He seems to use a NUC himself. Have to figure out how to extract the SYSTEM image, and then I'll see if it works.


    In Escalade's LE8 Remix post, I read this. Could that be the problem maybe (I'm not a Linux guru at all)? Does RA run in KMS mode on Intel GPUs in your addon?


    In order to run RetroArch in KMS mode you need to be in a VT not occupied by X, and not set the DISPLAY variable (I do this with my launch script). There is no Vulkan drivers or loader in standard LibreELEC.


    In plain English, you aren't running on either KMS or Vulkan with this addon.


    To mount my SYSTEM image you'll need a Linux system with 4.14 kernel because it's compressed with Zstd. The simplest way would probably be to boot my build from a USB then copy the binary.

  • Okay. Which files/folder do you need?

    just "libass.so.5", it should be in /lib folder or /usr/lib or wherever... I can not remember right now, sorry. If you connect using filezilla or similar ftp client software you can use search function.

  • RA 8.169.7 updated in repo.

    New lakka 2.1 core package updated. Also it is easier to use AEL addon with retroarch since I included an option to download AEL assets within RA addon settings.