Gamestarter: Retrogaming add-ons (RPi/Generic)

  • i cant get this to work i copied the git onto the pi did install from zip shows gamestarter 2.0.2 in my addons and it did its first run setup but after that it it asks to go into retropi but never siwitches and in the setttngs i tried to get it to install internet archive rom launcher but it did nothing when selected


    i am on a rpi 3 running LibreELEC (official) Version: 7.0.1

    Edited once, last by jesterod ().


  • i cant get this to work i copied the git onto the pi did install from zip shows gamestarter 2.0.2 in my addons and it did its first run setup but after that it it asks to go into retropi but never siwitches and in the setttngs i tried to get it to install internet archive rom launcher but it did nothing when selected


    i am on a rpi 3 running LibreELEC (official) Version: 7.0.1


    You have to download the zip from releases page not from the main page, that could be the problem...
    From settings you can download Internet Archive ROM Launcher addon zip, it will be located in /storage. After downloading you must go to kodi settings, select install from zip and select the zip file.

  • that worked but when i went to install the internet archive launcher it said it inastalled it (from zip after settings) but i cant find the program to run it and im using a bluetooth controler i set it up in libreelec and it works in emulatationstation in the control setup but not in the games only a few buttons do the d-pad and start and i get the controler to do anything in retropi


  • that worked but when i went to install the internet archive launcher it said it inastalled it (from zip after settings) but i cant find the program to run it and im using a bluetooth controler i set it up in libreelec and it works in emulatationstation in the control setup but not in the games only a few buttons do the d-pad and start and i get the controler to do anything in retropi


    By default IARL addon is located in Video Addons, you can change that in addon settings.


    About your bluetooth controller, can you connect it using usb to try if it works? what brand and model is it? are you saying if you install retropie in your SD the controller works both in emulationstation and retroarch, but with Gamestarter it only works in emulationstation? that is a very weird issue because rertoarch joystick configs are the same in both systems...

  • no I just tryed both front ends and only works in one but not inside the games only start and direction works tho to be fair ive only tryed snes

  • Just to add: I'm using a Genuine Playstation 3 Dual Shock Controller .... 100% Perfect, No Issues whatsoever

  • ok, so it is a problem with your controller and retroarch. You can try to download this package and paste into "/storage/.config/retroach/autoconfig" I found two config files for ipegas inside...


    one question, one you are in retroarch and you connect and disconnect your ipega, are there ant yellow characters in the left bottom corner?

  • i cant reconnect it in iather front end just in kodi then i go into retro or emulation station but no i dont see ant yellow characters in the left botton theres white words there

  • Kinda Off-Topic ...


    But i noticed that bite_your_idols "Gamestarter" announcement has only received ONE reply (myself) on the Official KODI Website
    C'mon ... let's leave some feedback there too, as a token of our appreiciation and acknowlegment of his cool addon and work


    [Pi] Gamestarter: Easy retrogaming addon for Raspberry Pi.


    Thanks again, BYI for your work in keeping retro games alive and on the Raspberry PI ... Appreciate it

  • Hi all,


    I'm using Libreelec 7.0.1. Audio is played on a bluetooth audio speaker, which is paired to Libreelec. That works fine.


    If I start an emulator, sound does not work. Is this due to the missing support for bluetooth speakers in retroarch/etc or am I just too stupid to set it up?

  • Hi bite_your_idols,


    I'm planning for a fresh re-install of LE 8 testbuild including Gamestarter on my Pi3. Would you be able and issue a version 2.0.3 of Gamestarter with the fixes included since 2.0.2 version? I'd be happy to report on any findings during the re-install...


  • Hi all,


    I'm using Libreelec 7.0.1. Audio is played on a bluetooth audio speaker, which is paired to Libreelec. That works fine.


    If I start an emulator, sound does not work. Is this due to the missing support for bluetooth speakers in retroarch/etc or am I just too stupid to set it up?


    Can you try using HDMI audio output? I don't know how works bluetooth audio output in libreelec and if it can make some issue with alsa audio... only thing I can tell you is: google... sorry...




    Hi bite_your_idols,


    I'm planning for a fresh re-install of LE 8 testbuild including Gamestarter on my Pi3. Would you be able and issue a version 2.0.3 of Gamestarter with the fixes included since 2.0.2 version? I'd be happy to report on any findings during the re-install...


    The truth is that I have no update plan in mind, there are a few upgrades since current versionand I am waiting for any big feature or improve... but If I have some free time next week I can make a new release ;) (This week I am full of work...)



    By the way, thanks to everyone for the support here and on kodi forums ;)


  • Hi all,


    I'm using Libreelec 7.0.1. Audio is played on a bluetooth audio speaker, which is paired to Libreelec. That works fine.


    If I start an emulator, sound does not work. Is this due to the missing support for bluetooth speakers in retroarch/etc or am I just too stupid to set it up?


    You need to change your audio driver in Retroarch to Pulse audio. Then it will output to your bluetooth while in-game.


    Settings\Drivers\Audio Driver

    MK808b Plus stick running LibreElec 7 with Retroarch 1.3.6 running as an addon

  • Thanks for this great addon,


    works like charm, even psx and n64. I only have one problem i can't solve. i use a hifi-berry sound card to passthrough 5.1 audio when i'm watching movies.
    When i set dtparam=audio=on, i have sound in retroarch over hdmi, but no soundcard detected in kodi.
    When i set #dtparam=audio=on, i have only sound in retroarch over the av-receicer and not over hdmi, but soundcard in kodi is working.
    When i putty on the pi, and check with aplay -l, only the hifi-berry is shown, no hdmi or pulse audio.
    I tried diffrent ways like audio_driver=sdl
    audio_device=hw:0,3


    But i can't figure out whats the reason, can someone help me please ?

  • You need to change your audio driver in Retroarch to Pulse audio. Then it will output to your bluetooth while in-game.


    Settings\Drivers\Audio Driver


    Thanks for the answer. Unfortunately, if I open up retroArch, the only available audio drivers are alsa, alsathread, oss, sdl2 and null. There is no option for pulse audio. However, for LibreElec, sound works great on bluetooth audio.

  • I'm trying to use Internet archiver...It downloads the zip ok, but it doesn't launch. I pointed it to the retorach bin location in /kodi/addons/script.gamestarter/resources/bin. Am I missing something?


    I also had to make a symbolic link from /.kodi to /kodi since the openelec menus won't let me select hidden folders.


    Thanks.
    Z


    (Using Libreelec RPi2)

    Edited once, last by zipeee ().


  • You have to enable hidden folders and files in kodi settings. IALR addon must point to gamestarter.sh script, not retroarch binary. Did you run IARL settings wizard?