RPi4 NFS playing hangs after 11.0.3

  • Code
    2024-02-01 12:10:59.082 T:867     debug <general>: ActiveAE - start sync of audio stream
    2024-02-01 12:10:59.208 T:867     debug <general>: ActiveAE::SyncStream - average error of 18.539941, start adjusting
    2024-02-01 12:10:59.208 T:867     debug <general>: ActiveAE::SyncStream - average error 0.539941 below threshold of 30.000000
    2024-02-01 12:10:59.579 T:996   warning <general>: OutputPicture - timeout waiting for buffer
    2024-02-01 12:11:07.902 T:997      info <general>: Skipped 154 duplicate messages..
    2024-02-01 12:11:07.902 T:997      info <general>: CVideoPlayerAudio::Process - stream stalled

    Do you have the issue with and without audio pass-through?

  • I tried it a bit, and it turned out that there is no such freezing with the default Estuary skin. I use Estuary Mod v2.
    Something with the skin and the LE above version 11.0.3 is causing the problem.

  • The default skin probably uses less RAM, resulting in more RAM for NFS chunk/cache (use top on SSH to find out).

    You can play around with NFS chunk/cache size, or you can create a swap file to emulate more RAM.

    I think there is something wrong with the new default settings for NFS. It now uses too much RAM:

    2024-02-01 12:10:02.733 T:965     debug <general>: CFileCache::Open - <nfs://> using double memory cache each sized 10485760 bytes
  • I'd guess there's something not updated in the skin for Omega final.

    I'm the maintainer of the skin. As I can say the skin is up to date for omega ;) . But the skin itself is indeed more memory invasive then the plain estuary. Maybe reducing the chunk size can solve this problem. The relevant code snippets from log are already posted here in this thread (#6, #10)

  • I tried to reduce the chunk size, but it didn't help. I think something has changed in Kodi or LE, because I can reproduce the error with every version above 11.0.3, while using the same skin version.

  • Small cache (64MB) and ‘Adaptive’, small chunk size (32kb) and NFS version 4 seems to solve my network problems with two Synology NAS (and I need to have both on, although that may have been fixed during betas).

  • I haven't made any progress with this, despite adjusting the cache/nfs settings. I've created two new logs with LE 12. One uses the standard Estuary skin, the other the Estuary Mod v2 skin. Just search for the term '409.mkv'.

    The same issue is discussed in this thread: RE: RPI4 - Constant freezing/crashing after upgrade from LE 11.0.1 to 11.0.6

  • You still have a memory problem on the Estuary Mod log:

    Please try the swap file.

  • Bash
    LibreELEC:~ # free -m
                  total        used        free      shared  buff/cache   available
    Mem:            7810         519        6884          56         575        7290
    Swap:            127           0         127

    I tried it, no change. There's plenty of free memory. :)