LibreELEC (Nexus) 11.0.3

  • Hi team,
    thank you for that !
    I have done the update and worked smoothly.

    May it be that in this version at the startup the version number is no longer shown in the upper left corner ?

  • Many thanks for everyones work on this.

    Installed fine & been running it for the last few hours without issue. :)

  • A fine release again. Compile went without a hitch, all running smoothly. Thanks, much appreciated.

  • Thanks ,

    update from 11.0.1 to 11.0.3 Generic stuck at the Versionsnr at the screen top left.

    AMD ryzen 3 3200G

    Libreelec Generic-Legacy 11.0.3 works fine.

  • Thanks ,

    update from 11.0.1 to 11.0.3 Generic stuck at the Versionsnr at the screen top left.

    AMD ryzen 3 3200G

    Libreelec Generic-Legacy 11.0.3 works fine.

    My CPU is AMD 3400G, same as you.

  • The OS is running fine (but no GPU drivers means Kodi doesn't start). SSH in and wget/download an earlier 11.x release to /storage/.update/ and reboot.

  • could somebody explain to me how to do this? My LE also only shows 11.0.3 in the corner.

    I tried upload nightly build 11.0.0 and 12.0.0 into the update folder using Samba. I just pasted the img.gz file in there. But the decompressing failed every time. "Gzip result corrupted data"

    Should i unpack the file? I thought the answer is no.

    Plus where can i find the Generic 11.0.1 file? I would like to see if i can go back to 11.0.1

  • Uncompression can fail due to random Windows crappiness and lack of space on the /storage partition. Otherwise there is no need to unpack the file. Issues with copying files around are avoided by doing what I suggested: SSH into the box and wget (download) the file directly into the update folder. See

  • Hello everyone.

    I've just joined so first of all I'd like to say thank you to the people who make this possible.

    This my first venture into Libre Elec, my usual way to use Kodi is on an Nvidia Shield, but I wanted to integrate Surfshark and as their Route Via VPN doesn't actually work. I learnt this after I bought a sub, and I only wanted to use a VPN for Kodi on my Windows PC so I repurposed an old Acer Intel Chromebook and I'm using that, but not to view Kodi.

    At the moment it's running like a charm so I'm gonna have a butchers around the site to see what else I can learn.

  • I've just completed a manual update from Matrix to Nexus, which went smoothly.

    After rebooting I can see Kodi in the bottom left and AEONNOX Silvo in the right and a mesage saying its building menu, which it's been doing for about an hour now.

    I can see the please wait dots moving, but as it's been like this for an hour I'm wondering if my update has crashed or if my generic build is still completing the update.

    If anyone could give some idea of how long it will take I would be grateful.

    Sorry I've not put the version numbers, but I didn't take note of them. I do manual updates as soon as I see new ones, but I've never jumped from one update to the next (i.e. Matrix to Nexus).

  • If you're seeing the Kodi splash things are up/running so you can SSH in to check kodi.log and see what's going on (or not). If there's not much info (as not in debug mode) and you have local DB files then it's possible to stop Kodi, add content to advancedsettings.xml for debug mode, delete the Nexus DB files, then restart kodi to reinitiate the update; but this time you'll see more info in the log to find the issue. If you have an external DB then it's the same process but you'll need to drop the tables in the DB to force the update process to restart.

  • Thanks for the info, I have the Kodi remote on my phone and after 2 hours I went with a reboot and everything loaded with no problems.

    I think it got hung up trying to set my menus up and couldn't reboot and just needed a kick in the right direction.