Thoradia Add-ons

  • hello, thanks for your great work!


    Exists a web-interface torrent client with rss embedded ?

    FlexGet is in the pipeline.

    Not sure about web interface.

    Keep it legal and carry on

  • I started this thread a year ago.
    I added FlexGet to celebrate.


    Default configuration downloads a NASA video podcast to /storage/downloads.

    To customize:

    nano /storage/.kodi/userdata/addon_data/service.flexget/config.yml

    systemctl reload service.flexget

    Keep it legal and carry on

  • Hi,


    Thanks for the great add-ons!

    I am using rTorrent and ruTorrent, and I am very happy with them.


    Is there a way to have authentication (user name and password)/https support for ruTorrent web-interface? Without it connecting from a remote network would be open to everyone...


  • Hi hrox,


    Thank you for the positive feedback.


    To define a user/password append :/my_user:my_password to /storage/.kodi/addons/service.rutorrent/config/httpd.conf and restart rutorrent with systemctl restart service.rutorrent.


    I might add this feature to a next iteration of rutorrent, but it is not one of my priorities.


    You can find additional information about BusyBox httpd at BusyBox HTTP Daemon (httpd) [OpenWrt Wiki].


    Be aware that any changes to httpd.conf configuration will be lost each time rutorrent is updated.


    More importantly, the add-ons were not designed for direct connection to the Internet, especially not rtorrent/rutorrent.

    Keep it legal and carry on

    Edited once, last by thoradia ().

  • Thanks for the quick reply.

    Should I not use rutorrent for direct connection to the internet even with a user name and password? Are there security or other concerns to avoid that?

  • Thanks for the quick reply.

    Should I not use rutorrent for direct connection to the internet even with a user name and password? Are there security or other concerns to avoid that?

    No efforts were made to protect any add-on from direct connection as a server to the Internet.

    I have no idea if exposing the user interface of any add-on to the Internet is safe.

    When in doubt, abstain: hic sunt dracones.

    Keep it legal and carry on

  • Great work on this addon - thank you!

    Is there a way of enabling access to Deluge from the Deluge desktop client instead of going via Deluge's web interface? When I try to add the libreelec deluge client to the connection manager in the desktop client it always displays a red status light and won't let me connect. The only way I can remotely connect is via the web port and then open the 'local' connection. I used to have it running when I had Deluge installed on my own Raspbian/Kodi install. I've since switched to LibreELEC for convenience.

    Cheers.

  • Hi,


    I would like to execute some flexget commands in the CLI, but I get the message "-sh: flexget: not found".


    Where is located the "program" flexget?


    Thanks

  • Use flexget.ctl

    Keep it legal and carry on

  • Great work on this addon - thank you!

    Is there a way of enabling access to Deluge from the Deluge desktop client instead of going via Deluge's web interface? When I try to add the libreelec deluge client to the connection manager in the desktop client it always displays a red status light and won't let me connect. The only way I can remotely connect is via the web port and then open the 'local' connection. I used to have it running when I had Deluge installed on my own Raspbian/Kodi install. I've since switched to LibreELEC for convenience.

    Cheers.

    In Deluge web ui, go to Preferences, select the Daemon Tab, select Allow Remote Connections

    Keep it legal and carry on

  • Use flexget.ctl

    Thanks.


    When I tried to use the transmission plugin in flexget I get the following message:


    "Transmissionrpc module version 0.11 or higher required"


    How can I update this module?


    Thanks a lot.

  • I have added it to the add-on

    Keep it legal and carry on

  • In Deluge web ui, go to Preferences, select the Daemon Tab, select Allow Remote Connections

    Thanks for replying. That was already turned on. On or off doesn't make any difference.

    If I add a new connection in the Connection Manager, the IP and port are correct but what should be the default username/pw to connect? By default the web UI just accepts 'deluge' as a pw (no username) but this doesn't work, neither does using root/root pw. I'm baffled! :)

  • Thanks for replying. That was already turned on. On or off doesn't make any difference.

    If I add a new connection in the Connection Manager, the IP and port are correct but what should be the default username/pw to connect? By default the web UI just accepts 'deluge' as a pw (no username) but this doesn't work, neither does using root/root pw. I'm baffled! :)

    This might help you: UserGuide/ThinClient – Deluge

    The configuration files are in /storage/.kodi/userdata/addon_data/service.deluge

    Keep it legal and carry on