Posts by yelkao

    Hi Neostylez,
    The scgi port is normally 5000 but I wouldn't use it. I think you are over complicating it by using the RPC guide as it for integrating directly with rtorrent. So long as you have rutorrent, you should also have the httprpc plugin. For the port, just identify which port your rutorrent website is on. You can find this by clicking configure on the rutorrent add-on. Default port is 6880


    I just tried configuring sonarr and it grabbed a show and added to rutorrent straight away.
    I run rutorrent on port 80. I just used host=localhost , port=80 , url path= plugins/httprpc/action.php
    You should be able to do the same, Probably just change port to 6880

    I've been digging through the forum here and online, looking for the scgi/port to map to for Sonarr <->ruTorrent/rTorrent, also trying various combos. Now I want to use Sonarr and r/ruTorrent combo, and Deluge for private trackers, I've managed to link Sonarr with Deluge. Everything works with the later, but for the life of me can't figure out how to get Sonarr and r/ruTorrent to handshake. 6880 is the default for ruTorrent I've tried static port, I've designated to Lib, localhost. 6880/6890 but nothing works.... any assistance in this matter?

    I don't use the RPC connections as I like what I get from blackhole/watch folders combined with the autotools plugin but because the httprpc plugin is included I think you just need to change your URL to plugins/httprpc/action.php and it should work.

    I have been trying for two days to set up automatic moving of files according to labels

    The rutorrent autotools plugin can put your completed files into subfolders matching the labels but instead of trying to get an outdated script to work, you should look at using couch potato and either sonarr or sickrage to move files.

    The add-ons are ready for LibreELEC 8.2.

    Please report any issues here.

    Thanks heaps for continuing to update these add-ons. With openssl included, I thought I would give 8.2 a try.
    I compiled libreelec and installed the 8.2 add-ons. Unfortunately ssl trackers were still not working with rtorrent. After a little bit of research I found it is actually a known issue with the 7.52 version of curl that is included in LibreElec.
    So, I modified packages/web/curl/package.mk and replaced PKG_VERSION="7.52.0" with PKG_VERSION="7.53.1"
    Recompiled and ssl trackers work!
    So I no longer need to run rutorrent in docker and have the added bonus that I can set my own root password. It was worth compiling Libreelec just for that anyway. Also using sickrage, couchpotato and jackett with no issues identified. It is a fantastic set of add-ons. Thanks again.

    Would you please be so kind to tell me how these are configured in your working rtorrents

    After some further testing, I dont think the issue is certificate related.

    For other implementations I have just refered to a ca certificate in .rtorrent.rc

    ie for the docker instance (which is rutorrent 3.7 rtorrent 0.9.6/0.13.6) I am using

    network.http.cacert.set = /rtorrent/ssl/cert.pem


    removing this line causes tracker error

    "Tracker: [Peer certificate cannot be authenticated with given CA certificates]"


    However, running rtorrent in your add-on, I have found that there is no need to do anything with ca certificates as curl is using /etc/ssl/cert.pem by default

    By setting cacert to an invalid file I can force the error Tracker: [Peer certificate cannot be authenticated with given CA certificates]

    leaving capath unset, or referring to a failed certificate file I see no certificate error but eventually eventually get the timeout message. I think this shows that it accepts the certificate but will still not connect to the tracker properly.


    I suspect the issue is curl/libcurl related There are certainly some protocol and feature differences between the build in the docker image I am using compared with the curl in libreelec.


    pi3mc:~ # docker exec rpi-torrent curl -V

    curl 7.39.0 (armv7l-unknown-linux-gnueabihf) libcurl/7.38.0 OpenSSL/1.0.1k zlib/1.2.8 libidn/1.29 libssh2/1.4.3 librtmp/2.3

    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smtp smtps telnet tftp

    Features: AsynchDNS IDN IPv6 Largefile GSS-API SPNEGO NTLM NTLM_WB SSL libz TLS-SRP


    pi3mc:~ # curl -V

    curl 7.52.0 (armv7ve-libreelec-linux-gnueabi) libcurl/7.52.0 LibreSSL/2.4.4 zlib/1.2.8 librtmp/2.3

    Protocols: file ftp ftps http https rtmp rtsp

    Features: AsynchDNS IPv6 Largefile NTLM NTLM_WB SSL libz UnixSockets HTTPS-proxy


    Looking at rpi-torrent-box/compiletorrent.sh at master · sdelrio/rpi-torrent-box · GitHub I would think that curl may need configuring prior to build with configure --enable-ares --enable-tls-srp --enable-gnu-tls --with-zlib --with-ssl


    I think I need to I build my own libreelec to test further and I wont have the time to attempt that this weekend

    Not really had issues with https trackers in the past running rtorrent on Raspbian and even an entware deploy on my router.
    I am using Librelec 8.0.2 on rpi3 and have been running rtorrent/rutorrent in docker successfully so will revert to that in the interim. I suspect the problem could be related to libcurl and openssl versions in Libreelec. When I find some time I will look at setting up a build environment so I can try rebuilding curl.
    Really liking the other add-ons in this set though. Outstanding job to get all of this running together.

    Is there a known issue with https trackers with the rutorrent/rtorrent add-ons ?
    http torrents work fine but when using https , I get Tracker: [Timeout was reached] and of course no peers or seeds
    I have tried setting http_capath = /etc/ssl and tested the trackers https url with curl successfully

    Is there something else I am missing?