Bricked NAND - how to create a USB bootable SD and LibreELEC on ONE SD?

  • I wonder if there is a way to restore /dev/system... as you pointed that appears to be the issue. I've ran installtointernal successfully before the last time when it froze. So if the eMMC isn't bricked, I'm assuming the partitions are corrupt. I have access to terminal through TWRP, which may not be as limited as LE.

    You should investigate where /dev/dtb is mounted from... And in general what you can reach (mount) on /dev/mmcblk0, when booting from sd...


    -TOP

  • hello,i know the topic is years old,but im kinda stuck with my box which has the same problem *broken nand*,could you please guide me how to use the sd card and flash drive method,my box is a95x f3 equiped with the s905x3 processor,thanks in advance

  • S905X3 devices can be (or should be) recovered from broken boot firmware (e.g. flashed the wrong image) using the Amlogic Burning Tool app and an appropriate firmware image (look on freaktab). You need to connect the box to a Windows PC using a USB > USB cable and flash the image directly to internal eMMC (not NAND). It can be fiddly, but with modern Amlogic devices, unless you cause electrical damage to the eMMC chips there's really no such thing as a bricked box.

  • S905X3 devices can be (or should be) recovered from broken boot firmware (e.g. flashed the wrong image) using the Amlogic Burning Tool app and an appropriate firmware image (look on freaktab). You need to connect the box to a Windows PC using a USB > USB cable and flash the image directly to internal eMMC (not NAND). It can be fiddly, but with modern Amlogic devices, unless you cause electrical damage to the eMMC chips there's really no such thing as a bricked box.

    Thank you for the reply

    I already tried to flash it using amlogic burning tool,the computer recognises the box,but it gives errors when flashing and stops exactly at 7% formatting, I tried different firmwares besides the original firmware from the supplier himself, always the same error, I tried the sd card method but still nothing the box doesn't even turn on, (there's just a red diode that turns on).

    First I used to get this error

    0x32030201]Uboot/Get result/DiskInitial error

    But lately I've been having this one

    0x10303004]Romcode/Switch status/Identify/ Error result

    I'd like to mention that the problem started when I forced shutdown the box by unplugging the power, because it just froze and didn't respond anymore.

  • This is not really a LE problem, you might get more help in the Freaktab forum.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro, X96+, Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)