[UNOFFICIAL][RK3228/RK3229]Libreelec builds

  • Hi all,

    new build of libreelec-11 available with:

    - linux 6.1.19

    - mesa 23.0.0

    - reverted https://github.com/xbmc/xbmc/pull/22919 (for now)

    - estuary skin optimization. removed the ability to set a background graphic pattern for performance reason

    - small fixes and improvements

    This build is an alpha release (not for daily usage), it contains some changes that break the update from 10 and it is strongly recommended to install only on sdcard (currently) and stay with libreelec 10 if something doesn't work.



  • Code
    Thanks I'll try it now who knows that the wify works now. I have no way to connect via heternet because it is too far from the router.

    Edited once, last by MIKMXIII ().

  • Code
    Nothing I think with this new kernel it does not see my radio, the strange thing is that with this build compared to the one with kodi 19.4 it can manage my blouthoot stick.
    But you Michele have a box with my same radio!

    Edited once, last by MIKMXIII ().

  • Everything ok, for now I'm trying it with this version of yours, ok wify and blouthoot and everything seems to be fine no restarts and temperature below 80°c, thanks Mich.

    We waiting Libreelec 11 for our box.

  • Hi ochentay4,

    If you are referring to 11, unfortunately if you have a NAND device still not. I'm working (slowly) on it.

    Anyway I just got a board similar to this one

    finally, I can try to experiment directly with esp wifi chips :)

  • I was referring to 10, its great that you have the same board now!

  • Ok then yes, 10 can be installed in nand. The recommended method is using the armbian multitool but if I remember correctly it didn't work with this board.

    However I don't know the status of your board, but the one I have has android 4.4. So the multitool problem could depend on an old bootloader that doesn't activate the sd card correctly.

    However this board is very well made (good heat sink, external antenna, easy to use uart) so as soon as I have some time I will try the multitool to try to understand where the problem is.

    Another method is to use a usb-a to usb-a otg cable and flashing tools, but it's a bit more 'complicated'

  • Hi ochentay4,

    I've continued my fork of rkflashtool

    GitHub - ilmich/rkflashtool: Tools for flashing Rockchip devices
    Tools for flashing Rockchip devices. Contribute to ilmich/rkflashtool development by creating an account on GitHub.

    which is now able to update the bootloader. It's a highly experimental tool (I'm a volunteer) but it should help you flash libreelec to internal memory. It can also be compiled for windows, but at the moment I don't have a machine to do it.

  • ok, im not a linux user but will try to test it, if you tell me how to use it :)

  • I'm working on this tool because:

    - I needed a simple tool for boards that I have without SD card

    - have a tool that also works on Windows (for users who are in your situation)

    So, given that the software is highly experimental and tested only by me:

    - download prebuilt 64bit windows binary: https://github.com/ilmich/rkfl…kflashtool-5.90Alpha1.zip

    - extract it somewhere. The zip contains the executable and a bootloader for RK322x.

    - put your box in loader mode (insert a toothpick into the A/V port and connect the OTG cable)

    - then execute

    rkflashtool.exe b 3 // this put your device in maskrom mode
    rkflashtool.exe l rk32\rk322x_loader_v1.10.238_256.bin // this put your device in usbplug mode
    rkflashtool.exe d > backup.img // optional, this do a full backup of your nand
    rkflashtool.exe f path_to_uncompressed_libreelec_img.img // flash the image
    rkflashtool.exe a rk32\rk322x_loader_v1.10.238_256.bin // install bootloader on nand

    The box must be in USBplug mode for the tool to work properly, so the first two commands are mandatory.

  • Hey! Thanks for your work, you put my almost trash tv box back to work :)

    I am trying to do this process in my windows machine but I am getting the following:

    \rkflashtool-5.90Alpha1>rkflashtool.exe n

    libusb: info [winusb_get_device_list] The following device has no driver: 'USB\VID_2207&PID_320B\9FEFFAAC84516652'

    libusb: info [winusb_get_device_list] libusb will not be able to access it

    libusb: info [winusb_get_device_list] The following device has no driver: 'USB\VID_2207&PID_320B\9FEFFAAC84516652'

    libusb: info [winusb_get_device_list] libusb will not be able to access it

    fatal: cannot open device

    It looks like some driver is missing in my windows machine. Do you know where I can find those?

    Thanks again!

  • Hi bacalazin,

    sorry, but honestly windows is not my operating system so I tried just the basics :blush:

    I did more tests and saw that the device must be configured as a generic winusb.

    I'm trying to figure out if I can create an ad-hoc driver but in the meantime the guide I followed is this

    WinUSB (Winusb.sys) installation for developers - Windows drivers
    Install WinUSB (Winusb.sys) in the device's kernel-mode stack as the USB device's function driver instead of implementing a driver.

    try and let me known.


  • Hi shMatrix,

    thanks, but it's not quite like that.

    The tools that currently exist for Windows need a driver because they don't know the rockchip usb protocol.

    My tool implements it in user space and therefore technically it doesn't need a driver, but only to access the device via USB.

    On Windows there is a generic driver called winusb, but in practice, it must be associated with the rockchip box which connects via USB.

    On windows 10 it is done with the procedure that I have indicated. On windows 7 it has to be done manually and maybe I figured out how.


    I've tried installing both 11.0 and 10.0 via armbian multitool, but they don't seem to work. I tried installing the original OS that I had backuped back in August when I installed armbian. It ran armbian super laggy and it was basically unusable. I don't expect much from a cheap chinese crap. The original OS didn't boot too. I think i somehow bricked my box. If anyone knows what the problem is and how can I fix it please letr me know.