Linux e1000e base driver for Intel Gigabit Ethernet Network Connection

  • I have finally narrowed down my Kodi NAS Playback issues to a problematic Ethernet connection. My Intel NUC uses the e1000e driver supplied with LibreElec. However, the existing driver is really buggy and outdated.

    Would it be possible to include a more recent version in the next release?…nections-under-linux.html?

    Version 3.8.4 seems to be the latest version, released almost 2 years ago!

  • Users with a problem Ethernet connection are not unheard of, but I'd start with changes to Cables and Switches before pointing the finger at the kernel driver. LE uses the upstream in-kernel driver - which is also used by 10's of millions of other Intel devices. It's not impossible for the driver to have an issue, but if you do want to point the finger in that direction you will need to convince us by sharing some proper technical evidence of it being the source of problems! NB: In all cases we will not update to the not-in-kernel vendor driver, it would be a bad move.

  • I have spent the whole Christmas period, updating my bios versions and OpenElec/LibreElec incrementally.

    I also have a windows box (same Kodi version) that uses the same NAS that plays movies without issue. I have also tried several ethernet cables. I can say with 95% confidence that the issue is the driver.

    I have even read a bunch of posts around the web with people experiencing the same issue. The trouble is, it is very difficult to prove. However, I can reproduce the problem without fail, if you want any specific logs.

  • Basically what happens is while watching a movie via NFS to my WD NAS, the movie will sometimes randomly pause and may then continue at speed, to try to catch up to the point at which the movie would have been. Other times kodi will completely freeze, and I won't be able to do anything at all. On a few occasions i get totally thrown out of the movie and back to the kodi main menus.

    Since unplugging the ethernet and using wifi, everything is fine.

    Also, as mentioned, I have a windows box with the same version of kodi, using ethernet to connect to the same NAS. Everything is fine.

    I have also tried various ethernet cables. Same issue. I am pretty sure it's the intel driver.

    Here are a few other examples of people complaining about similar issues:…s-galore-where-do-i-start…s-galore-where-do-i-start

    Intel e1000e Ethernet not working
    I have the problem that the ethernet device on the Intel NUC is not found. ifconfig -a only shows lo and wlan0 but not eth0. sudo lshw -C net gives the…

    There are many more, however, I do understand that these issues could be unrelated.

    Anyway, may I ask, what is the harm in shipping an improved driver with multiple bug fixes?

  • Anyway, may I ask, what is the harm in shipping an improved driver with multiple bug fixes?

    Test an LE11 nightly from and you will be using the latest LTS kernel driver that Intel has contributed fixes to. If we switched from the in-kernel driver frequently maintained by Intel to some forgotten out-of-tree kernel driver that Intel has not touched in two years; you can expect more breakage than fixage.

  • very likely its not the driver


    running e1000e over years with different kernels without errors, esp. connection problems.

    same goes for my NUC (see signature)

    surfing the kernel bugzilla (e1000e): bugs are all elder and more PCI-e (?) power save related AND should be fixed since, otherwise there should be newer reports.

    couldn't figure what's the last version of the e1000e driver in an kernel tree is.

    any hints ?

    if it related to the date in the copyright string in the driver files: the newest date is "2018" (Kernel 5.16)

    I guess a LE log file could show some more what's up with connection problem the OP is seeing

    DigiBit R1, NUC8i3BEH

    Edited 2 times, last by JoeAverage ().

  • Thanks for your assistance so far. Most appreciated....

    I have some more info for you that might assist. Details of the driver in use are as follows:

    lspci -v

    00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) I218-V (rev 03)

    Subsystem: Intel Corporation Ethernet Connection (3) I218-V

    Flags: bus master, fast devsel, latency 0, IRQ 46

    Memory at aa100000 (32-bit, non-prefetchable) [size=128K]

    Memory at aa13b000 (32-bit, non-prefetchable) [size=4K]

    I/O ports at 3080 [size=32]

    Capabilities: [c8] Power Management version 2

    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+

    Capabilities: [e0] PCI Advanced Features

    Kernel driver in use: e1000e

    ethtool -i eth0

    driver: e1000e

    version: 5.10.76

    firmware-version: 0.2-4


    bus-info: 0000:00:19.0

    supports-statistics: yes

    supports-test: yes

    supports-eeprom-access: yes

    supports-register-dump: yes

    supports-priv-flags: yes

    I notice that the driver on the intel site is version 3.8.4 (latest)? Yet the version number returned by ethtool is 5.10.76? So now I am confused.

    If we truly are running the latest version of e1000e then do you have any suggestions for the freezing and crashes that only happen when using ethernet? I am running out of options.

  • vhgroup - can you please share a full dmesg?

    - Should show the model of NUC.

    - What are the errors shown in the logs?

    What is the setting of AMT in the BIOS? Reportedly the below can change things.

    BIOS setttings -> System Management -> Intel AMT Capability
    switch it from "Restrict MEBx Access" to "Disabled"
  • To enable debug logs on your e1000e card (not suggesting this as a first pass:)

    echo "module e1000e +flmpt" > /sys/kernel/debug/dynamic_debug/control

    echo 8 > /proc/sys/kernel/printk

    Then check journalctl -f and see what happens when you are having the failure. (It is noisy)

  • Bump to the LE11 nightly, because if anything is fixed that's great, and if not fixed it's a current kernel to investigate from wheras the 5.10.x kernel used in LE10 releases is recent but also ageing .. Linux 5.16 was released last Sunday.

  • Version 3.8.4 seems to be the latest version, released almost 2 years ago!

    according to this document (date 2020):

    Release Notes (lan-25.6-release_notes.pdf

    the linux driver version for the 200 LAN Series is 5.3.x

    Linux 5.16 was released last Sunday.

    ... and it seems it might hit nightly tomorrow ... :saint:

    DigiBit R1, NUC8i3BEH

    Edited 3 times, last by JoeAverage: Merged a post created by JoeAverage into this post. ().

  • JoeAverage I can confirm after running "uname -r" my linux version was 5.10.76 as suggested.

    heitbaum Over the next few days I will try your suggestions and get back to you with the logs you are asking for.

    chewitt Will try the nightly as a last resort. Kodi is the only way we watch TV in our house and I have my wife and child to answer to when things aren't working :) I imagine it will take some messing around to get the latest version built, and to be honest, I highly doubt it will fix the issue. My device is a NUC 6, it has been around for years. I can't imagine the Linux team are placing their recent focus on a 6 year old problem.

    Further to our discussion, I believe the following link is very relevant:

    Intel® I218V being the same LAN controller that I use.

  • I believe the following link is very relevant:

    If you believe it's relevant have you tried the workarounds it contains? e.g. "ethtool -K eth0 gso off gro off tso off" .. If you shared logs (as asked multiple times) we'd be able to confirm your box produces the same hang messages. No logs = No problem.

    NB: LE11 nightlies are here: .. If you want to test safely, stop Kodi, rename /storage/.kodi to .kodi-old and then drop the udpate .tar file in /storage/.update and reboot. You will start with a clean Kodi install - which means we don't "upgrade" all your existing config to LE11 and the downgrade is simply the reverse process; stop Kodi, move folders around so the old folder so the active one and drop the older 'update' file in /storage/.update and reboot again. It's messing .. but low drama.

  • chewitt Ah OK, that sounds easy enough. Will try it and definitely provide the logs soon. My problem now is I am back at work, and even though I had a Christmas break, seems like my email inbox did not :cursing: So now I have to catch up two weeks! Holiday? What Holiday?

  • Hi vhgroup - I see you have a NUC6 (not sure on the model) - though has a different Ethernet Chip - but we have the same driver. Mine doesn’t experience th3 same issue that you have described.

    Dumb question…. Did you have wireless enabled at the same time as Ethernet?

    nuc6:~ # dmesg | grep -e DMI: -e e1000

    [ 0.000000] DMI: /NUC6i5SYB, BIOS SYSKLi35.86A.0073.2020.0909.1625 09/09/2020

    [ 1.263095] e1000: Intel(R) PRO/1000 Network Driver

    [ 1.263096] e1000: Copyright (c) 1999-2006 Intel Corporation.

    [ 1.263108] e1000e: Intel(R) PRO/1000 Network Driver

    [ 1.263109] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.

    [ 1.263306] e1000e 0000:00:1f.6: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode

    [ 1.464787] e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): registered PHC clock

    [ 1.532147] e1000e 0000:00:1f.6 eth0: (PCI Express:2.5GT/s:Width x1)

    [ 1.532153] e1000e 0000:00:1f.6 eth0: Intel(R) PRO/1000 Network Connection

    [ 1.532223] e1000e 0000:00:1f.6 eth0: MAC: 12, PHY: 12, PBA No: FFFFFF-0FF

    [ 26.570861] e1000e 0000:00:1f.6 eth0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

    nuc6:~ # lspci -v -s 00:1f.6

    00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-V (rev 21)

    DeviceName: LAN

    Subsystem: Intel Corporation Ethernet Connection I219-V

    Flags: bus master, fast devsel, latency 0, IRQ 125

    Memory at df100000 (32-bit, non-prefetchable) [size=128K]

    Capabilities: [c8] Power Management version 3

    Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+

    Capabilities: [e0] PCI Advanced Features

    Kernel driver in use: e1000e

  • While switching things on and off, I may have had both wifi and internet enabled. Is this a problem? Obviously the system only connects to one at a time?

    My NUC is a 5i3RYK if that helps.

    Going by the model number, I may have been mistaken. Seems like a 5th gen, not 6th gen.

    Edited once, last by vhgroup ().