Missing TV adapter LibreELEC 9.2.8 on Rasperry Pi 3B + TV Hat

  • Hi, I use LibreELEC on my Pi as a media center connected to a Samsung TV via HDMI since 2016 (thanks for that! :thumbup:).


    Now I want to use Kodi also for DVB-T2 so added a TV Hat and switched the aerial from TV to TV Hat.

    After installing the TVHeadend Server 4.2 add-on, on the Configuration web page, the DVB input tab shows no TV adapter.

    dmesg | pastebinit returns http://ix.io/3F8G (copied below).

    No Sony driver compares (which should be as learned from this forum) even if the green led on TV Hat is on and the antenna works well when connected to TV (the signal is strong).


    Before bothering here, I've also tried with a Raspberry Pi OS brand new installation on another SD card but with the same result :(.

    What am I doing wrong?


  • pls go to the driver chooser addon and select there "default LE drivers" and reboot, afterwards it should work


    you have actiavated the dvb-latest driver package for some reason

  • Thanks CvH,

    I went to "LibreELEC Module Drivers" add-on then chose "LE default drivers" from DVB driver module (the dvd-latest was one test, forgot to reset it), then reboot.

    TVHeadend on "http://10.0.0.19:9981/" still have no TV adapters.


    Here is the refreshed dmesg | pastebinit --> http://ix.io/3F9d:

  • The dmesg looks empty, can you try to boot without your usb devices connected it this changes anything ?

    Also pls have a look that you connected the hat properly (I can remember I accidentally shifted it 1 pin while connecting it).

  • Thank you CvH for the patience.


    I've boot the RPi after unplugging the external HDD, but TVHeadend still doesn't see the tuner :(.


    http://ix.io/3Ff0


    I'm pretty sure to have filled correctly the TV Hat pins thanks to the screw guides.

  • The TV Hat works plug and play, so it should just work.

    Its unclear why it is not working for you so lets do some basic tests :)


    Try to install LE fresh at some sd card without anything changed, just boot and install tvheadend and have a look (also keep all usb devices disconnected).


    If this is not working, try a different powersupply (shot in the dark).


    If you use a clean LE install + Tvheadend it should work OOTB.

  • I already did two tries with another clean SD before asking here: one installing Raspberry Pi OS and one installing LibreELEC. No USB device attached.


    Maybe I'll return the Hat.


    This is the power supply: 5V DC 2500mA.

  • that looks not too bad but can you try a different one ?


    I can't rule out a defect at the RPi or the Hat, so all I can say it should just work.

  • Other smartphone' power supplies in the house have less power than the RPi one, so I tried connecting the RPi to a PC USB (maybe it is even lower, I don't know).

    Kodi worked well but shown a little yellow thunder near the clock.

    Again no DVB tuner available.

  • I bought my "Vilros Raspberry Pi 3 Complete Starter Kit--EU Plug Edition" in 2016 with the following characteristics and it has worked great so far, even connecting an external HDD (where I store my camera videos to whatch them with Kodi on TV):

    - Includes The Raspberry Pi 3 Model B

    - Vilros Raspberry Pi 3 Clear Transparent Case With Easy Access to all ports

    - Sandisk Micro SD Card Preloaded With NOOBS --16GB (CLASS 10) & Micro SD-SD Adapter

    - 2 Amp Eu Power Supply--Designed for Raspberry Pi

    - HDMI Cabel--Set of 2 Heatsinks (1 Big 1 Small)


    Now, attacching a "Raspberry PI TV Hat DVB-T/T2 PI TV Hat DVB-T/T2", the RPi still works as usual (Kodi) but the DVB not does not.


    Do you think I've to upgrade the Power Supply? Which model should I buy?


    Thanks in advance.

  • Do you think I've to upgrade the Power Supply?

    unlikely, as long you get no yellow square it should be okay


    can you try a fresh install with an RPi2 test image from https://test.libreelec.tv/?

    its just a shot in the dark, if this is also not working I have no real idea left besides broken rpi or tv hat

    LibreELEC-RPi2.arm-11.0-nightly-20211114-51ad90e.img.gz

  • I've just tried LibreELEC-RPi2.arm-11.0-nightly-20211122-fb8bd5c.img.gz first with Tvheadend 4.2, then with 4.3(Alpha) but in the both cases, the wizard offers only IP TV and not real TV adapter: