LE 10 beta for i4 force hdmi resolution

  • I am using my pi 4 to drive my retro-crt TV

    I have the following in config.txt to enforce a 576i resolution.


    The setting is ignored by LE. It just switches to a resolution it has found with the edid from the hdmi <-> vga/rgb converter.

    The crt TV is not happy with a HDresolution :)


    Is this a bug in LE10 or did I overlook something (/lol me stupid)

    Only the "rainbow" boot screen is displayed in 576i.


    hdmi_group=1

    hdmi_mode=22

    hdmi_ignore_edid=0xa5000080

  • Do you get CVBS output if you disconnect the HDMI/VGA device? .. the hdmi_group/mode/ignore_edid settings no longer work in LE10, the kernel DRM subsystem manages output now (same as all our other devices).

  • Hi Chewitt,


    Thanks for the reply.

    I use the HDMI port with a HDMI -> VGA/RGB sync convertor to drive the CRT directly with a proper RGB signal.

    I do not want to use the (crappy) CVBS output.


    How do you enforce the resolution in LE10 with pi4 ?

    Edited once, last by vasonline ().

  • Hi Hiassoft


    Thank you for your reply.

    Added to cmdline.txt


    You would say it works, however

    There seems something wrong with interlaced modes coming from the PI4

    anyone with a pi 4 wants to test that?


    Selecting 576p in Kodi settings -> works.

    Selecting 576i in Kodi settings -> garbage pixelated.

    Selecting 480p in Kodi settings -> works.

    Selecting 480i in Kodi settings-> garbage pixelated.


    Please see attached pictures showing 576i pixellated and 576p normal.


    Please understand that it _need_ interlaced. Otherwise the retro CRT TV doesn't like it.

    Also it's the wrong aspect ratio. I want 16:9, not 4:3

    ( :) difficult me)


    Here is a photo I took on a recent-ish lcd tv to illustratie the picture quality problem.

    The retro crt will not want to give a meaningfull picture with this garbage PQ.

  • Thanks for the info!


    I could reproduce the pixelated output issue here and pinged the RPi devs - it looks though as 480i/576i output via HDMI always had this issue on RPi4.


    so long,


    Hias