Cloned SD Card corrupted on RPI

  • Libreelec on Pi model 3b

    After reading an image with win32DiskImager and writing it on a other sd-card of the same size, for backup, the Pi wouldn't boot, with the new sd with the following message

    After trying to format for a new install, that didn’t work. I took a closer look and saw that the boot-device mentioned dev/mmcblk0p1 sounded familiar.

    I’d seen that before, using a program to boot ubuntu-install on a computer that won’t boot on USB (Plopcec).

    This mmcblk0p1 was the name of my builtin mediacardreader on my HP G6 W10 laptop and my other bootdevice was called something like /dev/sda0 or so.

    Realising that, I took the cloned sd in an USB adapter and plugged it in, in one of the four USB ports from the Raspberry Pi, removed the original sd from its slot, powered on and behold, LE, and kodi was fully available.

    I think something went wrong, at reading the image.

    THE QUESTION: is it possible to edit one or another configfile to adjust the name of the device, what name should it have en what is the path/ location?

    Or is there an add-on for the Pi that can make a new bootreccord.

    Mind you i am a Windows pro but learning fast in Linux but i am still at a beginners level

    So a solution within a GUI would be welcome, or else exact syntax to copy and paste.

  • I don't know what you want. The rest when we do not want to have partition duplication errors we use some precautions: (1) we use linux to save and recover partitions in another storage, and (2) we verify the recovered partitions before using them.

    • Official Post

    How about doing a backup from LE's Backup/Restore tool, create a new SD card with the LibreELEC image, and restore the backup to the newly created SDcard?

  • Klojum can you be more specific? Do you mean LE usb-sd creator?

    Is there a LE image creator like win32DiskImager? Haven't found that yet.

    Edited once, last by Pruts ().

  • When I said Linux I meant Desktop Linux like Ubuntu. The utilities to use for copying, restoring and verifying partitions and disks are named as "gnome-disks" and "gparted".

  • Tried all the suggested apps/addons/programs, but looks like the sd is in one way or another become write-protected.

    And when I tried to write the image to it, I got the message 256mb smaller then necessary.

    Shrunk the original, made an image and tried again, same message. I think I’ll call it a day.

    And keep the card for spare. Wrote the image to another 32 Gig card. Using my Ubuntu laptop with “Disks” as Elonesna suggested. Thanks for all the suggestions. I now have the backup I need but still don’t understand how the first card got corrupted or write-protect.

    Edited once, last by Pruts ().

  • Finally, found out whats wrong, using check-disk in Gparted, Gparted offered to correct the damage but will and cannot correct it because of the discrepancy. With the SD is physically nothing wrong but changes cannot be made because of the difference,

    No idea how I did this. Anybody?

    Following a part of the translated message:

    The logical disk-building(1890,4,8192) mentioned in the file-system is invalid. The Build stored in the disk label is (121494,255,2)(cylinders,heads,sectors)

    I’ll later gonna try bootsector.img as Chewitt suggested, already downloaded. Thanx4that.