OSMC Wifi dongle disconnects on Rpi2

  • Hi All,


    I've been having an issue with the OSMC wifi dongle consistently disconnecting from my Rpi2.

    I have just recently installed the latest version of LibreELEC onto a brand new SD card. Everything works well except for Wifi. Unfortunately running a LAN cable to the Pi is not an option at the moment and I had a spare OSMC wifi dongle so I thought I would use that.


    The wifi works perfectly well initially, however consistently after a couple hours (give or take) the wifi disconnects and the dongle doesn't appear to be recognised anymore. The only method I have found to resolve it is to either reboot or unplug and reinsert the dongle. This works for a couple hours until another disconnect.


    Thinking that it might be a driver issue I tried the fix outlined here:

    RE: [Solved] OSMC WiFi dongle on RPi

    The dmesg output below was capture after attempting the steps in the link above. As far as I can tell (could be wrong) from the dmesg, the driver seems to be fine.


    I have managed to collect full debug logs, dmesg output and lsusb output. Please see these below:

    Debug Logs

    dmesg output

    lsusb output


    Does anybody have an idea as to what might be causing this?

    Thanks :)

  • One thought I had was that it might be a power issue.

    But I am using an official Rpi Power supply.


    I think the dmesg output above captures the issue, but I don't know what the error indicated there actually means..