LibreELEC (Matrix) 10.0 BETA1 Generic x86/x64 suspend/resume issue

  • Hi,

    I have tried LibreElec 10.0 Beta 1 and was very impressed at how much better my AMD (rx550) card performs in VAAPI now! :)


    I use a Generic x86/x64 build HTPC as my PVR (TVHeadend) and after setting it all up, I was surprised that suspend no longer works for me, particularly as I had tried quite a few early nightlies of 9.80 and it had worked fine in those.


    Re-installing 9.2.6 allows me to use the pc as before.


    The pc suspends fine, either by selecting suspend via the menu or by automatically suspending when idle and not recording. I then resume it by pressing the on/off switch and it appears to resume fine but the screen display is frozen to whatever was on the display as the pc suspended. Also, I cannot SSH onto the box after the resume.


    As SSH no longer connects at all after resume and the box appears to be completely hung, I'm a bit stuck as to how I can provide you with more information?


    If I can do anything to get at least some logs from after the resume, then please let me know?


    Thanks

  • Ah ok,

    As long as you are aware of the issue, I will continue to use 9.2 for now.


    Thanks for all of the hard work you all do, it really is appreciated.

  • Hi,

    Will the AMD suspend/resume issue be fixed in a nightly release at some point, or do I need to wait for a final release of LibreElec 10?


    I was going to try another nightly in a week or two to see if it was fixed?

  • I was going to try another nightly in a week or two to see if it was fixed?

    it is likely just fixed due a kernel bump with a fix included, we can't predict when the fix arrives nor have we one currently (as far as i know)

    but testing from time to time is likely the only way to know

  • Thanks for the quick response.


    Reading my question back, I phrased it wrong entirely as when I see "kernel" it usually makes me think "wait until next version", so I was intending to ask if it would be fixed in LE10, rather than have to wait for LE11.


    I think from your answer you are saying that it could well be fixed in LE10 at some point, which is great.


    Thanks again

  • Thanks for your help.


    I looked into this some more and found numerous forums where the amd/suspend bug for kernel > 5.8 is now fixed in kernel 5.11


    This thread mentions 5.11 fixing the issue:

    [Solved] Lenovo Yoga freezes on suspend / Newbie Corner / Arch Linux Forums


    It also includes details of a temporary fix before 5.11 that involves rolling back a kernel commit to fix the issue:

    [PATCH 09/10] iommu/amd: Store dev_data as device iommu private data - Joerg Roedel (kernel.org)


    Not sure if any of this helps? Is a kernel bump to 5.11 likely for libreelec 10?


    Thanks

  • I have just tried LibreELEC-Generic.x86_64-10.0-nightly-20210406 as the last one I tried was 20210326


    Sadly it is the same, if I select suspend from the power menu to test it suspends fine. If I then resume using the power button on the HTPC I get the display but it is frozen (also no SSH) and I can't do anything other than hit the reset button.


    For clarity, the way I have been testing this is to make a backup, copy the update into the Update folder and reboot, then try the suspend when the kodi menu comes up.


    Thanks for the help and suggestions

  • I have just tried the latest nightly build (LibreELEC-Generic.x86_64-10.0-nightly-20210409-d6594c8) and it is still the same.


    I wanted to make trying nightly builds easier by putting the nightlies on a usb stick and booting from that so I don't need to keep updating and reverting the SSD. To do that I had to remove the htpc from its cabinet and disconnect the SSD to get it to go into the BIOS as it wasn't setup to boot from usb. While I had it out I removed the AMD RX 550 and tried the same test just using the intel 3770k iGPU and still had exactly the same issue.


    Could the AMD card be a red herring and it's one of the other PC components on the motherboard causing the issue or the Hauppauge Quad HD card? That's basically all there is in the case, or is it pretty certain it will be related to a GPU in one form or another?


    This has only been n issue since libreelec 10.0, I had tried 9.80 nightlies previously and they worked fine with my hardware.


    Is there anything else I can do/test to give you more information on this?


    Thanks


    *EDIT*


    I have uploaded a file with DMESG / LSPCI and LSUSB outputs. These are from LibreELEC-Generic.x86_64-10.0-nightly-20210409-d6594c8 booted from USB stick :

    Files

    • output.log

      (65.88 kB, downloaded 15 times, last: )

    Edited once, last by ShadowMask2020 ().

  • Hi,

    Just to report I have solved this issue by removing a pci-e usb 3 card that was driving the front ports of my htpc. I don't really use them much so this isn't a big issue for me, but that was causing the resume hang in LE 10.0. it's possible I added this card *after* testing 9.80 as I changed the case around then and that is when I used the card to get the front ports working, so my assumption it all working in 9.80 was probably misleading!


    The card is just a generic usb-3 pci-e card that I bought quite a while ago but haven't really used until now, it has a VLI chip on it and should be listed in the output.log in the above post. This card does work in LE9.2, but not with the later kernels I assume?


    Thanks all for help in troubleshooting with this and giving me ideas on what the issue may have been. I m just happy that I can now use LE10 again with the better AMD VAAPI support


    Thanks again and if you want me to provide any further info on the usb card just let me know.

  • Similar problem here with NUC Apollo lake - 6CAYH (intel J3455). I used to shutdown my NUC automaticly when TV shuts down (by TV sleep timer or by remote). Now it does not work... Wake up of NUC when HDMI input is selected on TV is working as it used to...