LE-9.2.6 build for some Amlogic S905, S812 and S805 devices

  • Meanwhile, along with another colleague, we are already suffering in the same topic, although he has a different box, but that is also an n200.

    Everything works, except wifi and bluetooth, with the same AP6330. But there is no trace of anything in dmesg.

  • Hi, I have this too, but H18Q img does not boot

    Well, I did not do anything special.

    Burn image on the SD with Rufus. Introducing the SD in the MK808B Plus, press the RESET button to start the image and start. I did not do anything else.

    P.D: Even, then I installed it in the internal memory with command "Installtointernal" and without problems.

  • Hello dtech,

    First of all i want to thank you for all the work you are putting into this.

    the below image also sort of works on the MXIII 4k s802 soc (1G/8G) only the network (10/100 Mbps LAN) does not work.

    2. Amlogic Meson8 (S802) and Meson8m2 (S812) SoC on Linux kernel v3.10.108 (LTS):

    • M8S+ with Amlogic S812 SoC (2G/8G):

      Working services: Network (Gigabit LAN, WiFi 2.4+5 GHz, Bluetooth), amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal).

    Amlogic S8X2 images: Index of /S8X2/

    I get an APIPA address ( so i am guessing it does not have the right driver because with a static ip address it also does not work. The network cable is fine it works on different devices.

    I also tried different S805 images but they do not boot.

    The build in Bleutooth, wifi and the remote also does not work but i can live without those.

    If you could add network drivers for the MXIII 4k s802 soc (1G/8G) box i would really really appreciate it.

    Tell me if you need more information i will do whatever i can to make it work.

  • Thank you dtech for this, I just installed it on a Minix NEO X8-H Plus.

    Version: LibreELEC-M8S-Plus.arm-9.2.6.img.gz

    With an SD card as described in the github readme. Pretty easy.

    Unfortunately the WiFi doesn't work, no networks are available to configure. This should work right? It has an AP6335 module as far as I know (

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    I have connected it via ethernet and installed the system to the internal memory with the "installtointernal" command via SSH.

    It boots fine and I have tried a Twitch stream for example and it is smoothly playing at 1920x1080. WiFi (and bluetooth) still don't work though.

    Is there anything I could do or try?

    Thank you again!

  • I tried to make some images, these are quite different from the M8S+ in a couple of things, because the experience is that the automatic wifi chip detection doesn’t work properly with this devices. I don't know if this is due to the dtb, but for all of them I set the model by static for the specific wifi chips.


    MXIII (S802) with 1GB RAM and AP6330 wifi/bluetooth chip:

    Index of /3rdParty/S8X2-LE-9.2.6/MXIII-S802_1G-AP6330/


    X8-H Plus (S812-H) with 2GB RAM and AP6335e chip:

    Index of /3rdParty/S8X2-LE-9.2.6/X8-H_Plus-S812_2G-AP6335e/

    ... and anyone else who has this device:

    MXIII-Plus (S812) with 2GB RAM and AP6234 chip:

    Index of /3rdParty/S8X2-LE-9.2.6/MXIII-Plus-S812_2G-AP6234/

    But since I don’t have such devices, there is no guarantee that they will boot at all.

    Regardless, please send feedback on the test result.

  • dtech ,

    Thx so very much. Everything is working now even the remote.

    Thank you for your feedback. The configuration of the remote control and DTB is also specific to the device, so I was hoping for this positive end result. ;)

    Now, I’m just waiting for a feedback from TheBronx about the X8-H Plus device.

  • Hello dtech ,

    Libreelec is working very good on the MXIII only i have 1 problem and that is that i cannot turn it on when i turn the box off within kodi.

    It does go to sleep mode but then i cannot turn it on, not with the remote and also not with the power button.

    I have to completely turn off the box by keep holding the power button or to unplug it and then turn it on again and then it works again.

    I have also tried another DTB but still the same issue.

    I hope you can do something to fix it.

    Many thx in advance.