• My current OpenElec on my Nvidia x86/64 device is corrupt (original Kodi repositories & downloads are not functioning), so I am trying to reinstall the latest stable version of OpenElec. Trouble is, when I insert the loaded OpenElec USB and reboot, the system doesn't recognize the USB drive. I have gone into BIOS and the drive seems to not exist. I originally installed OpenElec using a USB and my USB bluetooth keyboard/mouse is still functioning, so I know that the USB ports are functional (yes, I've tried all existing ports and still no love in reading the bootable USB).

    I've attached a screenshot of the USB stick's contents.

    Any suggestions would be greatly appreciated

  • In case you are a little lost, this is the LibreELEC forum. Not the OpenELEC forum.

    If you want to do a reinstall with LibreELEC, use our LibreELEC USB-SD Creator and burn a fresh installer onto your USB stick.

  • Sorry, I kept typing that wrong. I did mean LibreElec. Yes, the USB stick has LibreElec loaded on it and I used the LibreElec USB-SD Creator.

    Apologies for that

  • If the USB stick is not booting, perhaps the boot sector is having problems.
    Try cleaning/formatting the USB stick with this HP USB tool: HP USB Disk Storage Format Tool Download

    Do a full format to be sure and then retry using the LibreELEC USB-SD Creator tool.
    If that not solves it, try a different USB stick. The other one might be worn out.

    What sort of hardware specification does the patient/pc have?

  • Thanks, I'll try that! The PC is an old HP Pavillion and it's been a while since I've checked the specs, but there's an AMD Athelon II in there (not sure of the clock speed), 4GB DDR2 RAM, and some sort of an old Nvidia graphics card. Pretty much an outdated computer that was lying around that I decided to turn into an entertainment center

  • Well, LibreELEC is not in the habit of upholding support endlessly for computers from the stone age. The video card is the most important part, so if that is supported poorly, start thinking of a replacement htpc, such as cheap boxes like a Raspberry Pi 3.