Official LE Test Images for Amlogic (Kodi-20)

  • i have freezes on wetek play2 when playing IPTV like plutotv or german public channels with the nightly from 7.3.2021.

    Should i post Logs here, or is this a known bug? When you need Logs, should i activate something in the debug settings?

    • Official Post

    I'd describe all issues related to audio/video playback as "known" and since there is currently nobody working on the Linux kernel driver code that's at fault, there is currently no need for anyone to share logs. Until someone in the community with coding abilities (which is not me) shows up to fiddle with drivers or commercial projects fund futher activities, progress is stalled.

  • I assume CoreElec have the same problem?

    "CoreELEC 19 becomes the active development branch and it is based on CoreELEC 9.2.6 Amlogic-NG. So all devices that support Amlogic-NG 9.2.6 will also support CoreELEC 19.0-Matrix. There is currently no support for GXBB and GXM (S905 and S912 respectively) based devices as these SoC are EOL and there are multiple devices with newer SoC available."

    • Official Post

    CE have a more functional but rather ugly and complicated vendor kernel codebase. LE has an much cleaner (modern and better implemented) kernel codebase which also respects backwards compatibility and supports open source GPU drivers (so S912 is not an issue) but it's lacking mature media drivers. CE's issue is that Amlogic supports "current and one previous" hardware generation; meaning Amlogic kernel devs do not maintain backwards compatibility with older devices and frequently break support foor older devices when hacking new features in. CE wants (or needs) to use the latest Amlogic kernel drop which presumably drops support or makes life difficult. This is 100% why LE (and Team Kodi) are persuing a path based on Linux kernel standards that breaks the cycle, but it's not the easiest route, in part because we have to write the standards as we go.

    • Official Post

    Hows that strategy working out for your users Chewitt ?

    It could be better, but I have a thick skin for armchair pundits like yourself and prefer to focus on the still reasonable numbers of LE (and now CE) users running older releases on older hardware. I'm confident they are more positive about someone working to bring the latest Kodi releaase on a modern efficient kenel to their board/box, even if progress is woefully slow.

  • Hello!

    I am the owner of a95xf3 air box, LibreELEC works perfectly on this device, for which many thanks to everyone who worked on it.

    It took a full desktop to work and I tried using ARMBIAN and ran into a problem, u -boot did not see the second partition of the SD card, did a workaround and put the arbian partition on the USB HDD. After loading, I found out that WIFI does not work, video acceleration and there is no way to read the SD card.

    Please tell me if it is possible to use the "sm1_s905x3_4g.dtb" device tree from the LibreELEC project in the Armbian project to add device support?

    PS: I apologize if my English is bad, I use google translator

    • Official Post

    is it possible to use the "sm1_s905x3_4g.dtb" device tree from the LibreELEC project in the Armbian project to add device support?

    If Armbian = Linux 4.9, then probably it can be used, because that filename is from a Linux 4.9 vendor kernel. It is *not* from a LibreELEC image because we use Linux 5.11 and the filenames for A95XF3-AIR in LibreELEC images are:




  • only a small feedback.

    Installed todays (box image) nightly on a Beelink M18 (S905)

    TVheadend HD channel ok, non hd green (mpeg2) picture

    searching for addons reboots the device

  • Gave the latest box nightly a shot on a Vero 4K+ (S905D), pretty impressive progress. Only thing noticeable was the seeking issue, and some sort of brightness flickering. But it seemed to use hardware decoding, and CPU usage is usually in the ballpark for this device. I am pretty basic user, tho, 1080p, regular old HDMI audio, mostly x264 encodings. Much like my RPi4 setup on LibreELEC 10. :)

  • Did anyone managed to watch SD TV with these images?

    I tried the p200 gxbb Version from 11.04 on a Beelink M18.

    In TvHeadend HD channels are fine - even switching between them.

    Amazon Prime Plugin works as well.

    But for SD channel I get a green screen. Is it somewhere possible to define to use mpeg2 software decoding instead of hardware? Maybe it would work then. CPU wise the CPU should be fast enough.

    I the Windows Builds there were some options to decide which codes is handled in hardware and which in software. On Arm I have not seen this - maybe because it is not controllable?