Failed update from 9.2.1 to 9.2.3

  • Hello folks,

    I am sad to report that my slice (with a CM3 and no internal HDD) has failed to upgrade.

    I was running 9.2.1, and everything was smooth.

    Then I decided to upgrade to 9.2.3 today. I did the upgrade via the GUI as usual.

    The file DL as it should and my Slcie rebooted to apply the upgrade.

    I should say that I did not really look at what happen since I never encountered any issue with upgrade before. I think that upon reboot, the Slice started to upgrade (reading the archive, etc) and I assumed that it did what it was supposed to do. Then I got a black screen.

    Usually, the Slice reboot one more time after this and go into Kodi.

    This time it did not happened. I waited 5-10 minutes, unsure what to do and then tried a hard reboot by unplugging the power.

    The Slice switch on (I always have the first colourful square picture) but then nothing. LibreELEC and Kodi do not boot.

    I have tried both the Kodi remote and ssh and nothing there.

    Any advice on how to restore the situation?

  • As the Slice has no USB or SD Card boot and the device is not booting (or booting far enough for SSH to work) the only real option is to reinstall the OS by flashing from a PC over the USB connection.

  • So I guess that means I cannot hope of saving my config files? If I flash, I will have to reconfig everything and lose my watched movies, etc.?

  • In theory the data is sat there on the eMMC storage and could/should be readable to make a backup *but* the data is on an EXT4 partition that cannot be read under Windows and I'm not sure 5Ninja's ever released Linux drivers/tools for mounting the storage.

    An old IT saying/proverb states there are only two type of computer users: a) those who back-up their data with religious conviction, b) those who haven't lost all their data in a mishap yet" .. which is kind of true.

    I shifted my DB stuff into a central MySQL DB some time ago as I'm hopping between different test devices all the time, but that's also another good way to make endpoint devices a bit more stateless.

  • Thanks for taking the time to answer. I tried the flash procedure yesterday while waiting for your answer to see if there was anything to salvage (with no luck obviously). I stopped just before flashing the cm3 (so everything was working good).

    But today, impossible to load the BMxxx with the rpiboot.exe. I tried multiple times (because I know that sometime it is a bit temperamental). Nothing. Seems that my CM3 is beyond recovery (I opened the case and checked for bad contacts so might have fried it definitely).

    I plugged my old CM1 and everything was working both for the flash procedure and even for booting in an old 17.00 Kodi. So i might recover my profile from 2 years ago (that would still save me some time).

    With that said, I think it is the end of the Slice adventure for me. I will move to a classic Rpi4 in the future (since h265 is such a pain in the slice). It is a pity because I really like the case and leds. I would like also to thank the LE team for having supported the devices until now. Thank you.

  • Never give up. Today I succeeded in flashing my CM3 (maybe it was some thermal past that was short-circuiting something, that I managed to clean).

    Since my last back up was when I moved from CM1 to CM3 (=3 y ago), I had to downgrade the CM3 to 7.95.1 :) Restore the back up, and update to 9.2.3. Everything was smooth this time.

    Then I spent some 2h tagging again watched movies and shows and I am now back to "normal" :)

    The only thing is that I have already a RPi4 on the way, but at least I had plenty of attempts to rehearse how to flash, back-up, restore, etc...

    Again thank you for the support.

  • As the Slice has no USB or SD Card boot and the device is not booting (or booting far enough for SSH to work) the only real option is to reinstall the OS by flashing from a PC over the USB connection.

    Hi, i wanna reset my hole Slice. I entered the Recovery mode and wanted a clean System. But then this Message appears. Is there no "local" reset possible the orig. ninjas website is probably offline.

    Or Maybe I can install the latest LibreELEC-Slice.arm-9.2.6.img.gz "directly" via an USB-Stick with FAT formatted?^^

  • I never really used the NOOBS based recovery stuff so I can't really guide you on how to work it, but the best option for LE use is to connect the box to a PC and (as per the comment you've quoted) write the image directly to emmc overwriting NOOBS.

  • Thank you! is there a manual to overwrite the Emmc?


    the only real option is to reinstall the OS by flashing from a PC over the USB connection.

    should I boot the slice from an usb stick with the latest image.gz, or how can I connect directly to the Slice (if ssh is not possible)

  • Ah... its me again. I bought a Compute Module 3 and wanted to install the image via the method above, so I downloaded the cm3 Slice image from here, but the slice with the cm3 don't appears in the windows disk menu so the raspberry pi imager can't write the image. I've made a quick video

  • Just ran rpiboot to compare..

    theres some differences but looks like its not crashing out. does your CM3 definitley have flash memory, i think you can buy them without.

    other than that i would try a different usb port or PC and see if the problem follows the slice or the PC.

  • You've purchased a CM3+ "lite" module. The U7 blank on the right side of the second image is where the RAM chip is (not) soldered.

    CM3+ Lite identification