Wifi sometimes works and sometimes not

  • Hi, since I have this computer, I used LibreElec on it. I've started using LibreElec since it's 9.1v, and I had no issues. I don't remember exactly after which version of LibreElec, I've started facing wifi issues. The problems is that sometimes connects to the wifi, but it won't detect the internet connection, and won't appear as a local device (seems like it can't communicate with the router or so), and sometimes it just doesn't wants to connect to the wifi, it just says failure on LibreElec settings.

    For a easy understanding, I'll explain them separately.

    1st Issue: WiFi "Seems" to connect, but doesn't works.

    In this case, in the LibreElec settings app, it shows that my PC is connected to my wifi, with a specific IP (a valid one for my router) but none wifi dependent addons will detect the internet connection (addons like Netflix, PlutoTV, YouTube, etc). Also, if I try to ping to the PC, it won't let me, and if I check if the PC is connected to the wifi, it won't show up in the router as connected. There is no specific way to reproduce this error. It's just try and error and see if it happens. I couldn't reproduce the error, so I don't have a log.

    2nd Issue: WiFi connection failure:

    In this case, the PC won't connect to the wifi. The LibreElec settings app will show a message (failure) next to the wifi that I'm trying to connect. Forcing to connect to the wifi (pressing the wifi connection and pressing connect), wont help. Setting a static IP also won't work and turning off and on the wifi adapter (pci) also won't help. This error also has no specific steps to be reproduced. It's just luck. I have the logs, but, while attempting to reconnect to my wifi, Kodi crashed, so I'll send 3 logs: kodi.log (after the Kodi crash), kodi.old.log (the actual log with the wifi error) and kodi_crash.log (the crash report of Kodi)

    Here go the logs:

    ~ kodi.log:

    ~ kodi.old.log:

    ~ kodi_crash.log:

    My system specs:

    Motherboard: ASRock N68S-UCC

    RAM: 4Gb DDR2

    GPU: AMD/ATI Radeon HD6670 (1gb)

    CPU: AMD Sempron 140 (Overclock to 3.3GHz, unlocked second core, now detected as a AMD Athlon II X2 4400e)

    WiFi board: Qualcomm atheros AR9227 wireless network adapter (rev 01)

    LibreElec version: 9.2.3

    If you need more info about the errors, please, tell me, this is the first bug report I've made


  • Kodi logs aren't much use for degugging OS issues related to wireless (Kodi isn't the thing with the problem). You'll need to share the systemd journal, e.g. "journalctl -b 0 --no-pager | paste" and copy the URL (easier than copy/pasting to pastebin).

  • Kodi logs aren't much use for degugging OS issues related to wireless (Kodi isn't the thing with the problem). You'll need to share the systemd journal, e.g. "journalctl -b 0 --no-pager | paste" and copy the URL (easier than copy/pasting to pastebin).

    Ok, the problem is that the PC won't have internet connection, so, I cannot upload the log to paste or anything. How can I copy the log and pase it in another folder? That's what I've made to get those Kodi logs

  • journalctl -b 0 --no-pager > my_journal.txt

    copy and paste the contents of the file "my_journal.txt" to Ubuntu Pastebin

    post the adress-link after you pressed the Button named "Paste!"

    DigiBit R1, NUC8i3BE

  • chewitt

    who is meant ?

    me ?

    sure it does:

    1. go to ubuntu's paste bin

    2. put in a name

    3. put in the text (the log file or a short text for testing)

    4. press the button "Paste!"

    5. watch the ending of the adress link has changed to something like this: ... ubuntu.com/p/QnW6MHMMX7/


    for the record: *I* always test the instructions I post

    DigiBit R1, NUC8i3BE

  • Sorry guys, right now I cannot get the error to show up so I can't send you the correct log. Probably it will take some time. As soon I get the log I'll paste it and send you the link

  • I've finally got the error to show up.

    Ubuntu Pastebin

    In this case, after knowing that the PC failed to connect to the wifi, I tried reconnecting and it successfully reconnected. So, this is a new case I think

  • I'm far away from being an expert reading your log nor giving the right advice regarding your wlan problem, but some thoughts:

    first some keywords/commands to investigate/further reading:

    - wpa_supplicant
    - regdomain

    - iw

    what *I* find in your log:

    Jul 06 14:51:28 LibreELEC kernel: wlan0: deauthenticated from 62:02:71:8f:22:33 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    Jul 06 14:51:28 LibreELEC connmand[381]: wlan0 {newlink} index 2 address 90:F6:52:F9:3B:6C mtu 1500
    Jul 06 14:51:28 LibreELEC connmand[381]: wlan0 {newlink} index 2 operstate 2 <DOWN>
    Jul 06 14:51:28 LibreELEC wpa_supplicant[568]: wlan0: CTRL-EVENT-DISCONNECTED bssid=62:02:71:8f:22:33 reason=15

    there are reports in the inet that some versions of wpa_supplicant made simular trouble you reported.

    I currently don't know which version is in LE now nor do I know if that's the problem here.

    One other and me got a long term regdomain bug with atheros cards (disabled channel 12 and 13)

    some questions:

    is your router and your wifi card *always* able to see each other ?

    means: did you pick the right channel on your router ?

    the channel you picked yesterday doesn't means it works today too !


    2.4 GHz is usually populated. I see ~40 in my neighborhood. In germany I'm able to use channel 13. Channel 13 is mostly off per default on the neighborhood routers, so while free I could use it and prefer it mostly [1].

    On the other hand I made good experience to use the same channel from the strongest router signal I see in my neighborhood.

    Why ?

    if you have ever played with apps which display the wifi signals graphically, you know they are displayed as parabola's with it's apex above the choosen channel.

    if I choose (in an populated wifi area) a channel beween the apex and the intersection with the x-axis of the neighbor's parabola (signal) I get disturbances of my signal.

    the fewest disturbances do I get if my apex and the neigbor's apex are the same => the same channel.

    sounds funny ?

    physics teaches (sort of): waves with the same/different Phase's boos-t/destroy each other.


    and while the routers addional configured per default to "auto channel choosing" they move away (from my channel 13) some days later ;-)

    DigiBit R1, NUC8i3BE

    Edited 6 times, last by JoeAverage ().

  • Thanks for the reply. Answering you questions:

    I cannot pick a specific channel on my router, the "ISP" (I think it's called) doesn't lets me access the router config webpage. It asks for a password that I don't have. Also, the distance between the PC and the router is small (no more than 5m), and the PC cannot see so many other neighbor's wifi. I've checked what you say about the wifi channels. None of the other wifi seem to interfere with mine.

    As you can see (my network is cba72) I don't have so many other wifis interfering mine. What it's strange, but I don't think it is a problem, is that other wifi network (Familia_Antun) that occupates almost 5 channels. Btw, you see 2 cba72 because I have a network repeater. It appears as one cba72, but I've tested shutting the repeater down, and sometimes the error also occurs.

    I home that my answers help a bit to figure out what's happening.

  • Thanks for the reply. Answering you questions:

    I cannot pick a specific channel on my router, the "ISP" (I think it's called) doesn't lets me access the router config webpage. It asks for a password that I don't have. ..

    Usually the router password is in your manual.

    If don't own one anymore, find the typ of your router (backside label ?) and search the inet for a manual or password.

    then *I* would play/test with channel 13, 11 (and 4).

    keep in mind: if you change channels your wifi equipment need some time to settle (~2 minutes)

    maybe another place for your router could help (moving out of the range of "Familia_Antun").

    maybe nailed at the half high of your wall with free (!) "sight" into the room/to your wifi devices.

    Please post the typ of the router here, too.

    DigiBit R1, NUC8i3BE

  • Ok. Thanks to your comment "usually the router password is in your manual" I finally accessed the routers webpage. In my country, ISPs, usually, lock the router, so the customers cannot change anything that they don't want. I was so lazy, that I only tried with the defaults (admin, admin) until now, that I read the manual and I found out that the password was a very easy password (admin, zhone). I will try changing the channel, now that I have access to the router, but I want to check some things before doing anything.

    If you look at the next image, you can see that almost all channels are occupied (idk why before I didn't saw so many neighbor's wifi).

    Now, this app has a tool that recommends you a channel for your wifi network.

    As you can see, the app suggest me to use channels 4, 3, 8, 9. Why? Aren't they already occupied?

    The other thing, is that I cannot move the router. Mainly because it's a fiber-optic router, and, as you might know, fiber optic is very fragile, and, also, the man that made all the electronics of my house messed up all wire channels, so, I cannot change the router location (also, I don't like the idea of having a wire on the corner of the sealing)

    My router is a DZS ZNID-GPON-2426A1.

  • A 2.4 GHz wifi channels are always occupied !

    - except you got a castle in the wood or on a hill (outside of all the "outlaws" out there) - ;-)

    what holds you off playing with the channels what the tool suggests ?

    but look at your screenshot:

    a) your wifi indicator (upper right corner of your smartphone display) says with your channel 1 nearly full wifi speed (until familia_antun moves again to channel 4 or so, I guess).

    b) channel 4 and 8 are both the flanks of "familia_antun's" parabola, so I would estimate more trouble there

    c) Famila_antun is the strongest wifi you see in your wifi equipment, so either go them completely out of their way(channels) or - according my writeup above - use extactly their channel.

    but it seems (your screenshot in comment #10) they use auto channel (yesterday 4, today 6): means you might never win until you do auto channel too - hoping the router software is smart enough -

    d) low parabola's means to me "far away" => less trouble.

    means Family "Zamblera" or "Capeta" could be your friend and I hope familia_antun wasn't smart enough to switch channel 13 on too.

    as said change the channel and wait some time that the routers wifi equipment settles, then switch off your PC-wifi card and on.

    Try to download a big file to see if the download speed change during download or if it is (nearly) constant.

    You need to download only some parts of the big file over some few minutes.

    usually you can see the download speed in the download manager of your web browser.

    Alternativ use a netspeed measure tool.

    a big file from an usually good connected download server is this:

    Download Ubuntu Desktop | Download | Ubuntu

    I see with an nominal 50 Mbit/s internet connection ~5,8 MB/s as download speed (measured via LAN)

    - (ISP's nominal internet-speed div. by 8 ) - 10 % -

    tricky, isn't it ?

    what's about to rent a castle ;-)

    or alternativly move your wifi equipment to devices which could do wifi 5 Ghz ?


    what's the typ of your repeater ?

    could it do 5 GHz ?

    And change the routers password to a stronger one !

    - That default everywhere known router password also might lower the ability to rent the castle -

    DigiBit R1, NUC8i3BE

    Edited 6 times, last by JoeAverage ().