wifi speed drops

  • Hi


    Recently,i tried libreelec project but i am facing a major issue. The wifi connection is 3 mbps instead of 7-9mbps that i have on other devices in the same spot ,it's difficult to connect through wired connection because the router is 3-4 meters away, i also tried the connection with a wifi adpater (wifi usb) and i get the same speed. is there any way to fix that issue or somehow increase the connection speed ? because sometimes i also get wifi speed below than 1.3mbps . ( i am using raspberry pi 4b 8GB ram model)

    thanks for the precious time of whoever read this thread , and sorry for my bad english

  • Try connecting the external wifi adapter through an extension cable. The rPi4's unshielded USB3 controller is a well-known problem: it throws around a lot of interference.

  • You mentioned an external USB adapter. You can use a USB extension cord and place the USB wifi adapter in perhaps a more optimized location.

  • I just tried it, nothing the connection speed it is the same but when I connect it with wired connection I get 12mbps but I want with wireless since the router is far from the television that I want to use the libreelec

  • 12 mbps with wired...


    I think you mean 12 MB/s, which refers to a 100 Mb/s connection on the router.

    The naming conventions in network speeds is important. There is a difference between bits and bytes.


    What is the top speed of your router or access point with wireless connections? Does it do both 2.4 and 5 GHz connections?

    A router with only 100Mb/s (gigabit is common these days) will also not have the fastest wireless speeds.

  • It can do both 2.4 and 5 but I also see on other threads that libreelec finds only 2.4 connection and not 5 and i meant 12 Mb/s , and i can't with 3 mbps or below to have a proper internet access on libreelec

  • Just a thought. You said you got the same exact results using an external usb wifi device. Then you said the usb extension cord made no difference. Are you SURE you were using the external device and not the internal one ?

  • Oh but I get better connection speed on all devices can somehow fix it for the libreelec to get better connection instead of 1-3 Mb/s and yes i am sure because the extender wifi duplicates the networks and the normal one is wlan0 and for the extender wlan1 and on both i have the same shifty connection

  • I just plugged it in and all the networks were duplicated , the one of the pi had wlan0 name and the others had wlan1 which was from the extender

  • nope, it wasn't the networks were duplicated and I both of my network (with the pi's wifi and with the usb wifi (that can get both 2.4ghz and 5ghz) are the same speed which is 0.8-3 mb/s instead of 7-9 that i have on the same spot in other devices