Posts by Franco

    I had this same type of problem. My only video source is a cheap 120 GB SDD, which now is connected to the RPi 4 through a USB-SATA cable that supports UAS. Before I tried two or three cables and enclosures which didn't support UAS, I applied the quirks to them, and they worked OK but I got the same symptoms that you describe.

    Look here to find USB SATA to USB adapters that support UAS: Raspberry Pi 4 USB Boot Config Guide for SSD / Flash Drives . Since I changed my adapter a few weeks ago I experienced no more video freezes. Your freezes could of course be related to something entirely different... Just my 2 cents...

    Hi Stefan, I read months ago that the USB3 circuitry and sockets in the PI 4 are unshielded or poorly shielded, so it receives a lot of interference from devices which are directly connected to the USB sockets. Try using USB extension cables and move as away as possible the devices from each other and from the Pi. In my case I have a 50 cm extension cable for the USB3 SSD connected to USB3, and a USB2 connected hub with a 50 cm cable for both the remote and mini-keyboard sensors. This setup works well (with the quirks for the SDD, obviously).

    Try connecting the external wifi adapter through an extension cable. The rPi4's unshielded USB3 controller is a well-known problem: it throws around a lot of interference.

    Please mark this thread as solved.:)

    I googled for my situation, I found out that the Pi4's USB3 has issues, its chip is easily disturbed by 2.4 GHz dongles nearby (so use a USB hub for them), and by improperly shielded USB cables. I googled for a long time, and at last I found this link: STICKY: If you have a Raspberry Pi 4 and are getting bad speeds transferring data to/from USB3.0 SSDs, read this - Raspberry Pi Forums


    Following the instructions I learned that my USB3 enclosure does not support UAS. UAS is an upgraded transport protocol, more efficient than the old one, "USB mass-storage". And PI4 insists on using UAS, which caused the terrible delays, but applying the instructions found in that web page I was able to get an acceptable boot time. Disk mounting and browsing, however, were still as slow as before.


    Having no other enclosures I could test, I extracted from the bottom of a drawer a long forgotten SATA to USB cable, to which I connected my SDD. That did the trick: now the SDD is browsable immediately after LE's boot completes. This cable is chinese, the brand is CableDeconn, I got it several years ago, and never used it.


    So if the software solution does not work for you, try another enclosure for USB3 speed. If you connect any enclosure to a USB2 port, it will probably perform perfectly, but of course slower.

    Hello, I have since 1 week a Pi4b (2 GB), I installed LE last version, and then I reproduced exactly the same setup I have running in my old Pi3b (NFS shares, remote control setup, "A Confluence Zeitgeist" skin, and an NTFS formatted SSD connected to the Pi through an USB3 enclosure). Ah, I upgraded the Pi4's firmware, too.


    With pi4 the LE's startup time is much longer than with Pi3, and this is a bad surprise. When my external SSD is connected to an USB3 port on the Pi4, it gets mounted about 20 seconds after the UI has appeared. And if I try to access the disk to play a movie in it, I must wait about 20 more seconds to see the file list. I tried changing the USB cable and the USB3 port, to no avail

    I switched to the default skin to see if there were differences, no change. I have only addons downloaded from LE's repository.


    (I think this is a Kodi problem, not LE's, because in Raspbian the disk's icon appears instantly on the desktop, and I can immediately see the disk contents. But if I install Kodi in Raspbian I get exactly the same behavior as in LE.)


    It occurred to me to try and change the USB port, this time using a USB2 port of the Pi4, and presto chango! Everything is normal again, no delays mounting the disk or waiting for the file list.


    I wonder if I am doing something wrong, and I would be happy and grateful to learn if there is a way that could make me enjoy the Pi4's USB3 ports.

    Thank you for your attention!

    In my experience, "older" BT headphones connect automatically, while "newer" ones need to be manually connected at every boot. This has something to do with the headphone's "hands-free" cell telephone capability.

    Under the Windows operating system it's the same problem, but you can disable the handsfree component in Device Manager: this will make your phones autoconnect. This is valid for my phones, Sony WH-CH700. I don't know if there is a way to persuade my phones to autoconnect under LE.

    Maybe in the future I'll switch to an AudioTechnica BT headphone (many of them lack the handsfree feature, so they should connect automatically).

    Thank you very much Iridium!

    My RPi3 is quite far from my main router, I connected to it with a WiFi USB Key, but results were not optimal because I live in a house with a very crowded WiFi environment. I tried 3 or 4 different WiFi Keys without any improvement. Following your suggestion, I bought a €13.99 N300 router with three 5dB antennas, I cable-connected it to the RPi, and this solved my problem beautifully (and at a lesser price than any of my former premium WiFi Keys.) I write this post not only to thank you, but also to encourage old and new users who have WiFi problems to try this solution. Ciao!

    Thank you for the link, blueribb. In that post someone said that disabling the onboard Wifi solves the problem. I can't confirm this statement: since months my Pi's internal Wifi is disabled, I use an external Wifi USB adapter placed quite far from both the Pi and the TV (by means of a thick USB extension cable) to avoid interference and maximize the connection speed. Even with internal Wifi turned off, the onboard BT in my Pi3 seems to perform very badly with audio. My setup now works like a charm.

    Hello everybody! I am running LibreElec 8.2.3 in a Raspberry Pi3. I recently bought a bluetooth 4.1 headphone and connected it without any problem to LibreELEC, but watching movies I experienced variable audio delays large enough (1 second or more) to unbearably annoy. I tried connecting the headphone to 2 computers running Win 10 64bit by means of a €8 USB bluetooth 4.0 adapter, and there was no audio delay watching the same movies. So I tried using the USB adapter on the Pi3 after disabling the onboard bluetooth, and the delay was gone forever (it seems).


    So I would like to ask: is anything fundamentally wrong with the Pi3's onboard BT? Or might it be that it goes bananas because I also have a USB WiFi antenna and an OSMC remote connected to the Pi? I think that the power supply, which is an original Raspberry 2,5 ampere, is not to be blamed.


    I would like to thank you all because reading this forum I learned a lot of things, and now my Pi3 and its LibreELEC run beautifully. Many heartfelt thanks also to the LibreELEC team! LE is really a great media center!