RPi4 - Can't use WiFi, Network Error Input/Output Eror

  • FOUND THE SOLUTION: I changed my WiFi network channel to channel 10. If you are having this issue it may be worth a shot to change your network channel to something else.


    The cause of this is likely the issues that the RPi4 has been having recently with the HDMI signal interfering with WiFi.


    Below is the original post I made.


    I'm on the RPi4, running the latest version of LibreELEC.


    I have been attempting to get it to connect to my WiFi with no luck. I put in my password and it does not connect. The first attempt seems to cause a crash. Second and subsequent attempts return a "Network Error Input/Output Error".


    There was only one exception to this, and that time it returned a "Network Error Operation Aborted"


    I don't know what to do to fix it.


    What I have tried:

    • Wait for network before starting kodi (30 seconds) - doesn't help, in fact I get the error "Failed to start service Wait for network"
    • Wait for network before starting kodi (60 seconds) - same as above
    • Wiping the SD card and using a fresh install of LibreELEC - didn't help at all.

    This issue has been reported several times on these forums, but none of them have any fixes.


    Link 1, Link 2, Link 3, Link 4


    I tried some of the suggestions I found in Link 4. Unfortunately neither switching the USB port I put my wireless keyboard into, nor switching to a wired mouse, helped.


    Does anyone know what the issue could possibly be? Or have a fix? It's very frustrating.


    EDIT: Okay, so I was somehow able to get it to connect to a different network. The network I was using served as sort of a boosted wi-fi connection from a main network. Connecting to the main network somehow worked. Maybe it has something to do with the network or router? If so I'm not sure why LibreELEC would crash the first time I attempted the connection. In any case, things are working for me now. I still have no idea what the issue was though.


    EDIT2: Okay, it may have connected to the network, but I don't have internet on the device. I can't seem to connect to any repository at all (not the default KODI addon repository, nor the LibreELEC repository), can't connect to my VPN, and the time servers only seem to be working occasionally. Also the Remote Connection Server consistently fails to start at the beginning. No idea what the issue could be, all the configuration options look okay.


    EDIT3: New day and I still can't get it working. Somehow got the LibreELEC repository working but no other repositories are working, the VPN still isn't working, and I can't even SSH into my device. At this point I'm completely lost and with the lack of help from people who actually know how LibreELEC works, I'm about ready to throw in the towel and start looking for other kodi solutions for my RPi4 that might work better.


    EDIT4: Finally managed to get a log file for it. Don't ask me how because I have been unable to upload any log files after I uploaded this one. http://ix.io/26cj


    EDIT5: So I got fed up and installed Rasbian and in an absolutely bizarre turn of events the issue persists but only in 1080p. Internet works fine at 768p and lower. No clue why, but since the issue is persisting in Rasbian and not just LE, I assume my specific issue isn't related to LE.

    Edited 6 times, last by LordBadon ().

  • After working through all the problems in Rasbian and getting the internet working in Rasbian, I tried LE again.


    When trying to connect to one network I get "Network Error Input/Output Error"


    When connecting to the other network it connects to the network, but not the internet.


    So basically I'm back at square one.


    Is there nobody here that can help me?


    EDIT: I just tested things out with a third network by sharing my phone's mobile data connection and it works on LibreELEC! So it may actually be a network configuration issue on my part. Does anyone have suggestions on how to identify it?


    EDIT2: This is a long edit. See everything below.


    I've done more testing in LibreELEC. I found that if I set the screen resolution to 640x480 the wifi suddenly works somewhat okay.


    At anything higher than 640x480 it doesn't work.


    In fact the 640x480 screen resolution helped so much that I was able to connect to the network that was giving me the "Network Error: Input/Output Error" message. This wifi network is the one that I changed from channel 3 to channel 8 to make it work in Rasbian.


    While in 640x480 I downloaded the YouTube addon from the KODI official repository. It would only play back video when I set the LibreELEC screen resolution to 640x480, at any other resolution the video would not load and in fact most of the time it wouldn't even load the search results.


    EDIT3: I DID IT! I FINALLY FIXED IT! Thanks to the Raspberry Pi forums for the help. What I did what change my WiFi network channel to channel 10.

    Edited 3 times, last by LordBadon ().

  • Thank you for this! I was having the same problem, and this fixed it. It was making me crazy...

  • I've found myself experiencing this very same issue.

    The proposed solution only provided temporary relief.


    I recently got a new phone and noticed it was connecting at a slower speed than the phone it was replacing.

    I tweaked some settings on my router and corrected the issue.


    That's when I started noticing drops from my Raspberry Pis

    I have several Raspberry Pis. [3B, 3B+ and 4B] although I don't think I am using 3Bs.

    I was observing disconnects on 3B+ and 4Bs running LibreELEC 9+ Kodi 18+


    Naturally, I initially suspected my Netgear Nighthawk R7000 router

    Its, at minimum, 8 years old.

    I'm running VPN server [an Amazon EC2 instance connecting to my home network]

    I'm also running two instances of VPN Client [separating streaming content from other traffic]

    Its also overclocked to 1200Mhz from 1Ghz.

    I was sure it was End of Life

    I was looking at getting a R9000 from Netgear

    However, their forums had users reporting the exact same symptoms w/ that router that I was seeing

    It wasn't related to Kodi or LibreELEC but that still made me suspicious


    So I dug some more and tweaked more settings, knowing that tweaking settings is what started all this

    The input/output error on connections kept occurring

    My new phone would drop its connection and not reconnect either

    When I encountered the error the RPi and Phone would not reconnect without rebooting the router.

    Then it would work again until the next failure


    Then I came across this thread and changing the channel seemed to work

    BUT... I couldn't get the RPi4 to connect to the 5Ghz network only the slower 2.4G network


    It was late, I wanted to watch a bit of tv and go to sleep

    I wanted to leave this issue until tomorrow [yesterday]


    So I slapped an older 3B+ on my TV which still had LibreELEC 8+ and Kodi 17.7 on it.

    I was remembering wrong, though

    It had been so long that I was expecting it to only connect to the 2.4 wifi

    At this point, I was fine with that


    To my surprise, it started and could see all networks/SSIDs [I have virtual SSIDs (1 on 2.4Gh and 1 on 5Ghz)]

    It was connecting immediately to the 5Ghz network and the signal was in the 90s

    Previously the 4B was seeing signals in the 60s.

    It's been 2 days and my connection is still strong.


    In that time, I've had one of my TVs streaming CNN

    It only stopped streaming once in that time and I restarted the stream.

    The connection with my network was still strong.

    But even with solid connections I can't remember having a stream play continuously for over a day

    Obviously the source was a quality source but also the connection [and more importantly my router] was no longer the weak point


    The issue appears to be LibreELEC 9+ [or perhaps connman]

  • I owe an apology. At least a partial one. The router warranted more scrutiny.


    My phone disconnected and couldn't reconnect again last night. I found it odd that it always seemed to happen at night. It screamed 'scheduled job' to me. So I looked at the logs on my router and it was full of DNSMasq crashes. It kept populating the logs until I rebooted the router. It was complaining about running out of memory.


    The RPi3B+/LE8/Kodi17 was still connected though. The RPi4/LE9 would always drop its connection when this happened. This suggests it still has issues if earlier version don't drop connection in the same situation.


    Anyway, the issue with my router involved an Ad-Blocker function built into TomatoROM [custom ROM like DD-WRT] I've disabled it but feel good that this was a case that the block lists slowly grew to a point where it became too big for DNSMasq to handle.


    I already have two Pi-Hole DNS servers on my LAN and the router's ad-blocker was just a fall-back to catch any rogue clients that attempted to bypass my DNS servers. I'll be leaving it disabled and/or using static lists.